3 Replies Latest reply on Mar 9, 2010 4:59 PM by Larry G. Schneider

    Text editing problems in CS4

    sherri m.

      When I open a CS3 File in CS4, save it as a CS4 file, and then try to edit text, after a few minutes, I am unable to select, cut, paste, or move text because the insertion point is not accurate. I might select two letters, then paste something, and instead of pasting it where the two letters are selected, it appears several inches away from the selected text where it is supposed to go. See image I pasted below for an example showing the two letters selected (by) and the place it pasted the copied text (ty).

       

        • 1. Re: Text editing problems in CS4
          Mylenium Most Valuable Participant

          Attachments are disabled, so please provide the files from another hoster like flickr, imageshack or your own web site. regardless of this, I would check the text formatting and the appearance panel. Might well be that you have set some odd manuall tracking/ leading or applied an effect/ secondary appearance that interferes. Either it's these extra attributes that make things go wrong or the otehr way around, AI not carrying them across correctly.

           

          Mylenium

          • 2. Re: Text editing problems in CS4
            sherri m. Level 1

            Dear Mylenium,

             

            I don't have a website and don't use any of the others you suggested. 

            I will try to simulate the screen shot by reproducing it in text 

            below. In the words you see, the letters in red and in all capital 

            letters (EST) were the ones selected with the type tool. The letters 

            you see in blue caps (ED) were the ones on the clipboard that were 

            supposed to be pasted where the red letters to the left were selected. 

            As you can see, the pasted letters were not pasted where the text 

            selection was; rather they were pasted randomly several words down:

             

            "The people were humblEST in the days that followed andED all was 

            peaceful."

             

            Your "solution" is not a solution. I have tried removing all manual 

            text adjustments such as leading, tracking, and optical kerning and 

            setting all the text to default settings before working on the file in 

            CS4, but it still doesn't solve this problem. Eventually the I-Beam 

            just will not insert where you click with the type tool or double-

            click with the selection tool. There are no appearance features 

            applied, either.

             

            My point is that CS4 apparently does not support text files from CS3, 

            or any other CS version for that matter. I didn't have this problem 

            with CS versions 2-3 after the big CS jump to Open Type (which was 

            worth the sacrifice because of the huge improvements to text features; 

            plus, with the first CS version, you could still edit, insert, and 

            reformat the text from legacy files even if you lost some manual 

            adjustments). I see absolutely no improvements to text features in 

            CS4, and there is no reason a CS3 Illustrator file should not be able 

            to be updated and fully editable in CS4. None of your literature 

            advertising your upgrade to CS4 mentioned that we wouldn't be able to 

            work with text from our CS3 files in the upgrade, either. I consider 

            this a bug in the software that should be repaired.

             

            Can you please report the problem, and will Adobe fix it? This renders 

            all my previous Illustrator files pretty useless, and Adobe should fix 

            it. Why would I ever want to upgrade again if you do not support 

            previous Illustrator files, nor do you warn us that if we upgrade this 

            will be a limitation?

             

            Please reply to me and send this to the Adobe research and tech teams.

             

            Sherri

            • 3. Re: Text editing problems in CS4
              Larry G. Schneider Adobe Community Professional & MVP

              Can you give us some information on which operating system you are using? The problem you report is not something I have had a problem with in any of my files from as far back as AI7 which I can open and edit in AICS4 with no troubles. Please also note that this is a user-to-user forum. No one from Adobe officially monitors this forum. All help given here is voluntary by people who like to help others.