5 Replies Latest reply on Mar 12, 2010 10:27 AM by blipstation

    Phantom cue points injected by Encoder CS4

    blipstation Level 1

      This is a strange one. I am putting cue points into flvs via an xml file. Everything has been fine to date with hundreds of flvs using successfully this same technique. Today I exported another but there are odd cue points that are ruining the smooth running of the Flex video programme I have created for them to play in. These phantom cuepoints that don't exist in the xml file and are even there when I export to flv with NO cue points in them at all visible on the timeline!

       

      I do create cue points with the names of these phantom cuepoints manually often ("trafficFadeOut", "trafficFadeOut") in other sequences but they are definitely in these sequences. How did they get there?

      Why is Premiere somehow injecting them?

       

      someone help...

       

      ian

        • 1. Re: Phantom cue points injected by Encoder CS4
          Colin Brougham Level 6

          My guess would be that your project file got slightly corrupted, and is somehow retaining information from one sequence and associating it with another. A pretty standard response when Premiere project start behaving badly is to create a new project, and import your whole original project or select sequences from it into the new project. Many times, this will "refresh" the XML of the project file (that's really all PPro projects are) and will strip out any of the cruft that somehow accumulated during the editing process. Give it a shot and see if it fixes your situation.

           

          Also, purge your temp folder on your computer (you didn't indicate Mac or PC, so YMMV); exported projects are copied there, and you may have a case of some "leakage" going on.

          • 2. Re: Phantom cue points injected by Encoder CS4
            blipstation Level 1

            Colin,

            Thanks so much for the reply - it's good to know I suppose that project files can get 'cruft' and corrupted as it were. Unfortunately, I have now tried following your recommendations but with no success. I created a new project and imported the offending sequence but still those phantom cues came up. Then I cleared all the temp files and created a new project, imported again but there was the same random insertion of cues from elsewhere. Then I recontructed the whole sequence from stratch in yet another new project importing all the media assets again etc. Again no joy. Any other ideas anyone?

             

            This is very frustrating as I can't proceed with my project like this at all. The cue points are all essential to my project that synchronises media assets (see The People at www.blipstation.com).

             

            best

            ian

            • 3. Re: Phantom cue points injected by Encoder CS4
              Colin Brougham Level 6

              Hmm... that's really weird if you've created a new project and the cue points STILL show up. The only explanation I can think of, in this case, would be that there is something in the source files themselves that is triggering the addition of these unwanted cue points. Adobe software does add metadata to files, either in the files themselves, or if that's not possible, it's written into XMP "sidecar" files that follow the source files around.

               

              Can you describe what your source files are, where they come from, or how they're generated? My thought is that one application or another is automatically embedding those cue points, either at the point of authoring them originally or during import, and then they are "stuck" to the source file no matter what you try to do with it.

              • 4. Re: Phantom cue points injected by Encoder CS4
                blipstation Level 1

                The source files were shot on a Sony PMW EX1 which is an XDCAM format. I have used this footage without any problems until yesterday. The editing process is quite laborious and mechanical in a way. I produce subtitle, a sound effect cue points in XML through a Flex app I made and import the cue points from there before rendering. I repeat I have done this with over 400 sequences without any problem or phantom cues being inserted. Today I tried again.First with a new project and reconstructed the offending sequence yet again from scratch. I exported without any cue points on the timeline. I tested this in a simple Flash app that spits out the cue point names as they pass. I got three errant cues, namely 'poemStart', 'trafficFadeOut' and 'trafficFadeOut'. The first cue. poemStart, I used ages ago while developing the project and has been replaced by 'poem' so this is really an old cuepoint from about three months ago.

                 

                I then tried editing some fresh footage with the same methodology as before. This time no phantom cues at all ! This is good. However, I am very puzzled by the phantom cues in the sequences that I can't seem to get rid of. Maybe they could return and be randomly inserted again. This random behaviour is driving me nuts. Can I cut out the phantom cues with some app or other? I have had a look at the FLVInjector and the flvtool2 applications but they are quite limited in what they do.

                 

                Thanks for your continued attention, Colin btw...

                • 5. Re: Phantom cue points injected by Encoder CS4
                  blipstation Level 1

                  I spoke too soon about things returning to normal. I re-rendered the new sequence clearing the old cues to move them all a frame on. Result: double set of cues. When I render again having cleared all the cues, it still remembers the first set or are somehow embedded still in the sequence (or perhaps into the MP4 source - but they don't have flash points!)

                   

                  Any known bugs with clearing cues from sequences from within premiere? Could this also have to do with the lack of linking between my CS4 and the encoder which I have to bring out separately before I use the Adobe encoder within Premiere, else it does not render ie bring it up automatically from within Premiere itself?