6 Replies Latest reply on Mar 13, 2010 9:19 AM by C55279

    Reader took over computer

    C55279

      I just had the experience of Adobe Reader taking over the entire computer - assuming ownership over virtually every program, including Task Manager.  It happened when I downloaded and opened (rather, tried to open) a PDF receipt for a purchase I made.  It took several restarts before I was able to get to the point where I could even uninstall the program and regain access to the computer - even in Safe Mode I was unable to uninstall it.  The only information I gather from Event Viewer appears to be  "Audit events have been dropped by the transport. 0,"  that plus the host of difficulties caused by reader trying to run a large number of programs that it was never intended to run.  Quite frustrating!!   I have never experienced this kind of problem before, is there some way  to record the computers internal state of affairs while this is going  on?

        • 1. Re: Reader took over computer
          C55279 Level 1

          I'd like to add that when I try to install reader now, it again takes over most of the programs on the computer (the icons change to the Reader Icon).  The Event Viewer shows nothing unusual, but I'm at least able to uninstall Reader and continue using the computer.  The computer is a Dell XPS M1530, running Windows 7 Home Premium.  Microsoft Security Essentials found no problems on a quick scan just now, nor on the regularly scheduled one this morning;  I am currently doing the full scan...

          • 2. Re: Reader took over computer
            pwillener Level 8

            We have seen similar situations on Vista in the past, but we have never been able to figure out what causes it, or how to resolve it.

             

            Could you do the following (when Adobe Reader is installed): open a command prompt window and type

            assoc .exe

             

            What reply do you get from this?

            • 3. Re: Reader took over computer
              C55279 Level 1

              Unfortunately, when Reader is installed it takes ownership of the command

              prompt as well.  I get the error message to the effect of: This file doesn't

              have any valid program associated with it...  This message being in a window

              on top of a blank Reader window.  I tried to run the command prompt by

              mousing to the icon in Accessories; by typing in "Command" and choosing

              Command Prompt from the list, by typing cmd.exe in the search box on the

              Start menu, and also by typing in cmd.exe from the Run command line, all

              with the same result.   Same results from typing in assoc.exe in the Start Menu search box,  and the Run command line, etc. as above.

              However, I am able to right click on any Icon that

              has been replaced by the Reader Icon and look at the properties. In every

              case the program associated and the path to it are correct, even though

              clicking on the icon produces the above error message with the blank Reader

              window.

              Possibly related: when I tried to download a new version of Reader, to

              reduce the possibility that the install package had gotten some sort of

              malware, there were problems with Firefox v3.6 regarding installing a

              missing

              plug-in called gp.xpi.  Firefox said that I needed this plug-in to display

              all the content on the page, and initially didn't allow me to download

              Reader.  The instructions for Firefox users showed screens that I never saw

              and was unable to even find, rummaging around through the Options menus.

              After I attempted (unsuccessfully) to install that plug-in I was able to

              download Reader without a problem.  This happened last time I upgraded

              Reader, but that time I switched to IE browser and downloaded from there.  I

              vaguely recall there being some message to the effect that gp.xpi could not

              be located, near the start of the current fiasco.  Sorry to be so vague

              here.

               

              I note that other users have had problems installing this plug-in using

              Windows XP and Firefox 3.0, so this is probably a Firefox issue and may be

              unrelated to the problem at hand.

              • 4. Re: Reader took over computer
                Unclaimed

                Same here under XP Pro SP3; couldn't even boot the machine, as Reader tried to open all the processes and prevented them loading normally!

                 

                If you need a pdf reader anytime soon, you might consider using Foxit.   It works perfectly with Firefox 3.6.

                 

                This reader 9.3 is the crappiest piece of software engineering I've seen in a long time.  Just look at all the different issues in the forums.

                Really, Adobe, get your collective heads out.

                • 5. Re: Reader took over computer
                  ronamater60 Level 1

                  and Adobe personnel can't wait to fob you off to this forum which is trail

                  and error

                  • 6. Re: Reader took over computer
                    C55279 Level 1

                    Thanks! Foxit takes care of the need for Reader to access my PDF documents

                    quite nicely.

                     

                    If Adobe could use further information to correct the problem, here may be

                    another clue on the Reader issue: the error message that is generated after

                    Reader takes over all, or almost all (?) .exe programs is "This file does

                    not have a program associated with it for performing this action. Please

                    install a program or, if one is already installed, create an association in

                    the Default Programs control panel."  The header on this box, which I will

                    try to include as a jpeg attachment, reads: "C:\Program Files\Adobe\Reader

                    9.0\Eula.exe"  It may be worth noting that although the Lightroom icon on

                    the Quick start bar visible in the picture has not been replaced by the

                    Reader icon, Reader still tries to open the program.