4 Replies Latest reply on Jan 10, 2008 11:24 PM by kunjanos

    code assist gone

    Vertine Level 1
      usually, when i loose the code assist, there is a problem in my code or syntax...however, i don't know where i went wrong!!!. Worse, for example, Flex uses the yellow explanation sign to tell me i did not "type declare" a variable, but in fact, it is!

      what have i done wrong?
        • 1. Re: code assist gone
          Bill_Gong
          Can you post an example of some code where you're seeing this when you get a chance?

          Thanks,

          Bill Gong
          Adobe Flex Builder QA
          • 2. Re: code assist gone
            kunjanos
            Hi Bill,
            I have the same problem :( . The project was working fine on Flex 3 Beta 1, but starting with Beta 2 and Beta 3 the code hinting(assist) is available only for a few mx classes, and none of my classes :( The project compiles fine with SDK 2.0.1 hotfix 2 so I assume there are no errors.
            • 3. Re: code assist gone
              Peter Flynn (Adobe) Adobe Employee
              Can either of you pare down your project to a fairly simple, small setup that you are willing to post publicly? If so, then please file a bug at http://bugs.adobe.com/flex and attach a ZIP of this project. Please also include your FB log file (<your workspace>/.metadata/.log).

              Thanks!

              - Peter
              • 4. Re: code assist gone
                kunjanos Level 1
                Hi Peter.
                I can't post any of the code because of copyright stuff, but I investigated the issue and in my case I fount out the problem.
                When we started the project we worked with Flex 2.0.1 and used Tortoies SVN (file versioning system)(only our source files were added, none of the files created by flex for the workspace).
                When Flex 3 Beta 1 appeared, I installed Flex 3 beta 1, started flex and switched the workspace to the workspace created with Flex 2.0.1...so it worked just fine(code assist was ok).
                Because of windows xp errors, I had to reinstall my operating system, I also reinstalled Flex 3 beta 2, created workspace using flex 3 beta 2 and checked out the project files from SVN. Starting with this point my project did'n show code hinting, and here is why:
                - initially we created the project with flex 2.0.1, so all the classes were created in the main directory, or directories in the main directory
                - flex 3 beta 1, 2 and 3 creates the project and assumes that all the code is in the /src directory (src wasn't created by flex 2.0.1)
                - because our classes were in the root directory and subdirectories of the root directories, the newly created project couldn't find our classes because they were not in /src...so code hinting didn't work.
                After changing the Main Source Folder in Flex 3 beta 2/3 (Project -> Preferences -> Flex Build Path -> Main Source Folder) to point to our applications root directory instead of /src code assist started working.
                I didn't notice this thing before, because I was compiling the project with ANT using mxmlc, so even if flex beta 3 searched the source files in the /src directory, my project was compiled just fine because the ant know where my source files are.
                I hope this helps.

                Janos