5 Replies Latest reply on Mar 18, 2010 3:09 PM by chipsticks09

    Lightbox issues

    chipsticks09

      Hi,

       

      I am having some real problems getting the Lightbox to work on my site. I have it working on other sites so am pretty confident the files are all in the right place etc, but I am quite new to all this so... Any help would be greatly appreciated.

       

      The url's of where the lightbox should be below;

       

      http://www.keironecapstack.com/illustration/index.htm

       

      http://www.keironecapstack.com/comics/index.htm

       

      http://www.keironecapstack.com/kids_books/index.htm

       

      Help Please!

        • 1. Re: Lightbox issues
          osgood_ Level 8

          I think the paths to the img src are not correct. You have ../ infront of everyone. I do not know from that information where the 'images' folder is in relation to your site root folder.

           

          I would make sure the 'images' folder associated with the lightbox images is sitting directly in the site root folder then change the img src paths to as below:

           

           

          <a href="images/ills1.gif" rel="lightbox[images]"><img src="images/ills1_thumbnail.gif" alt="illustration 1" width="173" height="173" border="0" /></a>

          • 2. Re: Lightbox issues
            chipsticks09 Level 1

            Hi,

             

            Thanks for getting back to me again. I have tried your suggestion and it's not that. The images file is in the site root folder as long as I am not missing anything and the root folder is the folder that holds the entire site? The images folder is directly in this folder alongside the index page and templates, js and css folders etc. When I delete the ../ before the images the images are missing when I test the site. 

            • 3. Re: Lightbox issues
              John Waller Adobe Community Professional & MVP

              The paths to your js and css folders needs to be the same code as your images - with a "../" in front.

               

              <script type="text/javascript" src="js/prototype.js"></script>
              <script type="text/javascript" src="js/scriptaculous.js?load=effects,builder"></script>
              <script type="text/javascript" src="js/lightbox.js"></script>
              <link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen" />

               

              According to the code, the prototype file should be at

              http://www.keironecapstack.com/illustration/js/prototype.js

               

              but I get 404 File Not Found

               

              I can find it at:

              http://www.keironecapstack.com/js/prototype.js

               

              Thus, since your code starts in the "illustration" sub-directory, your code needs to be amended to go UP a level to the root directory to find the js and css folders:

               

              <script type="text/javascript" src="../js/prototype.js"></script>
              <script type="text/javascript" src="../js/scriptaculous.js?load=effects,builder"></script>
              <script type="text/javascript" src="../js/lightbox.js"></script>
              <link rel="stylesheet" href="../css/lightbox.css" type="text/css" media="screen" />

              • 4. Re: Lightbox issues
                hans-g. Adobe Community Professional & MVP

                Hi,

                 

                it's always a risk if the nesting is too wide. You should store the images a directory under the one in which lies, for example "comics" and then you put your images in a directory like comics/images.

                 

                Hans-G.

                • 5. Re: Lightbox issues
                  chipsticks09 Level 1

                  BRILLIANT!! thank you so much! I have been scratching my head about this for days, can't believe it was something so simple! Thanks again.