1 Reply Latest reply on Mar 19, 2010 5:42 AM by AdrianWiecek

    Layout help for a newb

    jeffel123

      Excuse me if this problem has an obvious answer but I am new to flex.


      Consider the following mxml


       

      <?xml version="1.0" encoding="utf-8"?>

      <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="vertical" verticalGap="0" paddingLeft="0" paddingRight="0"  paddingTop="0" paddingBottom="0">

      <mx:VBox backgroundColor="#FDE884"  paddingLeft="0" width="100%"  horizontalAlign="center" verticalGap="0" includeInLayout="true" visible="true">

              <mx:Text text="Message 1"/>

              <mx:Text text="Message 2"/>

              </mx:VBox>

              <mx:HBox width="100%"  >

              <mx:VBox width="30%" backgroundColor="#AE5E8D">

              <mx:Text text="Configuration Summary" fontSize="15" color="#FFFFFF"/>

              <mx:List  labelField="name"  width="100%"/>

              </mx:VBox>

              <mx:VBox width="70%" backgroundColor="#AE5E8D">

      <mx:Text text="Recent Activity" fontSize="18" color="#FFFFFF"/>

      <mx:DataGrid  rowCount="10"  width="100%" >

      </mx:DataGrid>

      <mx:Text text="Events" fontSize="18" color="#FFFFFF"/>

      <mx:DataGrid rowCount="10"  width="100%" >

      </mx:DataGrid>

      </mx:VBox>

              </mx:HBox>

      </mx:Application>

      When this renders I am left with a small gap on the left hand side of the browser.
      When I remove the text line <mx:Text text="Events" fontSize="18" color="#FFFFFF"/>
      It goes away.
      Can anyone tell me why this is?