11 Replies Latest reply on Sep 2, 2013 8:20 AM by Alliebu

    Can't create a text frame

    heinelg Level 1

      I started a new two page, two column document and added all the text id multiple text frames in both columns on p.1. When I try to create a text frame on p.2, I only can get the cursor in the upper left corner of p.w in the margin, not in the defined area of the document.


      Can anyone please give me a suggestion as to what I'm doing wrong?





        • 1. Re: Can't create a text frame
          [Jongware] Most Valuable Participant

          A text frame on your master page? That might be getting in the way if you are trying to draw a new frame.

          • 2. Re: Can't create a text frame
            heinelg Level 1



            No master page in this design. However, after positing the question, I was able to create a text frame in the right place. Don't have any idea what prevented it before.



            • 3. Re: Can't create a text frame
              Peter Spier Most Valuable Participant (Moderator)

              Every document uses a master page, even if you don't choose to add new objects to it. The default master page will have a text frame or frames fitting the defined columns structure if you check off the "Master Text Frame" box in the document setup dialog.


              It doesn't really sound like this is what is happening, though, in your particular case. A master frame would need to be overridden to interfere with creating a new frame on a document page. What it does sound like, though, is that you drew a frame to hold a background image or something similar that is filling the entire page area, but didn't actually put anything into that frame before trying to add your new text frame.


              By default, clicking with the text tool in any empty frame or shape converts it to a text frame. If you understand this behavior you learn to work with it pretty quickly, or you can change the setting in your preferences if you find it annoying.

              • 4. Re: Can't create a text frame
                heinelg Level 1

                Thanks, Peter,


                I did not select the "Master Text Frame" box when I created the new document, but I did draw a rectangle to set the background color on both sides of the page. I've just created another similar document and couldn't repeat the problem. I don't use InDesign frequently and I've had similar problems in the past and couldn't pinpoint why - your explanation makes sense and I'll check my preferences.


                Thanks again,



                • 5. Re: Can't create a text frame
                  j_depaoli Level 1

                  This can also happen if you are using a large rectangle filling the background and accidentally click on it with the text tool at some point (transforming it into a text frame). From there on out, InDesign will only give you a cursor, because it thinks that you're trying to edit the text within text frame, just like if you held your mouse over any ordinary text area. Check your layers panel to see if your background is labeled as a "text frame".

                  • 6. Re: Can't create a text frame
                    Sandee Cohen Adobe Community Professional

                    One silly little suggestion about this.


                    Under Preferences > Type, there is a setting that you can disable so that clicking with the text tool doesn't convert frames to text frames.


                    I tell my students, especially those migrating from XP, to deselect it.

                    • 7. Re: Can't create a text frame
                      Alliebu Level 1

                      I am having a similar problem and need some help:  I have made a rectangle in the middle of my document, colored it green, and am trying to add text (in white) on top of the green.  The text tool doesn't seem to function where the green rectangle is.  What should I do?  I am using InDesign CC.

                      • 8. Re: Can't create a text frame
                        JoaoCP Level 2

                        Right click the rectangle and choose "Content -> Text".


                        If you prefer to convert regular frames to text frames by clicking with the Text tool, go to "Preferences -> Type" and enable "Type Tool Converts Frames to Text Frames".

                        • 9. Re: Can't create a text frame
                          Peter Spier Most Valuable Participant (Moderator)

                          Are you trying to add a new text frame on top? If so, then most likely you have Text Wrap appled to your green rectangle.

                          • 10. Re: Can't create a text frame
                            BobLevine MVP & Adobe Community Professional

                            Sounds like you are very new to InDesign. I suggest you buy Sandee's Visual Quick Start Guide: http://amzn.to/14JHq54


                            You might also benefit from some quality time on Lynda.com. Here's a link for a free one week trial: http://bit.ly/RS0GXs

                            • 11. Re: Can't create a text frame
                              Alliebu Level 1

                              Yes, very new.  I am happy to report that I have completed the project (a book cover) over the course of 2 days, about 10 hours spent.  I am astonished that InDesign is user-friendly enough for me to do this. (I have -0- experience with Photoshop as well.)

                              Thank you, Forum people. I appreciate the friendly and positive replies to my obviously basic questions.

                              Really, I am amazed and very pleased with the CC possibilities.

                              I will do the Lynda.com course on InDesign and will watch Sandee's Visual Quick Start, umm, next.

                              The only "flaw' I am left with is this, and I will figure it out:  On the front cover, the author's name is in strange outlines & highlights.  I must have added a layer without knowing it because the pdf printed without the unwanted characteristics.

                              Kudos to Adobe.