2 Replies Latest reply on Mar 22, 2010 3:13 PM by cameron.michaelson

    Connecting To Zend AMF Backend Via HTTPS

    cameron.michaelson

      Environment:

      - Flash Builder 4

      - Flex 4 Beta 2

      - Zend AMF (the one that gets automatically downloaded in Flash Builder 4)

       

      Issue:

      Using Flash Builder's "Connect To PHP" wizard, I can connect to my Zend AMF backend via HTTP but not HTTPS (and yes, my domain does have a valid SSL certificate from a trusted CA - it is not self signed).  Upon selecting the PHP class (using a SFTP mount to my web host) via the wizard, Flash Builder dies when "introspecting the service" and it throws this error:

       

      Make sure that Zend Framework is installed correctly and  the parameter "amf.production" is not set to true in the amf_config.ini file  located in the project output folder.
      Warning:  require_once(Zend/Loader/Autoloader.php) [function.require-once]: failed to open stream:  No such file or directory in /home <blah>

       

      If I change my PHP backend's URL from https://<domain> to http://<domain> then it works but I obviously need to use SSL for this application.

        • 1. Re: Connecting To Zend AMF Backend Via HTTPS
          Wade Arnold

          That file has been depricated. Where did you get the PHP files from? In I would try upgrading to Zend Framework 1.10.

          • 2. Re: Connecting To Zend AMF Backend Via HTTPS
            cameron.michaelson Level 1

            I upgraded to Zend Framework 1.10, which didn't help.  I also just installed Flash Builder 4 Premium (which was just released today) and that didn't help my situation either although I believe the problem is how I'm attempting to get my Flex client to communicate to my hosted web server.

             

            All the examples I've seen demonstrate how to connect a flex client and PHP backend (via Zend AMF) to LOCALHOST.  I need to develop my Flex client on my laptop and hook into my PHP backend running on a hosted web server (not localhost).

             

            Here are my server properties:

            - Application server type = PHP

            - Server location:

                 - web root = Y:  (this maps to my Y: drive on windows which is a SFTP mount to my web host)

                 - root URL = https://cl21.<web_host>.com/~<username>

            - Output folder = Y:\<app>-debug

             

            I can get this to work if I use my dedicated domain name www.<my_domain>.com but I haven't yet purchased a dedicated IP and SSL certificate so I'm attempting to use my web host's shared SSL certificate (which is valid).  The problem seems to be related to the setting "root URL".  Can you not point the flex client to anything other than a root URL?  Most server-side development happens on a shared dev server (e.g. sandbox.company_name.com/developer1, sandbox.company_name.com/developer2, etc.)