0 Replies Latest reply on Mar 23, 2010 8:52 AM by NuckNuck

    IE7 and Multiple Embedded SWF Videos Not Working

    NuckNuck

      We have a page that contains 2 videos that are streamed from our media hosting company.  The code is fairly straightforward,

      <object type="application/x-shockwave-flash" data="http://xxx.xxx.xxx/your.swf" width="400" height="300">
      <param name="movie" value=http://xxx.xxx.xxx/your.swf"" />
      <param name="allowFullScreen" value="true" />
      <param name="wmode" value="transparent" />

      <param name="allowScriptAccess" value="always" />
      <param name="flashvars" value="streamer=rtmp://zzz.zzz.zzz/zzz.flv&autoplay=false" />
      </object>

      Similar code is used for the second video. The embed code is actually generated from the hosting company and has worked every time. Firefox and Chrome display both videos with no problem. However, IE7 only displays the second video. The first video just has white space where the video should be.

      I have used 'embed' tag and conditional object tags (for IE), rewritten the code from scratch, changed the z-index, used Flash to generate code, cleared the cache - all to no avail. Is IE7 incapable of having multiple SWF files on the same page?

       

      **I did notice that changing the autoplay attribute to true will allow for the video to display, however, the playback controls are not available.


      Any ideas on how to get this working in IE7?

       

      Thanks in advance