5 Replies Latest reply on May 27, 2010 7:18 AM by injpix

    Flex 4 Builder and WST Project

    Drakkon

      Using the newly released Flex Builder 4 I would like to install the Web Standards Tools (WST) Project along with the Eclipse XML editors and tools for Eclipse. This worked fine in the Beta and so i thought it would be no problem with the final. I am using the europa discovery site to draw from. The problem is I get many dependency incompatibilities:

       

      Cannot complete the install because of a conflicting dependency.
        Software being installed: Web Standard Tools (WST) Project 2.0.2.v200802150100-7C-7C8k0JWR293WFMOOObjNnnqho (org.eclipse.wst.feature.group 2.0.2.v200802150100-7C-7C8k0JWR293WFMOOObjNnnqho)
        Software currently installed: Adobe Flash Builder 4.0.0 (com.adobe.flexbuilder.standalone.product 4.0.0)
        Only one of the following can be installed at once:
          Core Runtime Plug-in Compatibility 3.2.0.v20090413 (org.eclipse.core.runtime.compatibility 3.2.0.v20090413)
          Core Runtime Plug-in Compatibility 3.2.0.v20071008 (org.eclipse.core.runtime.compatibility 3.2.0.v20071008)
          org.eclipse.core.runtime.compatibility 3.1.200.v20070502
        Cannot satisfy dependency:
          From: Adobe Flash Builder 4.0.0 (com.adobe.flexbuilder.standalone.product 4.0.0)
          To: org.eclipse.platform.feature.group [3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7]
        Cannot satisfy dependency:
          From: Eclipse Platform 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7 (org.eclipse.platform.feature.group 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7)
          To: org.eclipse.core.runtime.compatibility [3.2.0.v20090413]
        Cannot satisfy dependency:
          From: WST Common UI 2.0.2.v200802150100-7C5EH3E9RvTVnirrspVz0bmP7g8d (org.eclipse.wst.common_ui.feature.feature.group 2.0.2.v200802150100-7C5EH3E9RvTVnirrspVz0bmP7g8d)
          To: org.eclipse.core.runtime.compatibility [3.1.100,3.2.0)
        Cannot satisfy dependency:
          From: Web Standard Tools (WST) Project 2.0.2.v200802150100-7C-7C8k0JWR293WFMOOObjNnnqho (org.eclipse.wst.feature.group 2.0.2.v200802150100-7C-7C8k0JWR293WFMOOObjNnnqho)
          To: org.eclipse.wst.common_ui.feature.feature.group [2.0.2.v200802150100-7C5EH3E9RvTVnirrspVz0bmP7g8d]

       

      Is there any way to resolve these so I can edit XML and HTML files within Flash Builder 4 with the full power of these packages?