1 Reply Latest reply on Mar 26, 2010 6:10 AM by PPdump01

    The process cannot access the file because it is being used by another process

      I get this error every now and then when im trying to debug my AIR application.

       

      These are the step that cause this (including mood indicators):

       

      - Im happily developing my AIR application in Flash Builder 4

      - I want to see if my application works so i push the debug button

      - The console warns me that there is a little typo i my code

      - I edit the typo

      - Hit the debug button again

      - Console still displays the same error (Although i did fix the typo and saved my work)

      - I get frustrated and delete the entire code just to see if its actually still using the code im working on

      - Still the same error in the console (I become more and more frustrated, where is the debugger getting its code from????)

      - I look at my errors page and notice there is something using the SWF (The process cannot access the file because it is being used by another process)

      - I look at my running processes and see ADL.exe is still running (I DID terminate debug)

      - I force shutdown the ADL.exe process

      - I try to debug again, still the same error pointing to a line in my code that doesnt even exists anymore

      - I reboot the application and start the debugging again

      - Still saying that the SWF is used

      - I reboot my PC and can debug one or two times before getting this error again

       

      Please adobe people, help me out here before my mood turns out in to