6 Replies Latest reply on Mar 28, 2010 5:15 PM by cheftimo

    Adobe: are CF9 and CF Builder REQUIRED for FB 4 to work with ColdFusion?

    cheftimo Level 2

      Apparently a dumb question on the title, so let me explain why I am asking it (I use ColdFusion 8):

       

      I have looked at more than one article and sample app in the Developer Center and, when ColdFusion is mentioned – or required to do the sample app – I see several references to ColdFusion 9 and ColdFusion Builder.

       

      Furthermore, I have experienced several problems in trying to work with FB 4 Premium; here is a big one:

       

      The sample app provided in the Flash Builder start page did not work for me because I was unable to set up the data source in the CF Administrator from the Apache Derby Embedded database provided for the sample. I had the same problem with another sample app I found on the Adobe site. Yet, I have 3 other Apache Derby Embedded data sources that work fine – not only that, I deleted and re-created all three without any problems.

       

      I have another problem with the RDS Dataview not working in FB 4. That is in another thread I started yesterday, which, so far, has had 10 views and zero replies. That thread should be near this one because I just added some more information to it a few minutes ago.

       

      So far, FB4 Premium has proven useless for me.

       

      Any ideas?

       

      Carlos

        • 1. Re: Adobe: are CF9 and CF Builder REQUIRED for FB 4 to work with ColdFusion?
          JeffryHouser Level 4

          I am using Flash Builder Premium w/o any relation to ColdFusion.

           

          RDS DataView is not, to the best of my knowledge, part of Flash Builder.  It sounds like something that might be part of ColdFusion Builder; which [I thought] was included w/ Flash Builder Premium.  RDS is part of ColdFusion; and should not be needed for developing Flex Applications; although could be helpful in developing CFCs as part of a CF Application.

           

          I never looked at the sample apps, but it sounds like you're trying to test a sample app that requires CF.

          • 2. Re: Adobe: are CF9 and CF Builder REQUIRED for FB 4 to work with ColdFusion?
            cheftimo Level 2

            Hi Jeffry, from your “Community Professional” designation, I am assuming you are somehow associated with Adobe – right?

             

            RDS Dataview may not be part of Flash Builder (FB4) (it’s a bunch of extensions for Eclipse), but all the indications are that it should work in FB4 – otherwise, why would FB4 five you the option “RDS Configuration” in the Preferences panel?

             

            There are also a couple of pages in the FB4 Help with instructions on how to install those extensions if you are using CF8. I tried that, but got back an error message stating the operation could not be completed because of something having to do with dependencies. This is where I need help.

             

            I heard someone say that Flex is better than the Nature Channel because its bugs are so big and diverse. I guess it’s good to look at it that way to keep from going crazy.

             

            You are right when you say ColdFusion Builder is included in FB4. This is copied from the Adobe site page where you can buy FB4:

             

            Adobe Flash Builder 4 Premium Edition
            Adobe® Flash® Builder™ 4 Premium Edition software includes all features of Flash Builder 4 and adds professional testing tools, including profilers, network monitoring, an automated testing framework, integration with Flex® unit testing, and command line build support. It also includes Adobe ColdFusion® Builder™software.
            (Bold text emphasis mine).

             

            So I find it kind of interesting to see nothing about it in FB or at any time throughout its installation – which I have done three times trying to figure this out. I would really like to learn how/where to find it so I can try it.

             

            Any suggestions – from you or anyone else – about where to go from here would be highly appreciated.

             

            Best,

             

            Carlos

            • 3. Re: Adobe: are CF9 and CF Builder REQUIRED for FB 4 to work with ColdFusion?
              JeffryHouser Level 4

              cheftimo wrote:

               

               

              Hi Jeffry, from your “Community Professional” designation, I am assuming you are somehow associated with Adobe – right?

               


              Depends how you define Associated.  I am not an Adobe Employee.  Community Professional is a designation given to people who Adobe has deemed are a force for good in the technologies they use.  More info here: http://www.adobe.com/communities/professionals/

               

              I do have an RDS Configuration option in Flash Builder.  It must be part of the ColdFusion Extensions for Flex / Flash Builder.  I would have assumed they were rolled into ColdFusion Builder.  But, yes, there is no reason that I'm aware of that the extensions would not work in Flash Builder.

               

              I was able to set up one of my local CF8 instances for RDS access and the 'test connection' on the RDS Preferences panel said it connected okay.  I don't have an active project >3.2 to test further though.

              • 4. Re: Adobe: are CF9 and CF Builder REQUIRED for FB 4 to work with ColdFusion?
                cheftimo Level 2

                OK Jeffry, you are at the point to which everything works. Now, it would be great if you do this:

                 

                In FB4, go to Window > Other Views…

                 

                You will get a Show View panel with a tree of folders you can open from there – if you get an option for Adobe (that was the option containing the RDS configuration you did) or ColdFusion, with the RDS Dataview as one of the choices, your FB4 is working better than mine; if you don’t, now you know exactly what my problem is.

                 

                I would really appreciate it if you let me know what happens.

                 

                Regards,

                 

                Carlos

                • 5. Re: Adobe: are CF9 and CF Builder REQUIRED for FB 4 to work with ColdFusion?
                  JeffryHouser Level 4

                  I don't have any of those options in 'Other Views'.  No Adobe Category, no ColdFusion category, and no RDS Dataview.

                   

                  I suspect the option would be there if Ihad installed ColdFusion Builder or the CF Extensions; but I haven't.

                   

                  The "Adobe / RDS Configuration" option I did before was in preferences.

                  • 6. Re: Adobe: are CF9 and CF Builder REQUIRED for FB 4 to work with ColdFusion?
                    cheftimo Level 2

                    So your scenario is exactly the same as mine.

                     

                    I just got the ColdFusion Builder trial, installed it, and everything works fine, just like in my FB3.

                     

                    I have FB4 on trial also, so, if I decide to buy it, I’ll make sure I also get the included CF Builder.

                     

                    Thanks for the help.