2 Replies Latest reply on Apr 1, 2010 6:30 PM by nicholaslucas

    CS4 After Effects no longer loading after installing Office 08

    nicholaslucas

      During the christmas break I installed Office 08 and its seamed to have mucked something up in CS4 After effects because it won't load anymore, the program starts loading the libraries and all that stuff at the splash screen and crashes when loading User interface

       

      After effects worked fine before I installed office 08. Does anyone know what has happened and how to fix it? The strange thing is, it works on a couple of macs but the majority of the lab is having this problem.

       

      I have tried heaps of things:

      - Totally uninstalled office 08 and its preferences
      - Uninstall CS4 and manually remove all the preference files
      - Locate the fonts folders and comparing the fonts with that of a working mac
      - Creating a new login account
      - Updated to After effects 9.0.2

       

      After spending hours and hours and hours doing this, I have had no luck solving the issue. Help will be greatly appreciated... I will backup all the data and re-install Leopard next week if no-one knows how to fix this.

       

      Here is part of the error message that i have reported to adobe and haven't had a reply

       

      Process:         After Effects [139]

      Path:            /Applications/Adobe After Effects CS4/Adobe After Effects CS4.app/Contents/MacOS/After Effects

      Identifier:      com.adobe.AfterEffects

      Version:         9.0 (9.0)

      Code Type:       X86 (Native)

      Parent Process:  launchd [93]

       

      Interval Since Last Report:          204 sec

      Crashes Since Last Report:           1

      Per-App Interval Since Last Report:  148 sec

      Per-App Crashes Since Last Report:   1

       

      Date/Time:       2010-03-17 11:13:10.239 +1100

      OS Version:      Mac OS X 10.5.8 (9L31a)

      Report Version:  6

      Anonymous UUID:  93AB0F34-3CF9-41AE-A9E5-21738DB3269F

       

      Exception Type:  EXC_BAD_ACCESS (SIGABRT)

      Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000008

      Crashed Thread:  0

       

      Thread 0 Crashed:

      0   libSystem.B.dylib             0x91ccce42 __kill + 10

      1   libSystem.B.dylib             0x91d3f23a raise + 26

      2   libSystem.B.dylib             0x91d4b679 abort + 73

      3   U.dylib                       0x029a529f U_LoadFrameworkBundle + 671

      4   libSystem.B.dylib             0x91ccb2bb _sigtramp + 43

      5   com.macromedia.FLVExporter    0x2ba2ded5 FLVCore::Initialize(__CFBundle*) + 657

      6   com.macromedia.FLVExporter    0x2ba45c32 FLVExporter::FLVExporter(ComponentInstanceRecord*) + 130

      7   com.macromedia.FLVExporter    0x2ba46005 FLVExportOpen + 37

      8   com.macromedia.FLVExporter    0x2ba468ca FLVExportComponentDispatch + 130

      9   ...ple.CoreServices.CarbonCore 0x957b2935 CallComponentDispatch + 29

      10  ...ple.CoreServices.CarbonCore 0x957b2915 CallComponentOpen + 43

      11  ...ple.CoreServices.CarbonCore 0x957b0fb1 OpenAComponent + 449

      12  ...ple.CoreServices.CarbonCore 0x957b0dea OpenComponent + 24

      13  ...dobe.AfterEffects.framework 0x00fe574c FEE_GetMotionTrackCmdAttrs(long, bool, bool, long, char*, bool*) + 512746

      14  ...dobe.AfterEffects.framework 0x00fe58fb FEE_GetMotionTrackCmdAttrs(long, bool, bool, long, char*, bool*) + 513177

      15  ...dobe.AfterEffects.framework 0x00fe7d5c FEE_GetMotionTrackCmdAttrs(long, bool, bool, long, char*, bool*) + 522490

      16  ...dobe.AfterEffects.framework 0x00ce44db CEggApp::IEggApp(bool, bool, boost::function0<void, std::allocator<boost::function_base> >) + 17347

      17  ...dobe.AfterEffects.framework 0x00ce7e4d CEggApp::CEggApp(bool, bool, boost::function0<void, std::allocator<boost::function_base> >, long) + 919

      18  ...dobe.AfterEffects.framework 0x00ceb825 egg::dvainit::DVAConsoleEnabled() + 1809

      19  ...dobe.AfterEffects.framework 0x00cebc37 EggMain(bool, bool, bool, bool, bool, char*, bool, long) + 97

      20  com.adobe.AfterEffects        0x00005bc6 main + 1574

      21  com.adobe.AfterEffects        0x00004f62 _start + 216

      22  com.adobe.AfterEffects        0x00004e89 start + 41

       

      Thread 1:

      0   libSystem.B.dylib             0x91c8f9c6 kevent + 10

      1   libSystem.B.dylib             0x91c90155 _pthread_start + 321

      2   libSystem.B.dylib             0x91c90012 thread_start + 34

       

      Thread 2:

      0   libSystem.B.dylib             0x91c5f2ce semaphore_wait_signal_trap + 10

      1   libSystem.B.dylib             0x91c912c6 _pthread_cond_wait + 1267

      2   libSystem.B.dylib             0x91cd6539 pthread_cond_wait + 48

      3   com.adobe.amt.services        0x1f44e294 AMTConditionLock::LockWhenCondition(int) + 52

      4   com.adobe.amt.services        0x1f448bfa _AMTThreadedPCDService::PCDThreadWorker(_AMTThreadedPCDService*) + 130

      5   com.adobe.amt.services        0x1f44e379 AMTThread::Worker(void*) + 29

      6   libSystem.B.dylib             0x91c90155 _pthread_start + 321

      7   libSystem.B.dylib             0x91c90012 thread_start + 34

        • 1. Re: CS4 After Effects no longer loading after installing Office 08
          Tim Kurkoski Adobe Employee

          The failure appears to be in the FLV QuickTime component, which is an FLV exporter for QuickTime that Adobe Flash (or older Macromedia releases) installs into your [root]/Library/QuickTime folder.  After Effects loads any such component that QuickTime makes available (they appear under the File > Export menu).

           

          First, try deleting the com.macromedia.FLVExporter in your [username]/Library/Preferences folder, if present.  Failing that, pull out the FLV QuickTime component I described above.

           

          It is also theoretically possible that the failure is in the next component in the QuickTime components folder, not the FLV component.  You might could just pull out the entire contents of that folder and see what happens.

           

          -=TimK

          -=After Effects QE

          • 2. Re: CS4 After Effects no longer loading after installing Office 08
            nicholaslucas Level 1

            Tim you are a Legend.It was the FLV.component file in the [root]/Library/QuickTime folder.... It seamed to have been corrupted or something. I removed it and after effects loaded fine. Then i copied the FLV.component file from another mac that had a working after effects and copied it to all the macs that had that file removed.

             

            Thanks for your help, the error message did say FLV but when i went to preferences, there wasn't any macromedia.flvexporter files so i assumed that it wasn't the cause of the problem.