0 Replies Latest reply on Mar 29, 2010 5:07 AM by Thorgil

    problem with spry html dataset and XML in dreamweaver cs4

    Thorgil

      I have 2 problems with spry in Dreamwdeaver cs4. I hope someone can help me.

       

      I used spry xml databases before in CS3 without any problems, but now I wanted to try the new feature of the html-database linked dataset.

      I made an html-page with a simple database-table (ID: databank).

      I tried to add a spry interactive dataset on an other page, which didn't seem very complicated. I made a new interactive page based on this database but I always get several errors when I try to check out the result in live view or in firefox.

      I get the following errors in live view:

      failed to add 'spryregion1' as a 'dataSet observer!'

      failed to add 'spryregion2' as a 'dataSet observer!'

      Spry.Data.updateRegion(spryregion1) caught an exception: Type error:

      Value undefined (result of expression ds.getLoadDataRequestIsPe

      nding) is not object.

      Spry.Data.updateRegion(spryregion2) caught an exception: Type error:

      Value undefined (result of expression ds.getLoadDataRequestIsPe

      nding) is not object.

      In firefox the errormessages are a bit different:

      Here's the file in which the dataset is used.

      http://users.ugent.be/~apeleman/html-gegevensset.html

      Here you can see the file with the database:

      http://users.ugent.be/~apeleman/databank-appels-tabel.html

      I did follow the instructions of the adobe tutorial, and I even tried it with their own database, but still nothing works. Not even when I put all the files on the external server.

      Can anyone tell me what I'm doing wrong?

      Also, in CS3 I could easily use foto's in my xml-database (I just had to mark them as images when creating the dataset), and use them in the interactive database on the other page. But now, in CS4, when I create a new interactive page based on that same database, the xml-dataset doesn't show the images anymore, it just shows the image-datalink: {fotos}, unless I change the code myself and put the image-datalink  {fotos} in between image-tags (<img src="{fotos}" >. This isn't very practical. Is there another way of inserting foto's in the interactive page?
      The pages I made in CS3 are working perfectly.

      Thanks for any help