1 Reply Latest reply on Aug 27, 2011 12:40 AM by EddieMartinezLPS

    Change Flex server type back to none?

    24z.me

      I've imported a third party project into Flex Builder 3 and the project server type is configured to an application server. I want to revert it back to None, so that I can remove all info in Project Properties > Flex Server. However, I could not find any option to do so.

       

      Any idea?

        • 1. Re: Change Flex server type back to none?
          EddieMartinezLPS

          While converting several Applications, Modules, and AS Libraries (for a large Real Estate entity) I found myself confronted with the same issue that you have described. I tried several times to JUST REVERT back to the default Flex Server settings only to find that each time I reviewed my project properties again – there were the old server settings for the ASP server [that at this point did not exist].

          There are several ways to solve this, but the core of the issue is the fact that when coupling your application to an ASP or IIS type server your Flex Application will inherit URL references for RSL framework files and any other runtime references within that domain. Flex and Flash builder both keep cached references for file content (this is mainly due to history settings), so I found that modifying your project by editing the .flexProperties file could solve them problem. This is the only reference within adobe.com that I could find on the topic:
          http://livedocs.adobe.com/flex/3/html/help.html?content=data_3.html

          That documentation only describes setting not un-setting.

          Getting to the point – you should always be somewhat careful when modifying either
          .flexProperties or .actionScriptProperties file(s) since you can truncate your Application settings. So, keep it simple and just modify your .flexProperties File. You will find references to aspUseIIS, serverContextRoot, serverRootURL – these should be deleted, but you must keep both flexServerFeatures and flexServerType – and these references should then be set to 0.


          And that’s about it.