2 Replies Latest reply on May 10, 2010 11:52 AM by chris.s.jordan

    My whole app fails to run once exported.

    chris.s.jordan

      Okay, I posted earlier today about some trouble I was having with the ELS. The crux of the problem was that it worked great when I was running it from inside my IDE (Aptana), but once I exported the application, and installed it. It failed to work properly. It didn't give an error it just failed to work.

       

      That was yesterday (though I didn't post until this morning). Now, however, my entire app fails to run. Once installed, and executed, I can see the process in the Task Manager (running this on Vista Business), but the app does not start.

       

      I'll clarify that last point a bit. The application is just one that sits in the system tray and give the user access to a menu with a few functions on them. So, when the application loads properly, the icon will be sitting down in the system tray. This was happening yesterday (with the exported/installed app), but today it's not even doing that!

       

      However, I can still run the application perfectly from within Aptana! I am not understanding this. Someone please help me.

        • 1. Re: My whole app fails to run once exported.
          chris.s.jordan Level 1

          Okay, so my app is running again. Apparently changing the id of the app from com.something.blah.AppName to AppName, screwed stuff up. I'm still having the same trouble using ELS that I posted about the other day.

           

          So far, I'm not feelin' the love from the community. AIR on JavaScript seems to be the redheaded step child of AIR development.

          • 2. Re: My whole app fails to run once exported.
            chris.s.jordan Level 1

            Okay so I solved this. The problem was that I was using a jQuery plug-in (jquery.json.2-2.min.js) and it was improperly encoding the object that I was trying to store, so when I'd read the string out of the store, and try to deserialize it, I'd get an error, but I couldn't see this error until I ran the app using adl.exe from the command line.


            Anyway, just wanted folks to know in case it might ever help anyone else.


            On another note, I'm actually sorta surprised that AIR does not provide some JSON encoding/decoding capabilities given how seemingly ever present it is as a data transfer format.