1 Reply Latest reply on Apr 6, 2010 1:28 PM by Emilio Corsetti

    mark of the web/template problem

    Emilio Corsetti

      I created three Dreamweaver Templates for my site. I inserted the mark of the web code to each template to allow me to test and preview pages without the pop-up messages. All of my pages are about done and some pages using spry and SWF files weren't previewing properly in IE so I decided that it was time to remove the mark of the web code from the templates. As soon as I tried doing this I got a message about data outside the HTML tag and if I continue changes to pages based on this template will not occur unless you insert the following code <!--TemplateInfo CodeOutsideHTMLisLocked="true"-->.

       

      So I hit continue. I got a couple of other error messages telling me I did something wrong. I went back into my template and typed in the code Dreamweaver told me to enter. I saved the template and got some more errors. I didn't think to copy it all down at the time. So after all these nasty messages I'm not sure what's happened. So I make some changes to a horizontal spry menu and hit save. I get some more error messages about the changes will not affect pages based on the template. I have to cancel out of a couple of error dialog boxes. I load a few pages that were based on the template and see that none of the changes that I made to the spry menu on the template are reflected on the html pages created from the template.

       

      So I go into the template and try deleting all references to the mark of the web code. Then I try changing the CodeOutsideHTMLisLocked="true"--> to "false." That didn't work. Then I tried deleting the entire line <!--TemplateIinfo CodeOutsideHTMLisLocked="true"--> thinking that if I just got rid of all of it that it would fix my problem. No such luck.

       

      So now I start searching online for answers and I see some things about attaching and detaching templates. Okay, so maybe if I detach the template and then re-attach it everything will update. When I follow the instructions to do this I learn that the page is no longer attached to a template. That would explain why my changes in the template aren't updating the other pages. So then I try re-attaching the template. I open the assets panel, click on templates, select the template, and then click apply. Nothing. It won't let me attach a template. Template properties shows no template properties available.

       

      Here is some of the code from of a page based on the template two_column.dwt

       

      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml"><!-- InstanceBegin template="/Templates/two_column.dwt" codeOutsideHTMLIsLocked="false" -->
      <head>
      <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
      <!-- InstanceBeginEditable name="document_info" -->
      <title>ONA</title>
      <script src="Scripts/swfobject_modified.js" type="text/javascript"></script>
      <meta name="Description" content="This page contains images of some of the former employes of Overseas National Airways." />
      

       

      You can't see it the code I pasted but everything after 1999/xhtml is grayed out and you can't edit it.

       

      So now I'm totally confused and have no idea what I need to do to straighten this mess out.