3 Replies Latest reply on Oct 1, 2011 11:58 PM by Peter Grainge

    Open project was cancelled or the application was unable to load database error

    taplouff

      Good morning,

       

      I am currently on RoboHelp, version 8.0.2.208 and last week my laptop (XP OS) crashed. My IT department ran a repair disk program and since that time I receive the error message in the subject line when I attempt to open any XPJ file. We use RoboSource Control 3.1. I can access/see all of our projects when I go through RoboSource Control 3.1 Explorer. I have already uninstalled/reinstalled the Adobe Tech Communication Suite twice. I think my next move is to have our IT staff wipe my disk clean if I can't solve this problem in the next day or so. Appreciate any advice/feedback anyone has. Kind regards.

       

      roboHelp_error.png

        • 1. Re: Open project was cancelled or the application was unable to load database error
          RoboColum(n) Level 5

          Hi taplouff and welcome to the RH community.

           

          Before you do that, rename the project's .CPD file and try opening the project.

           


          • Read the RoboColum(n) for a tips, tricks and musings on the Technical Communication Suite products.
          • Follow the RoboColum(n) on Twitter
          • 2. Re: Open project was cancelled or the application was unable to load database error
            dcdavison

            This morning a coworker got the same error message. He had been working on his RH8 project yesterday with no problems. He was unaware of any changes to his PC, but our IT dept may have pushed some kind of update. To reproduce the error on my PC, I made a copy of an RH8 project and renamed the .cpd file. When I tried to open the .xpj, I received the same error. When I restored the .cpd file name, I continued getting the error--not only on that project, but also on ALL OTHER PROJECTS! (Unfortunately, I didn't try to open the project before renaming the file--and hadn't used RH at all today--so there may have been a problem for me even before I started to break things, and that might indicate an overnight PC update.)

             

            I tried several solutions (including deleting the .cpd and .xpj files, then trying to open the .hhp in RH8, as suggested on other sites). No luck. Then I attempted to create a new project (File>New>Project>Blank Project), but RH8 created only a handful of files in the new project folder, then stopped, without creating an .xpj and most other critical files.

             

            Since I also have RH5 installed on my PC, I created a new project in RH5, then converted it by opening the RH5 .xpj file in RH8. After RH8 converted the new project to the RH8 format, I was able to open the "corrupt" project in RH8, as well as all the other projects!

             

            The manifestation of the problem in all of my projects seems to indicate that there was a corruption in the RH8 application, not in the .cpd file. The app just needed to be "unstuck," then everything was OK. Nothing in the project had been lost at all.

             

            Since my coworker does not have RH5 installed, he was able to fix his situation by simply creating a new project in RH8.

            • 3. Re: Open project was cancelled or the application was unable to load database error
              Peter Grainge Adobe Community Professional (Moderator)

              Deleting the CPD is safe to do in any project but too many people think that deleting the XPJ can also be undertaken lightly. It can be deleted and RoboHelp will create a new one but not without losing a number of things that will need to be repaired, as described in Opening Projects on my site. Also it is not often deleting it achieves anything. Sometimes it is necessary but only when it has been established that it is the project that has a problem rather than RoboHelp itself.

               

              Thus the first thing to do always is establish whether the problem is with the project or RoboHelp. To do that work on your own project and one of the supplied sample projects. If that determines the project is the problem, you can happily delete the CPD but don't delete the XPJ until further down the line. What you lose when you delete that can be fixed but it should not be done in the same casual manner as with the CPD.

               

              BTW. Check all your RoboHelp 8 machines have the 802 patch applied as if not, you have more troubles ahead.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

              @petergrainge