8 Replies Latest reply on Mar 28, 2011 9:56 AM by tojo45

    Template misbehaving in RH 8

    LisaR18

      Hi all,

       

      We recently upgraded to RoboHelp 8 and updated to 8.0.2.208 and are experiencing serious problems with the templates in one of our three projects (the other two projects seem to be fine).

       

      Existing topics look fine until you either preview them or generate the help system (WebHelp). Then the contents of the template on which the topic is based are inserted at the top of the topic.

       

      New topics based on the template don't look right at all. The CSS is applied, except for the header style, but the topic is blank with no placeholder text inserted from the template. Again, if you preview the topic or generate the help system, the placeholder contents from the template are inserted at the top of the new topic, above anything you've typed.

       

      In the Output View, I get this message:

       

      Applying WebHelp 5.50 Template...
      ........................Template Error: can not resolve macro: WH_LNG_FtsMaxResult
      ...........................................................................
      Finished applying Template in 3 sec(s)

       

      Does anyone know what this means and how to fix it?

       

      The only other fix I can think of would be to just delete our templates and not use them, but they are rather handy....

       

      Thank you advance for any help....

      Lisa

        • 1. Re: Template misbehaving in RH 8
          Peter Grainge Adobe Community Professional (Moderator)

          I just searched on WH_LNG_FtsMaxResult and got three hits.

           

          One included this link. http://kb2.adobe.com/cps/507/cpsid_50701.html Try that first.

           


          See www.grainge.org for RoboHelp and Authoring tips

           

          @petergrainge

          • 2. Re: Template misbehaving in RH 8
            LisaR18 Level 1

            Hi Peter,

             

            Thank you for your response. Before you answered, I did this:

             

            1. File | Project Settings
            2. Advanced button
            3. LNG File tab
            4. Made no changes, just clicked OK.

            The !language!.fpj file appeared in my File Status tab, and it wasn't there before. (I could find no mention of an LNG file anywhere in my project files.) This did not fix the problem with the template content being inserted above the topic text, but it did make the WH_LNG_FtsMaxResult error go away.

             

            I think these were two different problems, because I ended up trying the two solutions in the first solution you listed, to no avail. Copying the LNG file did nothing and changing the language for the project settings did nothing. I'm still having a problem with the template content being inserted. I looked in your website and could find no mention of either the error or the problem. I was unable to load your twitter page for which you sent links.

             

            Again, I think these were two separate problems. The WH_LNG problem seems fixed now, but the template is still being inserted above my topic text.

             

            Any other ideas?

             

            Thanks,

            Lisa

            • 3. Re: Template misbehaving in RH 8
              Peter Grainge Adobe Community Professional (Moderator)

              Maybe someone else has seen the template problem or has some ideas. Let's wait until tomorrow when more people will be around.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

              @petergrainge

              • 4. Re: Template misbehaving in RH 8
                RoboColum(n) Level 5

                Have you tried, creating a new template and applying that to your topics. We had similar problems with a RHX5 template that was upgraded to a RH8 master page. It had a table in the footer ith images in cells which proved to be the problem. This may not be the case for you but recreating may unclog the problem. Worth a try.

                 


                • Read the RoboColum(n) for a tips, tricks and musings on the Technical Communication Suite products.
                • Follow the RoboColum(n) on Twitter
                • 5. Re: Template misbehaving in RH 8
                  LisaR18 Level 1

                  Colum and Peter, thank you both for your responses.

                   

                  Colum, I believe you are correct about templates with tables. We have one of our three templates that contains a table. I'm not sure why all of the templates were affected and not just that one; maybe the presence of a table in one befuddled it for all.

                   

                  At any rate, for posterity here in case anyone else encounters this: This entire master page thing is new to me, but it seems that, in RH 8, template content should be contained in a "body placeholder." Our problem was that RH 8 didn't put put the content into a body placeholder during the conversion. As a result, the template content did not appear in new topics, and in existing topics, it was inserted above the topic content when you previewed or generated help. (According to RH's help system, this is working as designed, although I find it clumsy and confusing.)

                   

                  To fix this problem, I went into each template and inserted a body placeholder (in a new paragraph, right-click and select Insert Placeholder | Body), and then copied and pasted all of my template content inside the placeholder box.

                   

                  All seems to be working correctly now. Many thanks again!

                   

                  Lisa

                  • 6. Re: Template misbehaving in RH 8
                    kmaddox1 Level 1

                    Hey Lisa, Thanks for taking the time to document your fix. I couldn't figure out why the boillerplate text from my master pages was appearing on every page in the generated help. Your instructions worked like a charm, fixed the problem in no time! (Interestingly, this only occurred on one of my imported projects, even though they were derived from the same RH7 help system. Go figure...)

                     

                    kathy

                    • 7. Re: Template misbehaving in RH 8
                      LisaR18 Level 1

                      Kathy,

                       

                      You're welcome! I'm very happy it worked out for you and that you found my instructions helpful.

                       

                      Best regards,

                      Lisa

                      • 8. Re: Template misbehaving in RH 8
                        tojo45 Level 1

                        I was getting the same error and following the steps in this post got rid of the error.   Strange to me, but easy.  Glad I found this posting.

                         

                        Joe