4 Replies Latest reply on Sep 6, 2007 11:11 AM by Rylee3

    HH_GET_WIN_TYPE has not been specified

    Rylee3
      I have Version 5.0.2 build 801. In the last two projects I have compiled, I receive the above message when trying to access Help using F1 and the Help button in the software. I did not have any extra spaces in the window name as suggested by the tech. The .chm file works fine on all developers machines, just not on mine which has RoboHelp installed
        • 1. Re: HH_GET_WIN_TYPE has not been specified
          RoboColum(n) Level 5
          Hi Rylee3 and welcome to the RH community. Try renaming your window with a prefix of $global_ and recompile. It is standard practice for all my windows now as it solves many problems regardless of whether I'm using merged files. I suspect you are?
          • 2. Re: HH_GET_WIN_TYPE has not been specified
            Rylee3 Level 1
            Thank you for your reply. I tried the above suggestion and it did not work. I guess I need to explain a little further. I have a new laptop. Windows version is the same. I do not get this message on the old laptop and no one else gets this message when they load the .chm file into our software programs. Just on this computer. The strange part is that I have other projects that do not give me this message. Please let me know if you need more information regarding this computer setup. I am beginning to believe it is some setting on this new laptop. The actual message is The Window name :TopicWin" passed to HH_GET_WIN_TYPE has not been specified. Then it hangs up with the hourglass and I have to stop the program through the Task Manager. Thank you again for your help
            • 3. Re: HH_GET_WIN_TYPE has not been specified
              Rylee3 Level 1
              One more note: Our developer experimented by loading RoboHelp 5.0 on one of our swappable machines. The .chm file worked prior to loading and received the message after installing RoboHelp. This was his reply: So, it looks like Robohelp replaces(?) the standard HTMLHelp engine or adds its own stuff ..
              I am assuming that CR and UB CHM-files were made with this version of Robohelp and this is why they are affected.
              • 4. Re: HH_GET_WIN_TYPE has not been specified
                Rylee3 Level 1
                I have fixed this. I actually had to add a New Window and then deleted the other "TopicWin" and created it again. I have no idea why this happened, because it works on the other machine without the change. Thanks for your help