4 Replies Latest reply on Apr 12, 2010 9:55 AM by Adam Cameron.

    Autocomplete slow

    Adam Cameron. Level 5

      G'day

      When one keys in a partial tag, one can press CTRL-SPACE to complete the tag, eg typing:

       

      <cffuCTRL-SPACE

       

      will complete the <cffunction> tag. Cool.

       

      However it takes CFB about 1-1.5sec to actually react to this, during which time if one keeps typing, the tag is never completed.  And to be frank, I could have simply typed the rest of the tag name in less time than that.  So using this feature makes for very stilted development.

       

      I would expect to be able to type this - at full speed without any pausing for CFB to work out what it needs to do:

      <cffuCTRL-SPACEnCTRL-SPACEmyFunctionRIGHT-ARROW acCTRL-SPACE puCTRL-SPACE RIGHT-ARROWoCTRL-SPACEfaCTRL-SPACE RIGHT-ARROW hiCTRL-SPACEHere's my hint

       

      and end up with:

      <cffunction name="myFunction" access="public" output="false" hint="Here's my hint">

       

      However I just get this:

      <cffu n myFunction ac pu o fa hi Here's my hint

       

      (or something like that, you get my drift).

       

      Are other people finding this tag too?  I don't think my machine is under-spec'ed for the task here... it's quite happily running Open BlueDragon, CF9, MySQL (+ MySQL Manager and Query Browser), Tomcat, Apache, Firefox, Skype... [etc] simultaneously, and none of them seem to be slow.

       

       

      Another thing related to this (kinda).  I have "automatically insert single proposals" (or whatever it is) switched on, which is quite handy.  However when I type in:

       

      <cfsavCTRL-SPACE

       

      I might expect to get this as a result:

      <cfsavecontent variable="|">

       

      (Where the | is the cursor).  Because <cfsavecontent> has only the one attribute option, and it's required.  It'd be good if CFB was savvy enough to grasp this.

       


      Comment?

       

      --

      Adam

        • 1. Re: Autocomplete slow
          tony.garcia

          I used to think that autocomplete was slow until I found out that the delay is configurable. If you go to:

           

          Preferences > ColdFusion > Editor Profiles > Editor > Code Assist

           

          You'll see a setting named "Delay before code assist (in milliseconds)"

          I set it to 100 and it's a lot zippier now.

          Did you check this setting?

          • 2. Re: Autocomplete slow
            Adam Cameron. Level 5

            Isn't that just the delay for the automatic code completion?  I mean as opposed to triggering the code completion with CTRL-SPACE as I am doing.

             

            It's difficult to tell, but I guess it could be slightly faster when I decrease the setting from 2500 to 100.  Although it could be because I am editing  amuch smaller file than I was last week.

             

            However I am uncertain about this remedy because it's certainly not taking 2.5sec to do the completion when I press CTRL-SPACE, so I do not see the connection between the setting value and the delay here.  Plus it makes no sense to add a delay there anyhow: it makes sense before anything happens automatically (and it drives me up the wall when CFB tries to help me when I type without me asking it to); but it makes no sense for there to be a delay after I've explicitly keyed CTRL-SPACE to tell CFB "complete this please".

             

            I guess once I get back to my project work (in the larger files), I'll pay more attention to the completion speed.

             

            Cheers for your suggestion though!

             

            --

            Adam

            • 3. Re: Autocomplete slow
              tonygar

              Whoops! Yeah, you're right. That setting is for the code assist, not the autocomplete. My bad!

              And yes -- I've also noticed that sometimes the autocomplete is slow but I didn't make note of whether it was only with large files or not. I'll report back if I have anything more to add.

              • 4. Re: Autocomplete slow
                Adam Cameron. Level 5

                I guess once I get back to my project work (in the larger files), I'll pay more attention to the completion speed.

                 

                 

                Any performance differences I perceived earlier certainly were not perceptable once I returned to working in large files.

                 

                --

                Adam