1 Reply Latest reply on Apr 8, 2010 10:53 PM by matzeller

    Issue when tyring to load SWF Module inside a Flex Tile(mc:Tile)

    Shyam Sundar.A

      Hi,

       

           When i try to load an existing SWF Module inside a Flex Tile using ModuleLoader/ModuleManager (mc:Tile) and trying to run the application using mosaic, I am getting the following error:

       

      VerifyError: Error #1053: Illegal override of FlexModuleFactory in mx.core.FlexModuleFactory.

       

          at global$init()

       

      However, when i add the TileSDK.swc to the flex project and build the swf and load this swf inside  inside a Flex Tile, the application works fine in mosaic.

       

      But, i having a SWF provided by a third party for which i not having the source code and i want to load this inside a Flex Tile, but i am geeting the above error. Can u explain why this is happening and any workaround?

       

      I also made the following observations:

       

      Type   of SWF to be loaded inside a Tile

      With/Without   SDK

      Pass/Fail

      mx:Application

      WITHOUT

      Fail

      mx:Application

      WITH

      Fail

      mx:Module

      Without

      Fail

      Mx:Module

      With

      Pass

      Mc:ModuleTile

      with

      Pass

      Mc:Tile

      with

      Fail

       

      Thanks and Regards,

      Shyam Sundar.A

      ashok.shyamsundar@gmail.com

        • 1. Re: Issue when tyring to load SWF Module inside a Flex Tile(mc:Tile)
          matzeller

          Hello,

          a Module Tile (.swc) needs to be compiled with the same version of the Flex SDK like the Mosaic framework. The current version Mosaic 9.0 is compiled with Flex SDK 3.4. Do you know if the SWF Module was compiled with SDK 3.4? Application tiles (.swf) can be compiled with different version of the Flex SDK (3.3 and 3.4).

          We recommend to use Application tiles whenever possible and use Module tiles only as an exception (since Module tiles need to compiled with a specific version of the SDK).

           

          Hope that helps,

           

          Matthias Zeller