6 Replies Latest reply on Nov 3, 2011 8:38 AM by MurraySummers

    Blank spaces in code view

    alpsrn2010

      Hello,

       

      Whenever I copy and paste text from another website -- sometimes from my own website after it goes live -- onto Dreamweaver, the text looks just fine in Design view. Fonts and paragraphs are preserved, as they're supposed to according to my preferences.

       

      However, when I look at the code view, there are always several -- sometimes a whole lot of -- blank spaces separating words; blank spaces that were not in the original text (even in code view) and that can't be detected in Dreamweaver's design view.

       

      It looks ok online just like it looks ok in Dreamweaver's design view, but I'm just a little concerned that those blank spaces may confuse search engine crawlers.

       

      For instance. In design view and online, one sees:

       

      "Great Holiday"

       

      but in the code view/source page you'll see

       

      "Great                    Holiday"

       

      That's what the crawlers and spiders will see as well. And they may think that "Great Holiday" and "Great                    Holiday" are two different sets of keywords when they should be the same.

       

      How can I ensure that only *one* blank space is allowed in Dreamweaver's code view, whenever I copy and paste text from webpages? Is there a way that I can preserve the texts' format and fonts while ensuring *one* blank space in code view?

       

      Any suggestions would be much appreciated.

        • 1. Re: Blank spaces in code view
          hans-g. Adobe Community Professional & MVP

          Hi,

           

          could it be you think about that: <p> here should you read that what we cannot see in your letter</p>? To explain:

           

          &nbsp; means non breaking space - a space without simultaneous line break. As you can see, we don't see anything and so
          I use spaces between my letters: <p>& n b sp;</p>

           

          If you want to delete them (controled) in the source code it ually doesn't hurt.

           

          Hans-G.

          • 2. Re: Blank spaces in code view
            alpsrn2010 Level 1

            Hans, thanks for the response.

             

            But it's actually just a blank space in code view as well.

            There's no particular code that causes the space between words.

            It's just there whenever I copy text from a website (even my own).

             

            I was wondering if there's a command that will allow me to set a maximum of *one* blank space in code view.

             

            That way...

             

            "Great Holiday" would always look like "Great Holiday" -- and not "Great                      Holiday" (in code view)

             

            Thanks again for the response.

            • 3. Re: Blank spaces in code view
              hans-g. Adobe Community Professional & MVP

              Hi,

               

              do we talk about tabs?:

               

              dr.jpg

              If not it would be better you would send a link to your website.

               

              Hans-G.

              • 4. Re: Blank spaces in code view
                alpsrn2010 Level 1

                No, actually this is what happens:

                If one of us copies text from our blog online (www.altfg.com/blog/) we see the following in Dreamweaver's design view:


                Right behind Clash of the Titans, DreamWorks Animation’s How to Train Your Dragon, featuring the voices of Jay Baruchel, Gerard Butler, and

                America Ferrera, earned $3.8 million (+9.2%) domestically on Thursday,

                 

                 

                but in code view there are blank spaces between words. Blank spaces that shouldn't be there:

                 

                 

                 

                <p>Right behind <em><strong><a href=

                "http://www.altfg.com/blog/movies-431/clash-of-the-titans-box-office-predictions/"

                >Clash       of the Titans</a></strong></em>, DreamWorks Animation’s <em>How to   Train Your Dragon</em>, featuring     the voices of <strong>Jay Baruchel</strong>,<strong> <a href=

                "http://www.altfg.com/blog/photos/bradley-cooper-gerard-butler-andrew-r-jones-810/"

                >Gerard       Butler</a></strong>, and <strong>America Ferrera</strong>, earned     $3.8 million (+9.2%) domestically on Thursday, </p>

                 

                 

                 

                Notice the blank spaces separating "featuring      the voices" or "Gerard       Butler." Those shouldn't be there. Maybe it makes no difference. On the browsers, it all looks fine. But is there a way to ensure that Dreamweaver doesn't allow more than one blank space between words in code view?

                 

                 

                Also, *no one* has responded to my query about automatic hyperlinks for images. Any ideas?

                That has been such a drag.

                 

                 

                 

                http://forums.adobe.com/thread/613801?tstart=30

                 

                 

                Thank you.

                • 5. Re: Blank spaces in code view
                  JillTW Level 1

                  I'm having this same problem in DW5.5 running on Windows XP. Pasting into Design View throws in multiple series of usually 2 spaces in Code View. I've tried fiddling with Edit > Preferences > Copy/Paste but the only thing that works is using "Paste Special" and selecting Text Only. This isn't good because if I'm pasting multiple paragraphs with embedded links I lose all the links, paragraphs, bolding, etc.

                   

                  Any ideas of what to set to cause these extra spaces to not appear?

                  • 6. Re: Blank spaces in code view
                    MurraySummers Level 8

                    The spaces are in the material you have copied.  Your only choice is to remove them after the paste.