16 Replies Latest reply on Apr 10, 2010 9:21 AM by zannie13

    "Put" issues

    zannie13

      I do hope someone can help me. I have been thru adobe support, dreamweaver, other forums, etc.


       

      I have two sites that I work on and use Dreamweaver for both. One site (appliedtaiji.com) will not update files, all of a sudden. There are two people who work on this site and I can't figure out why it will not update now. I added paypal buttons and they were working fine, now only one of them works. They work from my computer (C:) files, but dreamweaver will not update from either of our computers. The second site (taijicommunity.com) updates fine so I know it is an issue with the appliedtaiji.com site, but I can't find what is causing it. Can you help?

      Thank you,

      Suzanne

        • 1. Re: "Put" issues
          pziecina Level 6

          Hi

           

          What does your ftp log say? What if any error messages are you getting?

           

          Have you tried a 'stand alone' ftp program or the extension 'FireFTP' for firefox?

           

          PZ

          www.pziecina.com

          1 person found this helpful
          • 2. Re: "Put" issues
            zannie13 Level 1

            Thank you for your prompt reply, I appreciate it very much.

             

            It says the put was successful, but it is not showing the updates on the site. I do not know what the extension FireFTP is. I have to admit I am a rookie and just learning as I go along, but the site  and the paypal buttons were all working fine and I am not sure if the other person has done something to make most of the buttons stop working or what happened. Also it will not update the template either. I tried to get help with the template issue a while back and never got it fixed, so I detached the template from all pages. I just do not understand what happened.

            • 3. Re: "Put" issues
              pziecina Level 6

              Hi

               

              FireFTP is a free extension for the firefox browser, (link to download - http://fireftp.mozdev.org/). Personally I prefer not to use templates as they can cause too many problems and quickly make a sites customization unworkable.

               

              Examine the code on your sites live pages and compare this with what you have in dreamweaver, (don't forget to clear your browser cache and refresh the page first). If it is still showing the old code on the live site try using the FireFTP to upload a page to your site. If this works then it may be an access issue, (password/username, site definition, (wrong folder, etc)) problem in your settings.

               

              As for the paypal buttons, can you post a link to a page with the problem?

               

              PZ

              • 4. Re: "Put" issues
                zannie13 Level 1

                Hey thanks again

                 

                Here is the link to the buttons, only the first one is working now. Meanwhile I will be checking out your suggestions. 

                 

                Suzanne

                • 5. Re: "Put" issues
                  pziecina Level 6

                  Hi Suzanne

                   

                  Sorry but the link is missing, can you repost?

                   

                  PZ

                  • 6. Re: "Put" issues
                    zannie13 Level 1

                    So sorry, one day I will learn to paste the link first. How embarrassing 

                     

                     

                    http://www.appliedtaiji.com/INSTCertification.html#C9

                    • 7. Re: "Put" issues
                      pziecina Level 6

                      Hi

                       

                      The paypal buttons that are not working correctly all have this line -

                      <input type="hidden" name="cmd2" value="_s-xclick" />

                       

                      Try changing this to -

                      <input type="hidden" name="cmd" value="_s-xclick" />

                       

                      PZ

                      • 8. Re: "Put" issues
                        zannie13 Level 1

                        I am using Dreamwever CS4 and here is the code for one of the nonworking buttons in Dreamweaver...

                         

                         




                         

                         

                        </form>

                         

                        I have looked at the other non working buttons and they all have this code (different id number).

                        • 9. Re: "Put" issues
                          pziecina Level 6

                          Hi

                           

                          Sorry but no code is in the post

                           

                          PZ

                          1 person found this helpful
                          • 10. Re: "Put" issues
                            zannie13 Level 1

                             

                            That was weird, because I actually rememberd to paste the link in the email. This time I am trying it from the post instead of an email. LOL

                             

                             

                            <form target="paypal" action="https://www.paypal.com/cgi-bin/webscr" method="post"> <input type="hidden" name="cmd" value="_s-xclick" /> <input type="hidden" name="hosted_button_id" value="8ZGVWZ3RYN2UJ" /> <input type="image" src="https://www.paypal.com/en_US/i/btn/btn_cart_SM.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!" /> <img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /> </form>

                            • 11. Re: "Put" issues
                              pziecina Level 6

                              Hi

                               

                              The code shows that you are using an encrypted button, ( _s-xclick and the encrypt code 8ZGVWZ3RYN2UJ ) which is defined in your paypal account is this correct?

                               

                              Also this is a 'Buy Now' button is this also correct?

                               

                              PZ

                              • 12. Re: "Put" issues
                                zannie13 Level 1

                                They are Paypal "add to cart" buttons and I copied the codes and pasted them in just like they said. They were all working for about a month and then while someone else was working on the site, we started having the update issues with the template and then noticed the buttons stopped working.

                                • 13. Re: "Put" issues
                                  pziecina Level 6

                                  Hi

                                   

                                  The code has probably been reinserted by the other person and they have not checked it once inserted.

                                   

                                  Unfortunately the only way to fix the paypal button code is to 're-generate' the code on the paypal site and reinsert into dreamweaver, before doing so check that your dreamweaver preferences are set correctly so it does not modify the code -


                                  1. Open your website in  Dreamweaver
                                  2. Click "Edit"
                                  3. Click "Preferences"
                                  4. Under  "General", deselect "Rename Form Items When Pasting" - for Dreamweaver  MX, this option is located under "Code Rewriting".

                                   

                                  Also check in your site definition that they have not enabled check-in/check-out of files as this would explain your file upload problems.

                                   

                                  PZ

                                  • 14. Re: "Put" issues
                                    zannie13 Level 1

                                    Ok thanks again. I am away from my puter right now but should be back 

                                    to check these in a few hours. Thanks for hanging in there with me. 

                                     

                                    Suzanne

                                     

                                    Sent from my iPhone

                                    • 15. Re: "Put" issues
                                      zannie13 Level 1

                                      Nope, non of that worked either. She hasn't been working on the site since we had the first sign of trouble.

                                       

                                      The code is correct, I just can't get my files updated in Dreamweaver. I check the preferences and deselected and refreshed and tried the "put" option again... Nothing. HELP!!!

                                      • 16. Re: "Put" issues
                                        zannie13 Level 1

                                        It seems to be an issue with Dreamweaver, so I am guessing that it in the settings somewhere. I checked with the other person and she hasn't touched it since the issues began. She doesn't have any files checked out so I have no clue what to try next. Any suggestions would be GREATLY APPRECIATED.