11 Replies Latest reply on Oct 25, 2007 1:13 PM by lmarden

    new to v6 BLUES

    lmarden Level 2
      To be fair, I didn't think about the fact that we have a major release ready to roll any day now before I decided to load the v6 upgrade. After all, it's been several months since v6 was put out there - shouldn't be any major issues, right?

      Uh huh.

      Had the problem with the .dll error when trying to generate the Help chm, but not until after a few application errors just trying to navigate around. So yes, I read Peter's Snippets. And yes, uninstalled / reinstalled / copied in the replacement .dlls. Went back in, had a corrupt CPD. Tried twice to rebuild it - both times the rebuild pooped out about half way. Had to import several hundred topics from a backup location I am still looking back at with longing and desire. And of course, problem number whatevah - the topic titles for almost all of the topics I had to import are now the file titles. And yes, I had already replaced the MDBMS.dll file before importing.

      So here's the issue - I now have several hundred topics that have their file name displayed as their title. Has anyone found a simpler way to correct them all than one at a time? Because I have already received an Out of Memory error doing this - on a PC with 2GB RAM and nothing else open but Outlook. I am scared to death that I am going to get another error that will corrupt something and I will have to start all over.

      So, send hugs and solutions this way, if you can spare them. I would REALLY like to get out of this swamp so I can move on to the last minute updates for the release.
        • 1. Re: new to v6 BLUES
          lmarden Level 2
          oh - and another thing - on the files that I had to import, none of them retained their Template, which was the same as used in the previous version, and is in use in the new one. So, trying to correct all those template selections from NONE to STD (standard) is a HOOT. When I try to mass assign in the Topics Pane, it frequently says the change has been made. But when I go into individual topics, NOPE. Or even more funner, sometimes the mass assign assigns to the other template I use called TN. And yes, I may be over 40 but I have 20/10 vision - I am selecting the correct template!!

          If you are out of hugs or answers, a pitcher of margaritas would do the trick too.
          • 2. Re: new to v6 BLUES
            Gravenstein Level 2
            I have a couple of suggestions:

            1. Regarding the cpd rebuild problem, you might find it helpful to replace the rhvariable.apj file. There appears to be a bug in how RH deals with rhvariable.apj during the X5 to RH6 project conversion, and the resulting problem is that the cpd file decides it's corrupted and won't rebuild. As a fix, you can either create a user-defined variable within RH (assuming that you can get the project open), or you can replace your existing rhvariable.apj file with a known good one (presumably one of these taken from a RH example project would be OK). Once you've got a good rhvariable.apj file in place, you should be able to scrap the existing cpd file (after having saved a copy, of course), and rebuild a new one without incident.

            2. Now for the title problem. One fix that I was able to use was to simply overwrite the (faulty) imported files with copies of the original htms. That is, once I saw that my imported files had a problem, I made a copy of my old files and pasted them over top of the new ones in Windows Explorer. (With RH closed.) Doing this didn't seem to cause any trouble in RH.

            I would also note that the RH patch that fixes this problem is only halfway effective. For it to work, you have to import the files from *outside* the project structure. From your description, you likely imported them from within the project structure; thus the problem.

            Good luck!

            G
            • 3. Re: new to v6 BLUES
              lmarden Level 2
              Thanks for your reply - I did see the suggestion to copy from a different location, so I did do that. Didn't help - filenames were topic names. But I will try copying in good files from Windows Explorer. I usually avoid doing anything to the RH environment from outside RH - but if you say this works, I'll give it a shot. Thanks much. And to all, I apologize for my little rant. I really am a huge fan of RH, have been using it for more than 10 years - it's just a bad time to be down for a day+ while ironing out these issues.
              • 4. Re: new to v6 BLUES
                ElisaFnord Level 2
                Agreed, agreed - RH6 is a great upgrade (in that there are very few problems) but a very difficult one (if you are one of the people who is affected). Have you ever read "I Had Trouble in Getting to Solla Sollew" by Dr. Seuss? It might go well with the margeritas.

                And about those darn template replacements - we had that problem, too, and the solution is silly, but pretty darn effective.

                1. Select your topics on the Topics pane.
                2. Right-click and select Properties.
                3. If <None> shows up in the Template field, go to step 5.
                If <Multiple Templates> shows up instead, CHANGE THE TEMPLATE TO <None>. I swear, it seems like you're going backwards, but it helps.
                4. Click the Apply button, NOT THE OK BUTTON.
                5. OK, now select the template you want.
                6. Click the Apply button, NOT THE OK BUTTON.
                7. Close the Properties dialog with the red X, NOT THE OK BUTTON.

                If you sense a certain theme here, you're right - the OK button seems to be the culprit. There's also some indication that changing mixed templates can be dicey. This method worked for me to change build tags in my 4,000 topic project.

                HTH,
                Elisa
                • 5. Re: new to v6 BLUES
                  lmarden Level 2
                  Just for continuity - added the same info below as a reply to another thread in which there are suggestions for replacing corrupt CPD files, and other suggestions for crashes in v6.

                  Basically, a quick update, and a question about one of the suggestions:

                  "Uninstalled, reinstalled (3x times now), restored my last backup from v5, and all seemed well until I got an app error while SAVING the THIRD topic I touched. So success lasted about five minutes this time. Now, I can't access my project. Can access the demos, or one of my smaller ones, but not the one, of course that is DUE ASAP.

                  So looking at this thread, thought I would give the last suggestion from Gravenstein a shot. There is no rhvariable.apj file anywhere - did a search of my entire drive - nothing, nowhere.

                  • 6. Re: new to v6 BLUES
                    lmarden Level 2
                    Gravenstein - reading your info above again, I wonder if I could go into the demo I have, add a user defined variable there, then find an rhvariable.apj file to copy? Gonna go try it right now.
                    • 7. Re: new to v6 BLUES
                      Peter Grainge Adobe Community Professional (Moderator)
                      Going back a version has never been a good policy. You might want to follow the instructions for Installing RH on my site. It includes stuff about a full uninstall with editing of registry entries.

                      First though consider is the inability to get into your project just because it has been opened in a later version. See the topic about Opening Projects on that one.
                      • 8. Re: new to v6 BLUES
                        lmarden Level 2
                        Sorry, I give up. I don't have the time to keep futzing with v6. I just tried EVERYTHING - a complete uninstall,reinstall, restore of the last backup made in v5, renamed cpd and xpj, copied in the rhvariable file, and tried to open with the hhp. Application Error. Can't keep doing this with our release waiting on me.
                        • 9. Re: new to v6 BLUES
                          lmarden Level 2
                          ok, so I kinda lied - or maybe I just changed my mind. I really want this v6 to work. So I did everything all over again. Used the article to completely uninstall, yada yada yada. And I got in, and was working in it, added a topic, made a few changes, and then had the unmitigated gall to try to <gulp> GENERATE the project. What am I - a moron? Because it crashed with an application error.
                          This is getting really old. The crash happened while it was trying to update files, according to the running commentary in the compile pane. If that gives any clues to anyone - holler!!!
                          • 10. Re: new to v6 BLUES
                            lmarden Level 2
                            just an update, for anyone interested. returned to v5. can't spend more time tweaking this while trying to prepare for a release. will try again later.
                            • 11. Re: new to v6 BLUES
                              lmarden Level 2
                              here's another update - tried again, while I am in relatively "down" time just after a release, to install v6. It just wouldn't cooperate. All the same errors and problems again. I tried everything. Replaced every problem file mentioned in Snippets, deleted cpd and xpj files, totally purged the registry of anything related to Blue Sky / eHelp / RoboHelp, disabled McAfee, even brought down all other programs and my SQL server.

                              I am fairly certain the problem is in my project files - no doubt, there is a problem with the CPD file. So, I uninstalled and returned to v5.02 and tried repairing the CPD file first (an ah-ha! moment...) and THEN upgrading. No good - the program displayed an application error while generating the .chm.

                              The reason that I am not 100% certain that my data is the issue is that I also have a WebHelp project - our Knowledge Base - that seemed to open up smoothly, and all seemed to be well, until trying to generate or publish. App error.

                              So, I am staying in v5.02 until I get the 7 upgrade. Heaven help my office mates if it doesn't install correctly they are a little afraid of me now....