2 Replies Latest reply on Sep 18, 2007 6:11 PM by psycik

    Webservice Request

    psycik
      Hey guys and girls,

      I am having a hell of a time trying to get this webservice to work how I want it to. If I put the request I want inside the <mx:request> tags it works fine just as it should. But I need to dynamically create the request. So I wrote all the code for that and it works perfect...except now when I send the request to the wsdl flex no longer adds the correct namespace to my XML that im sending it just leaves the tags as they are...
      So instead of:
      <tns:product></tns:product>
      It sends:
      <product></product>

      And the webservice im sending to does not like that at all so it wont work..

      So I tried a few things and have been searching google all morning to no avail.
      I was sending the request like this:
      ws.send(xmlcounts);
      And that obviously didnt work since it doesnt change the namespace, so i tried binding the xml in the request like this:
      <mx:request>{xmlcounts}</mx:request>
      And that doesnt even send a thing! and xmlcounts is defiantly populated!

      I am out of options on what to try, someone please help.
      Thanks