8 Replies Latest reply on Apr 6, 2011 10:23 PM by Lang Walker

    Snow Leopard Prores 4444 Gamma Shift Nightmare

    Lang Walker Level 1

      I've run into a nightmare with significant gamma shifts wrecking a lot of work we're trying to export using the Prores codec and After Effects CS3 (and CS4).

       

      I found this supposed fix, but it has not solved my problems: http://blogs.adobe.com/toddkopriva/2009/12/prores-4444-colors-and-gamma-s.html

       

      I appended suggested xml edit to the last line before  </MediaCoreQT...>  in both CS3 & CS4 files. Same infuriating darker gamma result after both edits.

       

      Scenario: large targa sequence we've been working on for months, established pipeline of compiling the targas in AFXCS3 (OSX 10.5.8), Project Settings/Color Settings/Working Space = none, exporting sequence as Prores 4444, gamma set to automatic. Colour matched targas perfectly.

       

      Now we're trying to use new Macpros we've bought specifically for this job that are run up as 10.6.2. Prores 4444 compiles are now coming out much darker! I've tried the XML edit (both CS3 & CS4), adjusting system gamma to 1.8 from new 10.6 default of 2.2, adjusting legacy gamma setting in project settings, etc... The colour is wrecked!! WTF?!?!?

       

      Really don't want to have to revert to "Animation" settings. Deadline looms. Any help would be enormously appreciated!

        • 1. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
          TynanW Level 1

          Lang, welcome to my hell !

           

          I have been similarly struggling with gamma shift problems for months, I think the basic answer from Adobe seems to be 'you aren't doing it right' - but they then fail to go on to offer a viable solution.

           

          Weeks of investigation have brought up numerous claimed solutions, all which fail to resolve the issue - that of renders having a pronounced colour shift (and occasional colour shift) from your composition window in AE.

           

          My solution was to go out and hunt down an old and slow G5 running Tiger and AE7 . . . . with this combination I can grade and compose and then render out a master file that looks identical to my composition and is free from gamma and colour shift issues.

           

          Good luck with your question, I will be watching for answers.

           

           

           

          Lee.

          • 2. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
            JaysonM-Y Level 3

            Just throwing this out there.... even tho OSX Tiger is unsupported now, it's still better than the snowy hell that some of you guys have to put up with.

            • 3. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
              Lang Walker Level 1

              Well, I've found a work-around, if not a solution. "Prores" is out. Max quality photo-jpeg matches targas (& 10.5 Prores 4444) perfectly. And its almost half the size.

              • 4. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
                Dan Ramirez Adobe Employee

                Sorry for the delay. I wanted to make sure I retested everything so my results would be current.

                 

                These Quicktime gamma issues are very frustrating for us as well. We've worked hard in the CS5 cycle to reduce our reliance on Quicktime and I'm happy to say the gamma roundtripping is looking very good. If you're using CS5, ProRes will roundtrip just fine in all cases except for one. OSX 10.5 users rendering to ProRes4444 will need to turn "Gamma Correction" OFF in the codec settings in the output module. Outside that very special case, we're roundtripping just fine in CS5.

                 

                Of course, that doesn't help you if you're currently using CS4. If editing the codec rules for CS4 didn't work, please try saving the file using a different text editor. I've had problems using textedit.app before. I used dashcode which is part of XCODE that's on your installer disk and it worked for me.

                 

                If that didn't work, it's very possible you have a 3rd party codec that's causing problems.

                 

                On my 10.6 Mac Pro, I had a gamma issue in 08, 16, and 32. It turns out that the presence of AJAVideoOutputCodec.component in my Quicktime folder caused this gamma shift. If you're still experiencing gamma shifts, I recommend removing ALL of your Quicktime components(HD/Library/Quicktime) except for ProRes. If your problem goes away, you can start replacing your missing codecs until you find the culprit.

                 

                If you don't have any conflicting codecs and you've made the codec rule changes, you should roundtrip just fine in 16 and 32. Unfortunatley, 8bpc still has a shift. If you must render to 8bpc, disabling deep color for ProRes4444 will get rid of this gamma shift. To disable deep color, you'll need to edit your MediaCoreQTDepthRulesCS4.xml file. The file is found @ users/username/Library/Application Support/Adobe/Common.

                 

                Simply add this line:     <QTCodec codec='ap4h' vendor='****' platform='mactel' direction='decode' versionlow='0x00000' versionhigh='*' status='notallowed' />

                 

                This will force ProRes to decode to 8bpc and you'll be able to roundtrip without issue.

                 

                Sorry the answer is so complicated for CS4. As I mentioned previously; in CS5 we're doing a better job controlling our destiny, so  you don't have to do any of this manual editing to get ProRes to roundtrip correctly.

                 

                Dan Ramirez

                After Effects

                QA Engineer

                • 5. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
                  AtonMusic Level 2

                  Lang Walker wrote:

                   

                  Well, I've found a work-around, if not a solution. "Prores" is out. Max quality photo-jpeg matches targas (& 10.5 Prores 4444) perfectly. And its almost half the size.

                  mmmmmm.....

                   

                  Not if you are aiming to generation-encode. 3-generation photo-jpeg encodings induce JPEG artifacts. Lots.

                   

                  Besides, it aint no fun using a codec which cant be played back in real time.

                   

                  Snow Leopard - a 29.97 encoded photo-jpeg movie will playback at 15 FPS in quicktime !!!!!

                  • 6. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
                    AtonMusic Level 2

                    To Dan Ramirez,

                     

                     

                    one problem with the gamma-shift has to do with the little preference file in the Quicktime Player Pro 7...

                    (At least when viewed there)

                     

                    Workflow

                     

                    1) Use Apple's compressor to generate a PR4444 file from a canon 5DMKII.MOV

                    Now open both files in the QT7 Player. They are indistinguishable.

                    The reason for using Compressor is that this app is the only encoder (I have tried about 7 different ones for OS X) that is capable of encoding a Canon5DMKII file into a ProRes4444 file that looks totally source-identical.

                    All other encoders are inducing color or gamma-shifts!

                     

                     

                     

                    2) Disable 'Enable Final Cut Studio color compatibility' from the QT7 Pro Preference Panel

                    THIS STEP IS CRUCIAL

                     

                    3) Drag the PR4444 file into AE CS5 and make a new comp. Set comp to 16bit

                     

                    4) Add comp to render-queue

                    Output module should reflect a QT PR4444 codec

                     

                    5) Render out.

                     

                    6) Open the Source(4444 generated via Compressor) and the AE rendered 4444.

                    The result SHOULD look identical in the QT7 player. It does not.

                     

                    Here is the trick...

                     

                    with both movies open;

                    open the QT7 preferences and check 'Enable Final Cut Studio color compatibility'

                     

                    Now the movies look identical

                     

                     

                    Now, one could be lead to believe that he should just keep this preference checked in order for colors to match.

                    If he does, he is in for a nasty surprise.

                     

                    If in the workflow above, one does NOT uncheck 'Enable Final Cut Studio color compatibility' AE will encode the file differently

                    and this time when viewing it in the QT7 player, one will NOT be able to match the colors, regardless of the 'Enable Final Cut Studio color compatibility' preference being checked or unchecked!

                     

                     

                    I am working with the ProRes4444(also in PPRO) format exclusively as I have found it to be the single best codec every created for any purpose(Multi-generation-encoding, half-res-playback, you name it) and I would really like adobe product to be able to cope with it.

                    • 7. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
                      AtonMusic Level 2

                      I Think (but dont know) that I have found an explanation to this problem.

                       

                      It has to do with colorsync on OS X (cant talk windows as I dont use that)

                       

                      Scenario

                       

                      1) Encode any non-ProRes 4444-source to ProRes 4444 using Compressor(Only encoder able to provide accurate result)

                      2) Be sure so DISABLE - Final Cut Studio color compatibility in the QT7 Player Preferences

                      3) Open source.MOV and new output.MOV in Quicktime7 -> Set view of both to half size (So you have overview) and place them next to each other

                       

                      They should look/be identical

                      sometimes placing them next to each other will lead you to believe that they are different. If so, place them on top of each other and flip back and forth via the Window menu to make sure that both movies are indeed identical-looking.

                       

                      4) Open OS X System Preferences

                      5) Click 'Displays' and select the color tab

                       

                      Now, toggle through various color profiles. You SHOULD see the colors adapt on BOTH movies.

                       

                      Create new AE Project and make sure that your Project is set to NOT color-manage your workflow

                      6) Create new AE composition and drag the Compressor-created ProRes 4444.MOV into it.

                      7) Add to render queue and select the ProRes 4444 as output.

                      8) Render out.

                       

                      9) Open Compressor-created ProRes 4444.MOV and new AE-created ProRes 4444.MOV in Quicktime7 -> Set view of both to half size (So you have overview) and place them next to each other

                       

                      10) They should look identical but they dont.

                       

                      11) Open OS X System Preferences (in case you closed it)

                      12) Click 'Displays' and select the color tab

                       

                      Now, toggle through various color profiles. You SHOULD see the colors adapt on BOTH movies.

                      They DONT. They ONLY adapt in the Compressor-created ProRes 4444.MOV not in the AE-created ProRes 4444.MOV

                      And that even though color-mangement has been turned off.
                      Turning color-managemen ON will have no different effect that leaving it off. The AE created movie(Color Management set to OFF) WILL not allow being color synced in OS X.
                      The Expected behavior IS:
                      1) when color management is set to OFF in the AE project settings and output module that the AE-Created movie would adapt to any color-profile change made within the OS X System Preference, COLOR Panel.
                      2) when color management is set to ON in the AE project settings and output module that the AE-Created movie would NOT adapt to any color-profile change made within the OS X System Preference, COLOR Panel.
                      As of NOW... There are no differences between above.
                      I hope this helps to solve this nuisance !!!
                      If I have missed something VERY obvious then please disregard my post and tell me what I seeing incorrectly !!!
                      PS - ON my computer - this last part of my post looks ridiculously small and that even though I have done NO font editing.
                      I find that posting and editing in this forum is as hard as getting Adobe products to encode correctly
                      • 8. Re: Snow Leopard Prores 4444 Gamma Shift Nightmare
                        Lang Walker Level 1

                        Wow, I'd forgotten about this thread ... thanks for the input. Jpeg was a good solution for us at the time because the QT clips weren't for playback or further mastering - they were being transcoded into MPEG2's for projection from media players. The gamma shift issues seem to have been dealt with in AFXCS5 ... we've got consistent results again between targas and prores QT files on 10.6 machines. Unfortunately, AFXCS5 broke the ability to render large QT files (>2.3GB) to a network volume. A serious bug that Adobe blames on Apple and seems to have basically refused to fix. It sounds like the color-sync issues are similar - bad communication and cooperation between Adobe and Apple making life difficult for end users yet again.