1 Reply Latest reply on Apr 13, 2010 3:24 PM by thepeterep

    Pre composed layer cuts out randomly...

    thepeterep

      Hello,

       

      I'm working on a composition in After Effects and I'm getting some really odd problems.

       

      I have two layers solo'd currently. Both are pre composed looped footage of a waterfall. Their transparency is being controlled using audio keyframes from a layer above. The transparency follows the waveform of the audio keyframes perfectly up untill about 45 seconds in where it suddenly cuts out. Both layers. The transparency is still at 60% (on the current frame I'm looking at) but my footage is no longer showing. When scrubbing through I can see that the transparency is still all above 50% (and following the keyframes) but nothing shows. It cuts out for 53 frames then comes right back in and follows the audio keyframes once more. It does this a few times after this, at seemingly random points.

       

      Any ideas what could be going on? The composition that is being used doesn't have any points where the video cuts out, it is a perfect loop. Also, it seems to be fine up untill then

       

      The other thing I have going on is an expression on the audio keyframe layer (on the effect slider to be more specific) that changes the values from 0.01 to 20 into values from 0 to 80. I've tried mucking around with this expression too and nothing helps. Even getting rid of the expression doesn't change the layer cutting out.

       

      I've also tried re keyframing the audio to see if the keyframes were the problem. That didn't help either.

       

      I'm desperately trying to solve this but nothing seems to be working. Please help!

       

      Peter.

        • 1. Re: Pre composed layer cuts out randomly...
          thepeterep Level 1

          Ok so I just noticed the time remapping on the layer (I have a loopOut() expression) it gets to the end of the loop then stops for the 53 frames and begins to loop again from 0. In fact. It seems to do it everytime it reaches the end of the composition...

           

          And having just disabled then re-enabled my time remapping it now works. I think this is because I edited the composition whilst it was being time remapped so it was trying to loop the previous version of the composition.

           

          Sorry for that. Bit of a waste.