3 Replies Latest reply on Apr 15, 2010 7:28 AM by Linda267

    RH 8 Hangs When Upgrading/Importing RH 6 Project

    Linda267

      I have a project I created in RH 6 that I am attempting to upgrade to RH 8. When I open the RH 6 project in RH, I get the dialog that tells me the project was created in an older version of RoboHelp and that in order for me to open the project in RoboHelp 8, I need to upgrade it. I click the upgrade button, RoboHelp begins to do the upgrade, and then it freezes when the status bar reads "Fetched style sheets". The project never opens.

       

      Just for the heck of it, I tried closing RoboHelp, deleting the CPD file, and the reopening the project to see what happens. The project then freezes at the startup screen, so that did not work.

       

      I am using version 8.0.2 and the project is stored on my local drive.

       

      I tried opening starting a new project in RH 8 and then importing the html files from RH 6 into them. I was able to import most of the files but it would hang on some of them. I looked at one of the suspect files in Notepad and did not find anything out of the ordinary. The files that did import, looked fine.

       

      Help!

        • 1. Re: RH 8 Hangs When Upgrading/Importing RH 6 Project
          Linda267 Level 1

          P.S. I am running MS Windows XP Professional, SP 2

          • 2. Re: RH 8 Hangs When Upgrading/Importing RH 6 Project
            RoboColum(n) Level 5

            This sounds like there is some content in the topics that is causing RH to choke. Look through them and tell us what is different compared to the topics that upgrade / import OK.

             


            • Read the RoboColum(n) for a tips, tricks and musings on the Technical Communication Suite products.
            • Follow the RoboColum(n) on Twitter
            • 3. Re: RH 8 Hangs When Upgrading/Importing RH 6 Project
              Linda267 Level 1

              Thanks, Colum. I compared the files and could not see any significant differences between the two. Then again, to be honest, I was not sure what exactly to look for. There were no strange characters present in the code, the Meta tags looked the same as those in the good file, etc. Is there an error log within RoboHelp that I can check to see what caused the hiccup?

               

              I did take a copy of the project and removed the folders with the troublesome file(s) in them and then tried another upgrade. This time the upgrade worked.

               

              The last thing I tried was opening the troublesome file in RH 6, went to the TrueCode tab and copied the html from there, then opened RH 8, created a new topic and pasted the html into it. The file displayed properly and I was able to close down and reopen RH 8 without a hitch.

               

              This is pretty bizarre....

              ---------------------------------------------

              UPDATE:

               

              I did find something weird in another file that did not upgrade/import. Looks like RH 8 hiccuped on a kadov tag from RH 6. This is the RH 6 tag:

               

              <!--kadov_tag{{<uservariable name=Street1
                                              x-format=Street1
                                              x-value="Contains the street address for a company."
                                              x-showvalue>}}-->Contains the street address for a company.<!--kadov_tag{{</uservariable>}}-->

               

               

              And here's what happened to it in RH 8:

               

              <p><?rh-u皜v_start name="Street1" ?>Contains the street address for a company.<?rh-udv_end ?></p></td>
                              <td style="border-right: Solid 1px #227cc6; border-bottom: Solid 1px #227cc6;
                                   width: 12.634%; padding-right: 10px; padding-left: 10px;
                                   " bgcolor="#FFFFFF"><p>

               

              OK...ummm.....now what?