1 Reply Latest reply on Apr 14, 2010 10:05 AM by Jason San Jose

    linking a source directory creates an error

    Antari

      I have a very simple program that I just started to use in playing with a few external libraries out there.

       

      I downloaded the Flint source and uncompressed it into c:\developer\flint_2_1_3_source directory.

       

      Then, I went to project-properties-flex build path and selected the source path tab.

       

      I then clicked on the "Add Folder" button and selected the above folder.

       

      Once I had that in my project I went back to the source file and found that my code hinting for AS was totally gone.  In other words when I typed "import " and hit control space, nothing popped up.  In browsing around I discovered I had a ! Root in my outline view and toggling over to design view I see the following message: "An unknown item is declared as the root of your MXML document. Switch to source mode to correct it."

       

      My source is simple and it looks a-ok (see below)

       

      I removed the source directory and the issue doesn't go away now.  Anyone know what's going on here?

       

      <?xml version="1.0" encoding="utf-8"?>

      <s:Application

       

       

      xmlns:fx="http://ns.adobe.com/mxml/2009"

      xmlns:s="

      library://ns.adobe.com/flex/spark"

      xmlns:mx="

      library://ns.adobe.com/flex/mx"

      minWidth="800"

      minHeight="600" xmlns:ns1="*">

       

       

      <fx:Declarations>

       

       

      <!-- Place non-visual elements (e.g., services, value objects) here -->

       

       

      </fx:Declarations>

       

       

      </s:Application>

        • 1. Re: linking a source directory creates an error
          Jason San Jose Adobe Employee

          Can you post the contents of your .actionScriptProperties file? That's the easiest way to show us what's in your library path.

           

          From Package Explorer (assuming Flash Builder 4), hit the filters button (the one with the 3 arrows) and uncheck ".* resources". You should see a .actionScriptProperties file at your project root.

           

          I was able to setup a project with Flint with no errors. Here's what mine looks like after creating a new Flex 4 project (using the default Flex 4 SDK) and adding the Flint source:

           

          <?xml version="1.0" encoding="UTF-8" standalone="no"?>

          <actionScriptProperties mainApplicationPath="flinttest.mxml" projectUUID="a3f4ea08-3178-4bc9-8527-12f0cbb6456f" version="6">

            <compiler additionalCompilerArguments="-locale en_US" autoRSLOrdering="true" copyDependentFiles="true" fteInMXComponents="false" generateAccessible="false" htmlExpressInstall="true" htmlGenerate="true" htmlHistoryManagement="true" htmlPlayerVersionCheck="true" includeNetmonSwc="false" outputFolderPath="bin-debug" sourceFolderPath="src" strict="true" targetPlayerVersion="0.0.0" useApolloConfig="false" useDebugRSLSwfs="true" verifyDigests="true" warn="true">

              <compilerSourcePath>

                <compilerSourcePathEntry kind="1" linkType="1" path="C:/Users/me/Downloads/Flint_2_1_3_source/Flint_2_1_3_source"/>

              </compilerSourcePath>

              <libraryPath defaultLinkType="0">

                <libraryPathEntry kind="4" path="">

                  <excludedEntries>

                    <libraryPathEntry kind="3" linkType="1" path="${PROJECT_FRAMEWORKS}/libs/flex.swc" useDefaultLinkType="false"/>

                  </excludedEntries>

                </libraryPathEntry>

                <libraryPathEntry kind="1" linkType="1" path="libs"/>

              </libraryPath>

              <sourceAttachmentPath/>

            </compiler>

            <applications>

              <application path="flinttest.mxml"/>

            </applications>

            <modules/>

            <buildCSSFiles/>

          </actionScriptProperties>

           

          Jason San Jose

          Software Engineer, Flash Builder