3 Replies Latest reply on Oct 16, 2007 6:45 AM by lukaro

    Can connect, but not edit

    Delladog
      I'm trying to use the trial version of Contribute CS3 to edit two web sites. First site uses SFTP--works perfectly.

      The second site uses FTP. I can create the connection in Contribute without error. But when I try to edit a page, the "waiting for server" bar stays up forever and finally I get the error message: "Server is down or not accepting..."

      I can FTP to this site and read/write files with no problem using Filezilla.

      I've tried some of the suggestions on this forum--fiddled with the Advanced settings for the FTP connection, etc. But nothing works. Have been trying things for several days with no luck. Can anyone help?
      Thanks!

      Update: Although I changed nothing, Contribute finally let me edit or at lease created a draft on my pc. But now I get the same message when I try to publish. I don't understand why it would work for some things and not others.
        • 1. Re: Can connect, but not edit
          lukaro Level 1
          I can't tell you exactly what the problem is, but it will probably be related to the network firewall protecting the client computer.

          Under active (normal FTP) the client will chose a random Port X to initiate the FTP connection. It will then listen on Port X+1. If you have an intelligent router like a Netgear, it can automatically open Port X+1 to allow the data connection in from the server. Often, the Firewall can't do this, and this will stop Contribute working.

          I suggest researching the difference between Active and Passive FTP, and then changing your Contribute advanced connection settings and client firewall settings accordingly.

          Try using passive FTP option in advanced connection settings. Here you must allow outgoing FTP connections from the client computer. Also, try checking combinations of the various options in Contribute advanced options. Even though some combinations make no sense, you might find it starts working.

          Rgds

          lukaro
          • 2. Re: Can connect, but not edit
            Tjipke Schouten
            I've the same (?) sort of problems: there's one site which I build with DW but that I cannot edit wih Contribute. I tried almost everything, but cannot find a solution. Peculliar detail: the site is hosted by Lycos. Nor their administrator nor the helpdesk of Adobe knows what to do.
            There's perhaps one thing I didn't figured out yet: I just installed Airport Extreme. Could that perhaps bother?

            Any tips or ideas? Thanx!
            • 3. Re: Can connect, but not edit
              lukaro Level 1
              If Airport Extreme involved changing your router, and there's a new network firewall, then new firewall settings on your network could be getting in the way. Try and take out any uncertainties, e.g. go back to ethernet and don't use wireless in order for testing. Look at the difference between active and passive FTP. If using Active, make sure you have the right ports open on your network firewall. If Active doesn't work try Passive (Contribute Connection Wizard, Advanced Settings), but this is only relevant if Lycos supports Passive FTP.

              Other things to consider:
              - File extensions. Is your home page a particular file extension that Contribute isn't recognising. If so, try using a .htm test file instead.
              - Set up of the hosting ac. Does the website have its own domain name? If not, this might be making it hard for Contribute to find your website files in the correct place??
              - FTP permissions. Does your hosting account have all the relevant FTP permissions you will need, add/edit/delete file etc, add/edit/delete directory etc.

              Just my thoughts ... hope it helps.

              Rgds

              lukaro