5 Replies Latest reply on Jun 8, 2010 1:52 PM by facu_it

    How do I make sure Adobe Reader has been correctly patched?

    morph2-21 Level 1

      Before Patching

      Adobe Reader version 9.3.0 installed through GPO has been running on WinXP Pro SP3 without a problem for months

       

      Patching Method

      I copied the following files to local C:\V932 folder:

      AdbeRdr930_en_US.msi (original v9.3 MSI installation file)

      AdbeRdrUpd932_all_incr.msp (the downloaded patch file released in April 2010)

       

      then I used the following command:

      msiexec /a AdbeRdr930_en_US.msi /p AdbeRdrUpd932_all_incr.msp

       

      The Result

      - AdbeRdr930_en_US.msi file gets updated to the date and time the above command was executed
      - 4 new folders created (Common, CommonAppData, Program Files and Windows)

       

      I then created a new shared folder (\\servername\AdbeRdr932) on the server and copied the whole content of C:\V932 to that shared folder. After that, I created a new GPO package to upgrade version 9.3.0

       

      Rebooted my Windows XP Pro machine and the upgrade went successfully. When I check Help - About, it shows that I have 9.3.2

       

      Here's the problem:

      When I compare Adobe related files in the following folders, some files do not match:

      C:\Program Files\Adobe\Reader 9.0\Reader

      and

      \\servername\AdbeRdr932\Program Files\Adobe\Reader 9.0\Reader

       

      For example:

      Properties of AcroRd32.exe in C drive shows File version 9.3.0.148

      Properties of AcroRd32.exe in the shared folder shows File version 9.3.2.163

       

      There are some other files (DLL, EXE) that do not match. The files in C: drive is older than those on the shared network folder. Now I'm not sure what to trust, the version info shown in Adobe Reader Help - About or the file version info.

       

      To those who deploy Adobe Reader version 9.3.2 through GPO, do you see the same problem?

        • 1. Re: How do I make sure Adobe Reader has been correctly patched?
          deepak_sisodia Level 2

          As you said -

          When I check Help - About, it shows that I have 9.3.2

                              and          

          Properties of AcroRd32.exe in C drive shows File version 9.3.0.148

           

          These two statements tell the whole story.

           

          Try out one thing - Go to help-->About .. I know you have done this and on this splash screen it shows 9.3.2....that's fine

                           Now take the mouse pointer to the position on splash screen where 9.3.2 is written and click

          After clicking you will see a different version string. I bet now you will see 9.3.0.148.

           

          This is what is happening behind the scenes:

          Initial version 9.3.2 is picked from a registry entry

          But when you click on the splash screen the version is picked from the AcroRd32.dll

           

          Unfortunately there is no straight way to make out whether Reader has been correctly patched or not because sometimes version in splashscreen is expected to change after click (if changes are going only in files other than AcroRd32.dll)

           

          In your case the installation of Reader 9.3.2 is corrupt because the way you are creating an AIP is wrong.

           

          Follow these steps to create an AIP and then deploy it via GPO:

          Perform administrative installation

          1. Copy the Reader 9.3 msi installer to your machine.

          2. Create a distribution point (a folder where the installer can install the uncompressed

          program files).

          3. Click Start, click Run, and then enter the following command:

           

           

          msiexec /a <path of Reader9.3.msi>

          4. When you receive a prompt asking where to install the files, browse to the distribution point

          you created in step 2.

          5. Click OK. When the installer finishes, all files will be at the distribution point.

          Also AdbeRdr930_en_US.msi is also present at the distribution point.(This msi is used in step 7 below)

           

          To add patches to the administrative installation:

          6. Copy the Reader 9.3.2 msp patch on your machine.

          7. Click Start, then click Run, and then type CMD.

          At the command prompt, type the following:

          msiexec /a <path of msi at distribution point> /p <path of Reader 9.3.2.msp>

           

           

           

           

           

           

           

          After installation is successfull you can copy this folder (distribution point) to any server and create GPO package.

           

          So it's a two step process.

          You were trying to do this in one step! and this is where you were going wrong.

          • 2. Re: How do I make sure Adobe Reader has been correctly patched?
            morph2-21 Level 1

            > After  clicking you will see a different version string. I bet now you will  see 9.3.0.148.

             

            That's correct.

             

            I suspected that I was missing some steps but didn't know what they were. I followed your instructions below except that I did everything on the server local drive (thru Remote Desktop Connection). Here's a summary:

             

              • Copy AdbeRdr930_en_US.msi and AdbeRdrUpd932_all_incr.msp to C:\Temp folder
              • Create a new subfolder under C:\Temp folder and call it AdbeRdr9.3.2
              • Run this command: msiexec /a C:\Temp\AdbeRdr930_en_US.msi
              • Specify target drive (where to install to) C:\Temp\AdbeRdr9.3.2
              • When the above process completes, I run the following command:

            msiexec /a C:\Temp\AdbeRdr9.3.2\AdbeRdr930_en_US.msi /p C:\Temp\AdbeRdrUpd932_all_incr.msp

              • Once again the target is C:\Temp\AdbeRdr9.3.2
              •  

            When installation process completes, I copy/paste C:\Temp\AdbeRdr9.3.2 folder to a shared drive that I created yesterday to deploy Adobe Reader 9.3.2 through GPO. Then I did a "Redeploy Application" and restarted my PC. It does the "Installing Adobe..." thing when my PC goes back to Windows GUI.

             

            AcroRd32.exe and AcroRd32.dll files in my C drive now show the correct version 9.3.2.163. Also, Help - About shows the correct version 9.3.2 and after a mouse click on that version number I see version 9.3.2.163 instead of version 9.3.0.148.

             

            Looks like it is installed properly now. Thanks for your help.

            • 3. Re: How do I make sure Adobe Reader has been correctly patched?
              BLARG19ft4

              Ok I am doing pretty much the same thing and it won't work.

               

              The only thing different I can see, is where do I download a MSI file?  The link Adobe provides is only an EXE file, and I have been grabbing the msi from there. (obviously wrong)

               

              Thanks for any help.

              • 5. Re: How do I make sure Adobe Reader has been correctly patched?
                facu_it

                Not sure if I should make a new thread or not ... But after following the instructions in this post, I cannot create the GPO.  I copied the AdbeRdr9.3.2 folder from C:\temp to my network shared distribution point, then tried to create the GPO using the AdbeRdr930_en_US.msi file in that folder.  This returns an error message and will not create the software installation package.  The .msi file is correctly configured though, I ran that from the distribtution point onto my workstation and it installed correctly.  Any suggestions about creating the GPO?

                 

                Thanks