7 Replies Latest reply on Apr 18, 2010 12:37 PM by Wade_Zimmerman

    missing tools in Illustrator cs4

    Deshea Green Level 1

      hey,

       

      This problem is driving me crazy. I have Adobe Illustrator cs4 installed (win.Vista), it runs o.k but I'm missing a lot of tools- I get all the main tool groups but the groups wont open` so I have the line tool but not arc or spiral, I have warp tool but not twirl or bloat, text area but not text path and so on.

       

      I have tried redirecting to plugins>tools via the edit>preferences>plug-ins and scratch disks dialog, but then when I load the software I get an error notice saying that some of the plug-ins conflict with... and it doesn't work. I've also tried deleting the AIpref. file from appdata but that didn't help.

       

      What am I missing? this situation consumes too much of my time and sanity!

       

      thanx

        • 1. Re: missing tools in Illustrator cs4
          Jacob Bugge MVP & Adobe Community Professional

          Deshea,

           

          You may try to close down Illy and press Ctrl+Alt+Shift during startup, or you may try to Move the folder

           

           

          You should be aware of the strange fact that with Vista sometimes you have to restart the PC for deletion/moving to work.

          • 2. Re: missing tools in Illustrator cs4
            Deshea Green Level 1

            Hey,

             

            Thanx, tried both but no success...

            I will try the other options on the other pink page (except the "moving the folder" folder, which I've already tried) but my hopes r not too high...

            • 3. Re: missing tools in Illustrator cs4
              Jacob Bugge MVP & Adobe Community Professional

              Deshea,

               

              If the Other Options fail too, you may consider an uninstall/reinstall, using the Clean Script in between, http://www.adobe.com/support/contact/cs4clean.html

               

              Please report back in any case; it may add to our combined knowledge/ability to help others.

              • 4. Re: missing tools in Illustrator cs4
                Deshea Green Level 1

                hey again-

                 

                I am still working on it so no solution so far. Worst, I'm afraid I've destroyed something cause now when I try to open AI it pops an error alert saying it can't load the plug-ins pencil tool, control panel and two others and then crashes.

                 

                I think this happened because I moved some plug-in files around in the plug-ins folder, as I thought was suggested on the pink page but I must have done something wrong.

                 

                anyway I will no uninstall/reinstall as you suggested using the clean script; will report back soon.

                 

                Thanx again!

                • 5. Re: missing tools in Illustrator cs4
                  Wade_Zimmerman Level 6

                  Let me ask a question, are you launching AI from an alias located on your desktop? Another Question did you move the Illustrator folder out of the Illustrator application folder and perhaps to a place where you could more easily launch it?

                   

                  An alias is a copy of the icon of a folder or directory of fie that links it to the original and looks like the actual originl.

                   

                  The aliases you know are My  Computer, Internet Explorer, Documents etc that you find commonly on a PCs desktop.

                   

                  This is the scenario that often takes place on a mac and probably would cause the same problem on a PC.

                   

                  Instead of creating the alias to use as a link to launch the application you either copied the application it self or you moved it to the desktop.

                   

                  What that means is that some essential links between the application are now broken such as some of the tools and menu items that reside in the Applications folders such as filters and effects, file formats and extensions.So they are not showing.

                   

                  The way to fix this is either move the application back to to the Illustrator folder and read about how to make an alias or just launch it from the Start menu or delete the copy if you have a copy of the application on the desktop and again either make a proper alias or launch from the Start menu.

                   

                  I do not know how this might effect the preferences on a PC but on the Mac it sometimes corrupts the preferences and they have to be trashed as well as correcting the problem.

                   

                  Having written all of this there was another way this can manifest itself on both a Mac and PC and you might do a google search if what I describe above does not apply to you.

                   

                  It was actually posted here about four or five months ago and it involved deleting a file.

                  • 6. Re: missing tools in Illustrator cs4
                    Deshea Green Level 1

                    Hey guys,

                     

                    first, I was actually launching Ai from a shortcut I'd placed on my desktop; I think it was made correctly but I could be wrong.

                    anyway I've uninstalled, cleared and re-installed, this time not creating a shortcut so I just launch it from the start menu, so now everything is back to normal- I still miss many of the tools but at least I don't get error messages and there are no more crashes.... 

                     

                    I will attack this problem again tomorrow; so far- thanx for the advise!

                    and good night

                     

                    Deshea

                    • 7. Re: missing tools in Illustrator cs4
                      Wade_Zimmerman Level 6

                      The shortcut on the desktop is called an alias and that was what I was referring to. So the problem may actually be solved since you have to manually remove the old preference mde from the last instal or the problems may still show up.

                       

                      Follow Jacob's instructions to move the settings folder and i think the tools will come back.

                       

                      Move the folder I know you did this before but this time I think it will work.