3 Replies Latest reply on Apr 19, 2010 11:30 PM by David_F57

    flex builder 4

    ShaneNari Level 1

      Hi,

       

      I have a question on the flash builder 4.

      I want to know the backward compability in flash  builder 4 for flash player runtime versions.

       

      I have a kind of browser that supports only flash player 7 runtime. I want to develop flash applications using flash builder 4 tool using flash player runtime version 7.

      But flash builder 4 compiler is asking for minimum flash player 10 runtime which my browser doesn't have. Is there the capability for flash builder 4 to run the applications using the lower versions of flash players(like fp7,fp6....fp1).

       

      Thanks,

      Shanenarrifield.

        • 1. Re: flex builder 4
          David_F57 Level 5

          hi,

           

          No, flex 3 was built around flashplayer 9, flex 4 was built around flashplayer 10 neither is bakward compatible with earlier versions of the player.

           

           

          David.

          • 2. Re: flex builder 4
            ShaneNari Level 1

            Hi david,

             

            Thanks for the reply.

            I come to know that flash cs4 professional designer has the backward compability of flash players.

            But,if that much flexibility is available in flash cs4 professional for flash player runtimes(older versions of flash players) then why there is no flexibility for flash builder4 supporting only the minimum flash player 10 runtime and not supporting the older versions of flash players?

             

            Any idea??

             

            Thanks,

            Shanenarrifield.

            • 3. Re: flex builder 4
              David_F57 Level 5

              Hi,

               

              Flash CS4 is an on going product and rightfully needs to support legacy flash code such as actionscript 2 which is part of the flash designer life cycle.

               

              FlexBuilder is a newer product that began as a tool for actionscript 3/FP 9 so it supports the versions of flashplayer that support actionscript 3.

               

              Flashbuilder supports both FP 9 through the flex 3.x sdk and the advantages of FP 10 with its optimised flex 4.0 sdk.

               

              David.