8 Replies Latest reply on Apr 20, 2010 10:49 AM by Raconteur

    HTML editor plugin for FB4

    Raconteur

      Hi all,

       

      I am doing some work leaning heavily on ExternalInterface to integrate with a JS/C# app, and am finding myself incredibly frustrated that there is not a decent HTML editor already included with FB4.

       

      Most of the plugins I would normally use (WTP, Aptana, Amateras, etc.), won't install due to pre-requisites missing or incompatible.  So... what are you guys using?  I don't need anything incredible, but would love to just have some basic syntax coloring and formatting.

       

      Thanks for any ideas/input!

       

      Cheers,

       

      Chris

        • 1. Re: HTML editor plugin for FB4
          Jason San Jose Adobe Employee

          Which Eclipse update site are you using? You should be able to download the web tools features from http://download.eclipse.org/releases/galileo/ (works with FB Standalone and Eclipse 3.5+)

           

          Jason San Jose

          Software Engineer, Flash Builder

          • 2. Re: HTML editor plugin for FB4
            Raconteur Level 1

            Hey Jason,

             

            Thanks for the info.  I don't remember which pre-reqs were hanging, but I am using the straight Eclipse update info/site from the WTP project homepage.

             

            I will try again tomorrow morning and get the errors to post here.

             

            Thanks!

             

            Chris

            • 3. Re: HTML editor plugin for FB4
              Jason San Jose Adobe Employee

              Sometimes those Eclipse project home pages get out of date or sometimes deliver a different version of the feature. The WTP site for example includes their SDK and their source code. Probably not what you're looking for.

               

              I highly suggest using the Galileo site. The WTP update site (http://download.eclipse.org/webtools/updates/) also suggests Galileo.

              • 4. Re: HTML editor plugin for FB4
                Raconteur Level 1

                Ok, cool.  Will give that try.

                 

                Thanks!

                • 5. Re: HTML editor plugin for FB4
                  Raconteur Level 1

                  Hey Jason,

                   

                  Ok... went to http://download.eclipse.org/webtools/updates/ and then just selected all of the updates and got these errors:

                   

                  Cannot complete the install because one or more required items could not be found.
                    Software being installed: Dali Java Persistence Tools 2.2.2.v200911250220-7L7OAPFBBoPS0TBgXV1je (org.eclipse.jpt.feature.feature.group 2.2.2.v200911250220-7L7OAPFBBoPS0TBgXV1je)
                    Missing requirement: Dali Java Persistence Tools 2.2.2.v200911250220-7L7OAPFBBoPS0TBgXV1je (org.eclipse.jpt.feature.feature.group 2.2.2.v200911250220-7L7OAPFBBoPS0TBgXV1je) requires 'org.eclipse.datatools.sqldevtools.feature.feature.group [1.7.0,2.0.0)' but it could not be found

                   

                   

                  Then I just selected the WTP 3.1.2 and I got these errors:

                   

                  Cannot complete the install because one or more required items could not be found.
                    Software being installed: Eclipse XML Editors and Tools 3.1.1.v200907161031-7H6FMbDxtkMs9OeLGF98LRhdPKeo (org.eclipse.wst.xml_ui.feature.feature.group 3.1.1.v200907161031-7H6FMbDxtkMs9OeLGF98LRhdPKeo)
                    Missing requirement: EMF Workbench Edit Plug-in 1.1.301.v200908101600 (org.eclipse.wst.common.emfworkbench.integration 1.1.301.v200908101600) requires 'bundle org.eclipse.emf.ecore.xmi [2.4.0,3.0.0)' but it could not be found
                    Cannot satisfy dependency:
                      From: WST Common Core 3.1.1.v200908102300-7B77FZ6F7RZHKDIwRlOwUN (org.eclipse.wst.common_core.feature.feature.group 3.1.1.v200908102300-7B77FZ6F7RZHKDIwRlOwUN)
                      To: org.eclipse.wst.common.emfworkbench.integration [1.1.301.v200908101600]
                    Cannot satisfy dependency:
                      From: WST Common UI 3.1.1.v200908102300-7B5FRHDhdMOGnoekn4gtEJxSmPxV (org.eclipse.wst.common_ui.feature.feature.group 3.1.1.v200908102300-7B5FRHDhdMOGnoekn4gtEJxSmPxV)
                      To: org.eclipse.wst.common_core.feature.feature.group [3.1.1.v200908102300-7B77FZ6F7RZHKDIwRlOwUN]
                    Cannot satisfy dependency:
                      From: Eclipse XML Editors and Tools 3.1.1.v200907161031-7H6FMbDxtkMs9OeLGF98LRhdPKeo (org.eclipse.wst.xml_ui.feature.feature.group 3.1.1.v200907161031-7H6FMbDxtkMs9OeLGF98LRhdPKeo)
                      To: org.eclipse.wst.common_ui.feature.feature.group [3.1.1.v200908102300-7B5FRHDhdMOGnoekn4gtEJxSmPxV]

                   

                  Isn't there some package or update or other tool that won't make me hunt down all of these dependencies??  I know in "real eclipse" you can have the update system track pre-reqs down for you, but it doesn't seem to be an option (or if it is it isn't working) here...

                   

                  Any assistance greatly appreciated!

                  • 6. Re: HTML editor plugin for FB4
                    Jason San Jose Adobe Employee

                    Sorry, maybe I shouldn't have put that link in my most recent post. Use http://download.eclipse.org/releases/galileo/ and choose the "Web, XML, and Java EE Development category. What I was trying to point out was that Web Tools' own update sites recommends using http://download.eclipse.org/releases/galileo/.

                     

                    Jason San Jose

                    Software Engineer, Flash Builder

                    • 7. Re: HTML editor plugin for FB4
                      Raconteur Level 1

                      Alright... this is really frustrating...

                       

                      So I whittled down the bits to just the Web Developer Tools, the JavaScript Editors, and the XML Editors and was able to get by the pre-reqs problems, BUT... when I get to the install page where you have to review licenses, I select the Accept radio button and the only buttons that activate are BACK and CANCEL.  I can't click NEXT or FINISH.

                       

                      WTF?!?!

                      • 8. Re: HTML editor plugin for FB4
                        Raconteur Level 1

                        Thanks, Jason, that did it... it auto-resolved all of the pre-req conflicts and installed exactly what I needed.

                         

                        Thanks for guiding me through that.