10 Replies Latest reply: Jun 30, 2012 9:06 PM by TroZac RSS

    Adobe installer "failed to initialize" error.


      I have been trying without success for 2 days to install the tr

      ial version of Flash Builder 4 but cannot get past the following erro

      r - displayed affter launching the Set-up.exe in the Adobe flash Builder 4 Standalone folder.

      The following information is showing the PDApp.log file:


      4/21/2010 15:38:09 [INFO] Setup - Build Version -
      4/21/2010 15:38:09 [INFO] Setup - Logging Level verbosity Set  to 4
      4/21/2010 15:38:09 [INFO] Setup - Start Adobe Setup
      4/21/2010 15:38:09 [INFO] Setup - TimeLog: Bootstrapper Start
      4/21/2010 15:38:09 [INFO] Setup - TimeLog: Start initial checks
      4/21/2010 15:38:09 [INFO] Setup - Dictionary Path: C:\Documents and Settings\SW102124\My Documents\Adobe\Adobe Flash Builder 4 Standalone\resources\Dictionary\en_US\stringTable.zdct
      4/21/2010 15:38:09 [INFO] PIM - Trying to access xml at path:C:\Documents and Settings\SW102124\My Documents\Adobe\Adobe Flash Builder 4 Standalone\resources\setup.xml
      4/21/2010 15:38:09 [FATAL] PIM - Failed to Create XML instance : DOMDocument40 ADXML::initWithXMLPath Error:80040154
      4/21/2010 15:38:09 [FATAL] Setup - Could not initialize ADXML object
      4/21/2010 15:38:09 [FATAL] Setup - Unable to initialize. Error parsing setup.xml file
      4/21/2010 15:38:09 [WARN] Setup - Reboot is pending from earlier installation.
      4/21/2010 15:41:05 [INFO] Setup - End Adobe Setup. Exit code: 0


      I am running XP service pack 2.

      I have installed and continue to use Flex Builder 3.

      Also running fully licensed copies of MS Vis Sudio 2005 and 2008, Adobe Master Collection CS4 and CS3; also trial version of WebOrb - all of which are working fine.

      I have been running the setup/install using an account with admin rights

      I have tried installing after booting up in Safe mode - doesn't help

      I have confirmed that my account has full control over all the folders/files in the installation package

      I have tried the install with virus protection turned off, and have tried right click>Run As> Current user - with "Protect my computer..." unchecked.


      I suspect that I am either missing a dll or a dll needs to be registered - most likely the one required for opening and parsing the setup.xml file shown in the error log above, however, I have no idea which dll(s) are implicated.


      Any help will be very gratefully received!