14 Replies Latest reply on Apr 23, 2010 3:26 PM by stihlchainsaw

    Elements 5.7 Update

    Monoclops2

      Have successfully updated Windows Camera Raw in Elements 7 before, but downloaded Camera Raw 5.7 update doesn't appear to contain CameraProfiles.exe.

       

      Tried fresh downloads, but still now joy.  CameraProfiles.exe missing?

        • 1. Re: Elements 5.7 Update
          Tom Hogarty Adobe Employee

          Monoclops2,

          You are correct, an incomplete Camera Raw Plug-in "package" was posted under the listing for Photoshop Elements and Premiere Elements.  A corrected download will be available today.

           

          Regards,

          Tom Hogarty

          Lightroom, Camera Raw, DNG Product Manager

          • 2. Re: Elements 5.7 Update
            athegn Level 2

            Just downloaded the ACR 5.7 from:-

             

            http://www.adobe.com/support/downloads/detail.jsp?ftpID=4685

             

            and tried to use it in Elements 7 under Windows 7.

             

            As normal i.e. as I do whenever I update an ACR, I deleted the old file from:-

             

            Program Files\Adobe\Photoshop Elements 7.0\Plug-Ins\File Formats

             

            and copied the new 8bi file from the download Zip file; ensuring I did NOT use the 64 bit version.

             

            However on launching PSE 7 and trying to open a Canon 450D CR2 file I am told:-

             

            Unable to use Camera Raw plugin.

             

            I got the same message when I tried to use asset 1003 work around of the Release Candidate of 5.7

             

            Is there an ACR 5.7 for PSE 7 and if so is it in the downloaded area?

            • 3. Re: Elements 5.7 Update
              Monoclops2 Level 1

              I have just tried to update to ACR 5.7 using the corrected package, after completing the install I get the message "File format incompatible with this version of Elements".

               

              According to the instructions it is supposed to be compatible with Elements 7.

              • 4. Re: Elements 5.7 Update
                PevenseyPirate

                Same problem here. I downloaded the corrected package. It now includes Camera Prolies.exe but the .8bi plugin looks unchanged from yesterday  (it is dated 7th April) and gives me the same incompatibility message.

                 

                Ian

                • 5. Re: Elements 5.7 Update
                  Tom Hogarty Adobe Employee

                  My apologies but the documentation was not updated properly for the Camera Raw 5.7 release.  The team is working to update the information as quickly as possible but here is the correct compatibility list for Camera Raw 5.7:

                   

                  Compatibility

                  The Camera Raw 5.7 plug-in is not compatible with versions of Photoshop earlier than Photoshop CS4 or versions of Photoshop Elements earlier than Photoshop Elements 8.0 for Windows and Photoshop Elements 8 for Mac. 

                  • The      latest version of the Camera Raw plug-in available for Photoshop Elements 3.0      customers is Camera Raw 3.6. 
                  • The      latest version of the Camera Raw plug-in available for Photoshop Elements      4.0 (Windows) is Camera Raw 3.7. 
                  • The      latest version of the Camera Raw plug-in available for Photoshop Elements      5.0 (Windows) is Camera Raw 4.5.
                  • The      latest version of the Camera Raw plug-in available for Photoshop Elements      6.0 (Windows, Mac) and Photoshop Elements 7.0 (Windows) is Camera Raw 5.6.
                  Regards,
                  Tom Hogarty
                  Lightroom, Camera Raw, DNG Product Manager
                  • 6. Re: Elements 5.7 Update
                    PevenseyPirate Level 1

                    Tom,

                     

                    That is absolutely appalling customer service. I have owned Elements 7 for less than a year and already you are discontinuing support for it. Money grabbing in the extreme.

                     

                    I could understand it if this was a major & incompatible release to ACR but 5.7 is just a point release supporting a few new cameras and you want to charge me £63.46 for an upgrade. You also want me to put the effort in to learning a new product and buying new documentation.

                     

                    Do you really expect customers to buy every release? Any decent vendor of PC software would support at least the current and previous release but suddenly without warning Elements 7 is dead. You could at least wait until Elements 9 went on sale.

                     

                    Pathetic !  

                    • 7. Re: Elements 5.7 Update
                      Monoclops2 Level 1

                      I would not have updated from Lightroom 2.6 to 2.7 if your documentation was correct.

                       

                      I am having second thoughts about upgrading to Lightroom 3 when it comes.

                      • 8. Re: Elements 5.7 Update
                        William886

                        Tom,

                         

                        I have just upgraded from PSE6 to PSE7 at the beginning of this year and you said PSE7 is being desupported for upcoming update on ACR. This really hurts and make me think about leaving adobe for the other image editing platforms especially when I acquire a newer camera in near future.

                         

                        William.

                        • 9. Re: Elements 5.7 Update
                          PevenseyPirate Level 1

                          Monoclops2 wrote:

                           

                          I would not have updated from Lightroom 2.6 to 2.7 if your documentation was correct.

                           

                          I am having second thoughts about upgrading to Lightroom 3 when it comes.

                           

                          Why oh why can't Adobe keep their products in step. I blame the Product Manager.

                           

                          LR2 isn't compatible with Elements 7 or 8 either in terms of imaging or database compatibility.

                           

                          If LR3 is compatible with Elements 8 I'm pretty confident the annual update of Elements will make them incompatible again.

                           

                          The more money we throw at Adobe the worse they seem to get.

                           

                          Come on Tom, please be upfront with your compatibility plans so we

                           

                          a) don't keep wasting money on the wrong product versions

                          b) don't have our workflows screwed up every few months

                          • 10. Re: Elements 5.7 Update
                            stihlchainsaw

                            Here's what I think:  Adobe posted the update to 5.7 and clearly stated  that it was compatible with Windows PSE 7 and Mac PSE 6.

                             

                            Like many other users, I downloaded the first round update and it didn't work.  Adobe management posted an "oops" stating that the download would be updated to fix the problem.  After the fix, I downloaded it again, it still didn't work.  And then, Adobe changed the compatibility statement after twice stating it would be compatible with the earlier Mac & Windows versions.

                             

                            Adobe needs to stick to the information in their announcements. They had plenty of time to review the compatibility information they posted TWICE. They need to make corrections to 5.7 so it works as it was announced worldwide.

                             

                            Adobe: Keep your customers excited and confidant about your customer support!  And when ACR 6 is posted, be clear about which PSE versions are compatible.

                            • 11. Re: Elements 5.7 Update
                              KKuja Level 1

                              The more money we throw at Adobe the worse they seem to get.


                              Yes... Welcome to the Adobe land. I'm beginning to feel that Photoshop isn't selling enough, so Adobe must try to force users to upgrade. The reason I haven't bought Photoshop is that I don't want to support Adobes strategy in this matter. I feel that being market leader has made Adobe greedy and arrogant. If there would be equal competitor to Photoshop, I guess Adobe would start to lose market share quite a fast (e.g. because lousy customer support).

                               

                              Come on Tom,  please be upfront with your compatibility plans so we

                               

                              a) don't  keep wasting money on the wrong product versions

                              b) don't have our  workflows screwed up every few months

                               

                              Every workflow change is also chance to change to other software. Which reminds me that PaintShop is actually quite a usable software. And I don't actually need Photoshop because I can use Lightroom to my RAW needs.

                              • 12. PSE 7 Win  & PSE 6 Mac compatibility
                                stihlchainsaw Level 1

                                Well, as of 9:30 AM CST on 4/23/10, Adobe still lists PSE7 (Win) and PSE6 (Mac) as compatible with ACR 5.7

                                 

                                Here's the link: http://www.adobe.com/special/photoshop/camera_raw/Camera_Raw_5.7_ReadMe.pdf

                                 

                                Second paragraph of the Adobe Photoshop Camera Raw 5.7 Read Me still states:

                                Compatibility

                                The Camera Raw 5.7 plug-in is not compatible with versions of Photoshop earlier than Photoshop CS4 or versions of Photoshop Elements earlier than Photoshop Elements 7.0 for Windows and Photoshop Elements 6 for Mac.

                                 

                                I say they need to make good on what they say.

                                 

                                 

                                 

                                 

                                • 13. Re: PSE 7 Win  & PSE 6 Mac compatibility
                                  Tom Hogarty Adobe Employee

                                  Again, I'd like to apologize for posting incorrect compatibility information as part of the initial release.  This was my responsibility and it should not diminish the reputation of the Camera Raw engineering and quality engineering teams that put a significant amount of effort into providing rapid camera support to our customers.

                                   

                                  More specific responses below.

                                   

                                  Regards,

                                  Tom Hogarty

                                  Lightroom, Camera Raw, DNG Product Manager

                                   

                                   

                                  @PevenseyPirate

                                  Yes, this is my responsibility.  Some responses to your comments:

                                  "LR2 isn't compatible with Elements 7 or 8 either in terms of imaging or database compatibility."

                                  Lightroom 2 shipped before Photoshop Elements 7 or Photoshop Elements 8 so catalog upgrade functionality could not be included in Lightroom 2 without significant modifications in the middle of the Lightroom 2 product cycle.  Photoshop Elements 7 and Photoshop Elements 8 catalog migration functionality will be included in the Lightroom 3 release.

                                   

                                  "If LR3 is compatible with Elements 8 I'm pretty confident the annual update of Elements will make them incompatible again."

                                  We're investigating the work required to allow customers of a version of Photoshop Elements that ships after Lightroom 3.0 ships to migrate to Lightroom 3.

                                   

                                  "Come on Tom, please be upfront with your compatibility plans..."

                                  The compatibility plans for our Lightroom customers and Photoshop customers is quite clear.  When we ship the next version of each application, raw support for the previous version is no longer updated.  We attempt to maximize the amount of raw support provided for each version as indicated by the fact that we added support for 9 new camera models for Photoshop CS4 even after Photoshop CS5 has been announced.  Photoshop Elements has actually enjoyed an extended raw support period that extends beyond one version of the product because the Photoshop Elements product release timing does not align well with our Lightroom and Camera Raw update cycle.  This can lead to significant overlaps in raw support updates for multiple versions of Photoshop Elements but the only commitment is to support the current shipping version of the product which is Photoshop Elements 8.

                                   

                                   

                                  @stihlchainsaw

                                  No need to speculate on what happened with this release.  I've explained it above and will explain it again.  An incomplete "package" was posted to Adobe.com that was missing the camera profile installer necessary to correctly interpret the color data from newly supported camera models.  The package was corrected and reposted.  That package was not related to Photoshop Elements 7 support in any way.  The incorrect documentation was a second error in this release in that it was not updated to reflect the change in support for Photoshop Elements and Premiere Elements products.  That documentation has been corrected. 

                                   

                                  "Adobe: Keep your customers excited and confidant about your customer support!  And when ACR 6 is posted, be clear about which PSE versions are compatible."

                                  Camera Raw 6 will be compatible with Photoshop Elements 8(Mac, Win) I'll let you know ahead of time that Camera Raw 6.0 will not be posted as a standalone plug-in. Due to the timing of our internal Creative Suite quality processes, the Camera Raw 6.0 plug-in was finalized much earlier than the Camera Raw 5.7 plug-in and actually provides less raw file format support than the 5.7 release.  Camera Raw 6.1 will follow soon after Photoshop CS5 ships and will be posted for Photoshop Elements 8 customers to download.

                                   

                                   

                                   

                                  • 14. Re: Elements 5.7 Update
                                    stihlchainsaw Level 1

                                    OK, thanks.

                                     

                                    I'll upgrade to PSE 8.

                                     

                                    I already run CS4 as my primary, I only use PSE as a novelty to keep aware

                                    of the differences between the two.  Many of my website readers use PSE,

                                    and it helps to understand their situations when they ask me questions.

                                    I'll be upgrading to CS5 as soon as it's on the shelves.

                                    --

                                    John Cowley

                                    Lonestardigital.com

                                     

                                    Again, I'd like to apologize for posting incorrect compatibility

                                    information as part of the initial release.  This was my responsibility

                                    and it should not diminish the reputation of the Camera Raw engineering

                                    and quality engineering teams that put a significant amount of effort into

                                    providing rapid camera support to our customers.

                                     

                                    More specific responses below.

                                     

                                    Regards,

                                    Tom Hogarty

                                    Lightroom, Camera Raw, DNG Product Manager