3 Replies Latest reply on Aug 26, 2010 12:15 AM by armibewob

    HAS ANYBODY SEEN THIS PROBLEM

    tworm Level 1

      I have posted this twice under two other threads but nobody has an answer. Surely there is somebody from Adobe that looks at these things.

       

      I have taken a Adobe Reader 9.3.0 msi file along with the other 5 files from a fresh install and ran msiexec /a AcroRead.msi /p AdbeRdrUpd932_all_incr.msp. Everything ran perfect. I then installed the new package that was created through a GPO. No problems.

       

      When I go to Edit>Preferences>Trust Manager>Settings all the settings on that form are grayed out. I also notice that when I open any pdf file and click on a link in that file it blocks the link even if it is another pdf file. There is no option to Allow or open or save or anything just a message saying your blocked and a link to a trust manager help file. 9.30 doesn't do that 9.3.1 doesn't do that but 9.3.2 does.

       

      I have tried installing from Adobe's web site  and then downloading the 9.3.2 msp file and running it. That works but incoporating 9.3.2 into 9.3.0 so I can push it out through Active Directory does not work.

       

      I have worked on this problem for days and tried everything I can think of and can not get this to work. Surely someone else has this problem. or somebody know how to fix it. I am desperate Please Help!!!

        • 1. Re: HAS ANYBODY SEEN THIS PROBLEM
          deepak_sisodia Level 2

          You are creating the package in a wrong way.

          Creating a package the way you are doing leaves a lot of files unpatched which means file which was supposed to change after applying the patch has actually not changed and it is same as it was before applying the patch.

          (Now exactly which files are left unpatched and which are correctly patched I am not sure of )

           

          I helped another user facing a similar issue like yours. You have to just create the package following the right process.

          Try out the steps mentioned in link below.

          http://forums.adobe.com/thread/617561?tstart=0

           

          Now one question arises, if you are doing something  in a wrong way then how come it worked in case of Reader 9.3.1??


          Here is the catch-


          9.3.1 was a zero day patch which means it would target only specific files.

          Only 2 files - Acroform.api and uthplay.dll are patched by the 9.3.1 patch.


          After you created the 9.3.1 package (via the wrong way) then actually these two files are not patched and are still same as these were for 9.3.

          So effectively you have all the files of 9.3 version so it works fine as if you have installed Reader 9.3.


          But 9.3.2 is a Quaterly update and it patches a lot of files (about 60-70 files).

          When you create a 9.3.2 package then some files are now updated to new version 9.3.2 and some are at the old version 9.3.

          Because of this mismatch of the files you are facing the problems.


          Intrestingly in earlier case (with 9.3.1) also there was the same problem but all the files were at the level of 9.3 so there was no mismatch and hence it worked!

          • 2. Re: HAS ANYBODY SEEN THIS PROBLEM
            tworm Level 1

            My problem is fixed. Thank you very much. I have always used the executable from Adobe's ftp site because we do not want Adobe Air and Adobe.com.

             

            I used the -nos_ne to extract the files to a folder. Then I ran the msp against that msi. This does not work. It has always worked in the past or though I thought.

             

            When you do it this way you get cab files, setup file, .ini files etc. I read another post that said the msi file like the exe file on the ftp site doesn't contain the air and com installs either. So I decided to try it and use the directions in your post and it works great. Don't know why it doesn't work with the exe file but I am happy.

             

            Thanks Again.

            • 3. Re: HAS ANYBODY SEEN THIS PROBLEM
              armibewob Level 1

              Hi,

               

              Sorry to bump this post but I seem to be having a similar problem with the latest 9.3.4 release. However I am using the MSI from the FTP site mentioned above.

               

              I download the 9.3.0 MSI, then apply the MSPs for 9.3.1, 9.3.2, 9.3.3 and 9.3.4 using:

               

              msiexec /p file.msp /a file.msi

               

              The resulting install has the options in Trust Maganer grayed out.

               

              Has anyone else had this problem with the latest version?

               

              Thanks

              Gareth

              Hestia Solar