2 Replies Latest reply on Apr 18, 2011 12:45 PM by Anadi KUMAR

    FB3 Maven plug-in eclipse (error JRE)

    sun.kati

      Hi

       

      Need some help with error :

      Eclipse is running in a JRE, but a JDK  is required
         Some Maven plugins may not work when importing  projects or updating  source folders.

       

      Trying to  install Maven plug-in in order to use it in flexmojo.

       

      Was   fallowing Maven instalation from  http://www.maximporges.com/2009/09/22/how-to-install-m2eclipse-in-flex-builder-3  /  with few changes in order to make them work:

       

      Changes  in  maximprogress steps

      - step4 - has change url  from  http://m2eclipse.sonatype.org/update/ to  http://m2eclipse.sonatype.org/sites/m2e - as his link return error

      -  step4 - only selected  “Europa Discovery Site” as “The Eclipse Project  Updates” return error

       

      All  instalation went smooth  but...

       

      When in flex 3 clicked : File -> New   ->  Other.... -> Maven -> Maven Project... eclipse return  'warning':

       

      Eclipse is running in a JRE, but a JDK  is required
         Some Maven plugins may not work when importing  projects or updating  source folders.

       

      Was googling to find solution   and as far as know, issue is that eclipse run on JRE , so need to  change  it to JDK.

       

      People advice  to add command in  eclipse.ini file:

       

      -vm   "C:\Java\jdk1.6.0_13\bin\javaw.exe"

       

      ...In my Flex  Bulder 3 root  directory there is not any eclipse.ini file but is  FlexBuilder.ini .  Think is the same? I added this line but still the  same error...

       

      Any advice  what is wrong?