2 Replies Latest reply on Sep 18, 2007 5:51 PM by Peter deHaan

    Deep Linking Trouble

    doof moof
      hey, i'm trying to get deep linking on the go but it's realy not happening for me. I'm using flex builder 3 with a very recent version of the sdk.

      I first tried doing my own custom deep linking implementation following the example on labs... http://labs.adobe.com/wiki/index.php/Flex_3:Feature_Introductions:_Deep_Linking#Example

      But i couldn't get it working. So i then tried just copy and paste the example code into a new project to see if that would work, but it wont! I seem to have everything in place and can't figure out whats wrong. I have ensured that the "Enable integration with browser navigation" is checked, as it was by default in flex builder 3, and the deeplinking javascript and historyFrame html is showing up in my bin folder, and the refernce to it is there in my applications html wrapper. I have tried running the app localy from the run command in fb3 in both ie7 and firefox, and have done the same from my server with a real http:// url. But nothing is happening with the browser when i tab through the tab navigator, and nothing in the app when i put the fragment at the end of the address in the browser.

      I am completely confused, it can't be anything i've done wrong because i have copied the example straight into the main application mxml file.

      one thing that may hold a clue is a trace statment i have added to the end of the actuallyUpdateURL() function....

      var s:String = URLUtil.objectToString(o);
      browserManager.setFragment(s);
      browserManager.setTitle(t);
      trace("s: "+s); // output - s: view=1
      trace("fragment: "+browserManager.fragment); // output - fragment: null

      so when i change the tab navigator and this function calls browserManager.setFragment(s); the string it's passing as the new fagment is formated fine but when i then check browserManager.fragment it has not been set and out puts null.

      So i guess my prblem is somewhere between setFragment and then the fragment actually getting set. Can anyone help me work out what is goin wrong here? How can i find why my fragment is net getting set?




        • 1. Re: Deep Linking Trouble
          doof moof Level 1
          ok i have an update here for anyone thats interested, i changed the sdk used by the project back to the moxie M2 version that comes with the FB3 beta and the deep linking now works fine. Does anyone know of any changes that have been made to the sdk that could have stopped the newer version from working all together. I would like to find out whats happend since the origional beta reliese version as i would realy prefer to be using a more up to date version of the sdk. even if anyone knows where i can go to find where the breakage happend for myself i would be very greatfull.
          • 2. Re: Deep Linking Trouble
            Peter deHaan Level 4
            doof moof,

            Are you testing the deep linking feature from a file:/// path, or using a server and http://?
            I find that you almost always need to put the files up on a server for the Flex+JS to work as expected.

            Peter