1 Reply Latest reply on Apr 28, 2010 6:36 AM by sonicDivx

    Setting up a Remote Server (Virtual) and using CFC Generator Extension

    sonicDivx

      I am trying to setup Coldfusion Builder to work with a Coldfusion Server setup in a virtual machine and then use the ORM CFC Generator. For some background I use Virtual Servers to better emulate my Test and Production environments because often times I am working in environments that a local install will not experience the issues found (e.g. Gov't where Dev is not the same as TEST or PROD, Corp enterprise, crazy server mappings, firewalls, etc....)

       

      My Virtual Server is configured as follows (minor typing discrepencies should be ignored as just my jazz hands)

       

      Virtual Box

      Windows 2008 R2 Web Server Build (IIS 7.5). Server security is default (i.e. means user rights are restricted in certain directories)

      IP Address access only (network IP of 10.0.0.11) , so no dns names

       

      IIS 7.5 Configuration

      1 site running at 10.0.0.11 port:80 (access via  http://10.0.0.11)

      virtual directory for  CFIDE (physical location:  C:\inetpub\wwwroot)

      website (mysite) is located in C:\websites\mysite  (this is because there are are websites setup and I never user inetpub\wwwroot)

       

      Eclipse configuration

      Eclipse custom build with CFB plugin

      Project files located in D:\Projects\Workspace\mysite (this is the site that corresponds to the website on the virtual server)

      There are no network shares to Webserver.

      FTP is only way to move files from Eclipse to Virtual Server.

       

      Coldfusion Server Settings (ignoring first page)


      Remote Server Settings:

      Port:2910

      username: admin

      password: *****

      Document Root: C:\websites\mysite

       

      Mappings (Empty)

      Virtual Host Settings (Tried Empty and populated)

       

       

      I have tried various configurations for the Server and Adobe CFC Generator extension and the only thing I have been able to accomplish is the "Create CFC" function. This was accomplished by using the following settings for install of CFC Generator

      Map Server Root :  D:\Projects\Workspace\mysite

      Select Install Location: D:\Projects\Workspace\mysite\CFBExtension

      once installed I FTP'd the Adobe CFC Generator

       

      Then ran Create CFC and type this

      C:\websites\mysite\nonorm       (nonorm is a test directory)

      files generated

       

      Then I try the Create ORM CFC and nothing happens (no errors that I can tell)

       

      So part of the question that the documentation does not really answer is how the Mappings and Virtual Host Settings impact Extension installation, if at all? How is Mozilla Browser used for extensions and how to verify is being used?

       

      The various paths and what they should point to. If someone says should map to drive on Virtual machine or local machine should use C: drive to store files or paths should match or something along those lines, that person will be virtually flogged.   Oh and don't say install CF locally (sorry that is a cop out and does not speak my development considerations)

       

      I have seen various posts but have not found a real definitive explanation or anything.

       

       

      Thanks for the help. Hopefully can get fully resolved and repeatable for others.

       

      Kevin

        • 1. Re: Setting up a Remote Server (Virtual) and using CFC Generator Extension
          sonicDivx Level 1

          Here is an update. Well it seems my problem was with the setting to use Mozilla Browser for extensions.  I decided to install the Standalone version of CF builder and I experienced the same problem. At that point I started playing with other settings.  Once I turned Mozilla Browser setting off the ORM CFC generator worked.

           

          I wonder if there are several things at play. First my default browser is Firefox (latest version running). On my plugin based eclipse build the debug console showed an error in the SWT (see below).  Also It  seems Adobe is developing a habit of development that does not handle 3rd party component updates well ( CF 8 ExtJs, YUI., CFB Aptana, etc...).  So here is the error and maybe someone has some clues as to why. I am still looking into it.

           

          !MESSAGE Unhandled event loop exception
          !STACK 0
          org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.swt.SWTErr
          or: No more handles [Could not detect registered XULRunner to use])
                  at org.eclipse.swt.SWT.error(SWT.java:3884)
                  at org.eclipse.swt.SWT.error(SWT.java:3799)
                  at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.ja
          va:137)
                  at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3855)
                  at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3476)
                  at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
                  at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
                  at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
                  at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
                  at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.ja
          va:332)
                  at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.jav
          a:493)
                  at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                  at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEAppli
          cation.java:113)
                  at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandl
          e.java:194)
                  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runAppli
          cation(EclipseAppLauncher.java:110)
                  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Ec
          lipseAppLauncher.java:79)
                  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.ja
          va:368)
                  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.ja
          va:179)
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
          java:39)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
          sorImpl.java:25)
                  at java.lang.reflect.Method.invoke(Method.java:597)
                  at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
                  at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
                  at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
          Caused by: org.eclipse.swt.SWTError: No more handles [Could not detect registere
          d XULRunner to use]
                  at org.eclipse.swt.SWT.error(SWT.java:3910)
                  at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:472)
                  at org.eclipse.swt.browser.Browser.<init>(Browser.java:119)
                  at com.adobe.ide.coldfusion.appcodegeneration.runtime.dialogs.HTMLConten
          tDialog.createDialogArea(HTMLContentDialog.java:111)
                  at org.eclipse.jface.dialogs.TitleAreaDialog.createContents(TitleAreaDia
          log.java:147)
                  at com.adobe.ide.coldfusion.appcodegeneration.runtime.dialogs.HTMLConten
          tDialog.createContents(HTMLContentDialog.java:164)
                  at org.eclipse.jface.window.Window.create(Window.java:431)
                  at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
                  at org.eclipse.jface.window.Window.open(Window.java:790)
                  at com.adobe.ide.coldfusion.appcodegeneration.runtime.CFMenuHandler$5.ru
          n(CFMenuHandler.java:389)
                  at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
                  at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.ja
          va:134)
                  ... 22 more