19 Replies Latest reply on Jun 28, 2010 1:59 PM by jcook4now

    ColdFusion Builder won't start at all

    _jmprich_

      After installing Coldfusion Builder and Flash Builder as standalone installations on WinXP, I can't start either of them.

       

      In the Coldfusion Builder folder where the the .exe is located, I get the hs_pid.log log files that you would normally see from a problem in eclipse. I get the same exact problem with Flash Builder with the same hs error logs after the program fails. Obviously they are suffering the same problem and the root of the problem is the embedded eclipse they are using.

       

      Any ideas? I realize that it would be difficult to debug considering the complete lack of details about why the apps fail. That's due to Adobe offering no user feedback when they fail.

       

      My guess is that it's a problem with the JRE in the installs, but there's no debugging info to find out what is going on. When I try FlashBuilderC.exe standalone, I get the following:

       

      C:\Program Files\Adobe>"Adobe Flash Builder 4\FlashBuilderC.exe"
      #
      # A fatal error has been detected by the Java Runtime Environment:
      #
      #  Internal Error (os_windows.cpp:3266), pid=19764, tid=26520
      #  Error: DuplicateHandle failed

       

      #
      # JRE version: (uninitialized)
      # Java VM: Java HotSpot(TM) Client VM (14.2-b01 mixed mode, sharing windows-x86 )
      # An error report file with more information is saved as:
      # C:\Program Files\Adobe\hs_err_pid19764.log
      #
      # If you would like to submit a bug report, please visit:
      #   http://java.sun.com/webapps/bugreport/crash.jsp
      #

       

      I can run Flashbuilder as an eclipse plugin, and I suspect that I could run CFBuilder as a plugin also but that's not really what I want to do. It's just frustrating that products that cost thousands of dollars fail silently, offer no recovery, and won't run at all from a fresh standalone install.

        • 1. Re: ColdFusion Builder won't start at all
          Balaji Sridhar Level 2

          Hi,

           

          Could you attach the log files created under FB and CFB?

           

          Also, which is the java version you are using?

           

          Thanks,

          Balaji

          http://balajisridhar.wordpress.com

          • 2. Re: ColdFusion Builder won't start at all
            _jmprich_ Level 1

            I'm using 1.6 for my Java stuff and for the plugin versions of CFB and FB4. Each builder standalone has it's own JRE which appears to be the same version (except for FB4 which is only a couple builds off). Both builders reference the same internal error file os_windows.cpp. As I mentioned earlier, both IDEs are currently running fine as eclipse plugins in my home directory.

             

             

            U:\>java -version
            java version "1.6.0_18"
            Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
            Java HotSpot(TM) Client VM (build 16.0-b13, mixed mode, sharing)

             

             

            C:\Program Files\Adobe\Adobe ColdFusion Builder\jre\bin>set PATH=

            C:\Program Files\Adobe\Adobe ColdFusion Builder\jre\bin>.\java.exe -version
            java version "1.6.0_18"
            Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
            Java HotSpot(TM) Client VM (build 16.0-b13, mixed mode)

             

             

            C:\Program Files\Adobe\Adobe Flash Builder 4\jre\bin>set PATH=

            C:\Program Files\Adobe\Adobe Flash Builder 4\jre\bin>.\java.exe -version
            java version "1.6.0_16"
            Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
            Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode)

             

             

            hs_err_pid27396.log

            ------------------------------------------------------------------------------------------ -------

             

            #
            # A fatal error has been detected by the Java Runtime Environment:
            #
            #  Internal Error (os_windows.cpp:3276), pid=27396, tid=29696
            #  Error: DuplicateHandle failed

            #
            # JRE version: (uninitialized)
            # Java VM: Java HotSpot(TM) Client VM (16.0-b13 mixed mode, sharing windows-x86 )
            # If you would like to submit a bug report, please visit:
            #   http://java.sun.com/webapps/bugreport/crash.jsp
            #

            ---------------  T H R E A D  ---------------

            Current thread is native thread

            Stack: [0x00030000,0x00130000],  sp=0x0012fba4,  free space=3fe0012fbb4k
            Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
            V  [jvm.dll+0x1f4000]
            V  [jvm.dll+0xa1cc8]
            V  [jvm.dll+0x17d0e3]
            V  [jvm.dll+0x1030a0]
            C  [eclipse_1206.dll+0x501e]
            C  [eclipse_1206.dll+0x4721]
            C  [eclipse_1206.dll+0x152c]
            C  [CFBuilder.exe+0x1495]
            C  [CFBuilder.exe+0x1181]
            C  [CFBuilder.exe+0x4a3a]
            C  [kernel32.dll+0x17077]


            ---------------  P R O C E S S  ---------------

            VM state:not at safepoint (not fully initialized)

            VM Mutex/Monitor currently owned by a thread: None

            Dynamic libraries:
            0x00400000 - 0x0040e000     C:\Program Files\Adobe\Adobe ColdFusion Builder\CFBuilder.exe
            0x7c900000 - 0x7c9b2000     C:\WINNT\system32\ntdll.dll
            0x7c800000 - 0x7c8f6000     C:\WINNT\system32\kernel32.dll
            0x6f000000 - 0x6f06c000     C:\WINNT\system32\SYSFER.DLL
            0x7e410000 - 0x7e4a1000     C:\WINNT\system32\USER32.dll
            0x77f10000 - 0x77f59000     C:\WINNT\system32\GDI32.dll
            0x773d0000 - 0x774d3000     C:\WINNT\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x-ww _35d4ce83\COMCTL32.dll
            0x77c10000 - 0x77c68000     C:\WINNT\system32\msvcrt.dll
            0x77dd0000 - 0x77e6b000     C:\WINNT\system32\ADVAPI32.dll
            0x77e70000 - 0x77f02000     C:\WINNT\system32\RPCRT4.dll
            0x77fe0000 - 0x77ff1000     C:\WINNT\system32\Secur32.dll
            0x77f60000 - 0x77fd6000     C:\WINNT\system32\SHLWAPI.dll
            0x76390000 - 0x763ad000     C:\WINNT\system32\IMM32.DLL
            0x10000000 - 0x1001e000     C:\WINNT\system32\privman32.dll
            0x7c9c0000 - 0x7d1d7000     C:\WINNT\system32\SHELL32.dll
            0x72000000 - 0x72014000     C:\Program Files\Adobe\Adobe ColdFusion Builder\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_12 06.dll
            0x77c00000 - 0x77c08000     C:\WINNT\system32\VERSION.dll
            0x6d8b0000 - 0x6db47000     C:\Program Files\Adobe\Adobe ColdFusion Builder\jre\bin\client\jvm.dll
            0x76b40000 - 0x76b6d000     C:\WINNT\system32\WINMM.dll
            0x7c360000 - 0x7c3b6000     C:\WINNT\system32\MSVCR71.dll
            0x76bf0000 - 0x76bfb000     C:\WINNT\system32\PSAPI.DLL

            VM Arguments:
            java_command: <unknown>
            Launcher Type: generic

            Environment Variables:
            JAVA_HOME=C:\java\jdk1.6.0_18\jre
            JRE_HOME=C:\java\jdk1.6.0_18\jre;C:\java\jre6
            CLASSPATH=.;JDK_HOME;JAVA_HOME;C:\java\jre6\lib\ext\QTJava.zip
            PATH=C:/Program Files/Adobe/Adobe ColdFusion Builder/jre/bin/client;C:/Program Files/Adobe/Adobe ColdFusion Builder/jre/bin;C:\Program Files\Adobe\Adobe ColdFusion Builder;C:\java\jdk1.6.0_18\bin;C:\java\jdk1.6.0_18\lib;C:\java\jdk1.6.0_18;C:\java\jdk1. 6.0_18\jre;C:\java\flex_sdk_4\bin;C:\java\flex_sdk_4\;C:\Program Files\Serena\Dimensions 10.1\CM\prog;C:\servers\subversion;C:\Ent\Appl\Prod\Oracle8i\bin;c:\ent\appl\prod\Oracle8 i\JRE\bin;C:\WINNT\system32;C:\WINNT;C:\Serena\CHANGE~1\DIMENS~1\9.1\PROG;c:\ent\appl\prod \perl\5.00502\bin\MSWin32-x86;c:\ent\appl\prod\perl\5.00502\bin;C:\WINNT\system32\wbem;c:\ ent\appl\prod\bin;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\ATI Technologies\ATI.ACE\;C:\DSM\Script\;C:\ent\appl\prod\Exceed\Connectivity\10.00\Accessori es\;;C:\servers\cake\cake\console;C:\servers\xampplite\php;C:\java\apache-maven\bin;C:\jav a\ant\bin;C:\Program Files\CA\SC\CAWIN;C:\Program Files\ActivIdentity\ActivClient\;C:\Program Files\QuickTime\QTSystem\;C:\servers\SDK\bin;C:\Program Files\IDM Computer Solutions\UltraEdit\
            USERNAME=pritcjm
            OS=Windows_NT
            PROCESSOR_IDENTIFIER=x86 Family 6 Model 23 Stepping 6, GenuineIntel



            ---------------  S Y S T E M  ---------------

            OS: Windows XP Build 2600 Service Pack 3

            CPU:total 2

            Memory: 4k page, physical 3652840k(1812720k free), swap 7137288k(4992188k free)

            vm_info: Java HotSpot(TM) Client VM (16.0-b13) for windows-x86 JRE (1.6.0_18-b07), built on Dec 17 2009 13:35:55 by "java_re" with MS VC++ 7.1 (VS2003)

            time: Thu Apr 29 08:52:56 2010
            elapsed time: 0 seconds


            • 3. Re: ColdFusion Builder won't start at all
              vinu_kumar_cf

              There could be some incompatible library in the system. Can you keep only the default paths, removing others in the path variable in a command prompt and launch CFBuilder?

               

              - Vinu

              • 4. Re: ColdFusion Builder won't start at all
                _jmprich_ Level 1

                Yea, I tried that too. I also went and cleared all the env variables in the error log with no luck. Basically the same errors. I included the process part below.

                 

                It seems the problem is all throughout our office. Three other of my colleagues are having the exact same problem after getting their new CFB and FB4 last week. They get the same error logs in the installation folders of the standalone install.

                 

                ---------------------------------

                 

                 

                C:\Program Files\Adobe\Adobe ColdFusion Builder>set PATH=

                 

                C:\Program Files\Adobe\Adobe ColdFusion Builder>set CLASSPATH=

                 

                C:\Program Files\Adobe\Adobe ColdFusion Builder>set JAVA_HOME=

                 

                C:\Program Files\Adobe\Adobe ColdFusion Builder>set JRE_HOME=

                 

                C:\Program Files\Adobe\Adobe ColdFusion Builder>CFBuilder.exe

                 

                 


                ---------------  P R O C E S S  ---------------

                 

                VM state:not at safepoint (not fully initialized)

                 

                VM Mutex/Monitor currently owned by a thread: None

                 

                Dynamic libraries:
                0x00400000 - 0x0040e000     C:\Program Files\Adobe\Adobe ColdFusion Builder\CFBuilder.exe
                0x7c900000 - 0x7c9b2000     C:\WINNT\system32\ntdll.dll
                0x7c800000 - 0x7c8f6000     C:\WINNT\system32\kernel32.dll
                0x6f000000 - 0x6f06c000     C:\WINNT\system32\SYSFER.DLL
                0x7e410000 - 0x7e4a1000     C:\WINNT\system32\USER32.dll
                0x77f10000 - 0x77f59000     C:\WINNT\system32\GDI32.dll
                0x773d0000 - 0x774d3000     C:\WINNT\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x-ww _35d4ce83\COMCTL32.dll
                0x77c10000 - 0x77c68000     C:\WINNT\system32\msvcrt.dll
                0x77dd0000 - 0x77e6b000     C:\WINNT\system32\ADVAPI32.dll
                0x77e70000 - 0x77f02000     C:\WINNT\system32\RPCRT4.dll
                0x77fe0000 - 0x77ff1000     C:\WINNT\system32\Secur32.dll
                0x77f60000 - 0x77fd6000     C:\WINNT\system32\SHLWAPI.dll
                0x76390000 - 0x763ad000     C:\WINNT\system32\IMM32.DLL
                0x10000000 - 0x1001e000     C:\WINNT\system32\privman32.dll
                0x7c9c0000 - 0x7d1d7000     C:\WINNT\system32\SHELL32.dll
                0x72000000 - 0x72014000     C:\Program Files\Adobe\Adobe ColdFusion Builder\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_12 06.dll
                0x77c00000 - 0x77c08000     C:\WINNT\system32\VERSION.dll
                0x6d8b0000 - 0x6db47000     C:\Program Files\Adobe\Adobe ColdFusion Builder\jre\bin\client\jvm.dll
                0x76b40000 - 0x76b6d000     C:\WINNT\system32\WINMM.dll
                0x7c360000 - 0x7c3b6000     C:\WINNT\system32\MSVCR71.dll
                0x76bf0000 - 0x76bfb000     C:\WINNT\system32\PSAPI.DLL

                 

                VM Arguments:
                java_command: <unknown>
                Launcher Type: generic

                 

                Environment Variables:
                PATH=C:/Program Files/Adobe/Adobe ColdFusion Builder/jre/bin/client;C:/Program Files/Adobe/Adobe ColdFusion Builder/jre/bin;
                USERNAME=pritcjm
                OS=Windows_NT
                PROCESSOR_IDENTIFIER=x86 Family 6 Model 23 Stepping 6, GenuineIntel

                • 5. Re: ColdFusion Builder won't start at all
                  Vinu_kumar_t Level 1

                  Are all these machines upgraded from windows NT? Can you try by copying MSVCR71.dll from c:\windows\system32 to C:\Program Files\Adobe\Adobe ColdFusion Builder\jre\bin. The eclipse libraries shipped with CF and FB require MSVCR71.dll and may not be loading it properly.

                   

                  Thanks

                  - Vinu

                  • 6. Re: ColdFusion Builder won't start at all
                    _jmprich_ Level 1

                    I'm not really sure if these are updated machines or not. You may be right though, because the system32 folder is under winnt rather than windows. Anyway, I copied over the DLL but no luck. I still get the same error log.

                     

                    Thanks

                    • 7. Re: ColdFusion Builder won't start at all
                      Vinu_kumar_t Level 1

                      Hi,

                      Do you have a software called "Privilege Manager" by any chance? Just trying to check the dll's found in the path for incompatibilities.

                       

                      - Vinu

                      • 8. Re: ColdFusion Builder won't start at all
                        _jmprich_ Level 1

                        We do have a Privilege Manager program running called Beyond Trust. Both were installed with BT, which may be the problem. The only reason I didn't suspect that was because I get the failure even when I try to execute ColdFusion builder from an Administrator console.

                         

                        So what I did was create a cmd prompt with escalated privilege, navigate to the Adobe Program Files folder and try to execute the exe with that console. That usually solves any privilege problems I encounter but not in this case. I still get the same error log.

                         

                         

                         

                        ---------------  P R O C E S S  ---------------

                        VM state:not at safepoint (not fully initialized)

                        VM Mutex/Monitor currently owned by a thread: None

                        Dynamic libraries:
                        0x00400000 - 0x0040e000     C:\Program Files\Adobe\Adobe ColdFusion Builder\CFBuilder.exe
                        0x7c900000 - 0x7c9b2000     C:\WINNT\system32\ntdll.dll
                        0x7c800000 - 0x7c8f6000     C:\WINNT\system32\kernel32.dll
                        0x6f000000 - 0x6f06c000     C:\WINNT\system32\SYSFER.DLL
                        0x7e410000 - 0x7e4a1000     C:\WINNT\system32\USER32.dll
                        0x77f10000 - 0x77f59000     C:\WINNT\system32\GDI32.dll
                        0x773d0000 - 0x774d3000     C:\WINNT\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x-ww _35d4ce83\COMCTL32.dll
                        0x77c10000 - 0x77c68000     C:\WINNT\system32\msvcrt.dll
                        0x77dd0000 - 0x77e6b000     C:\WINNT\system32\ADVAPI32.dll
                        0x77e70000 - 0x77f02000     C:\WINNT\system32\RPCRT4.dll
                        0x77fe0000 - 0x77ff1000     C:\WINNT\system32\Secur32.dll
                        0x77f60000 - 0x77fd6000     C:\WINNT\system32\SHLWAPI.dll
                        0x76390000 - 0x763ad000     C:\WINNT\system32\IMM32.DLL
                        0x10000000 - 0x1001e000     C:\WINNT\system32\privman32.dll
                        0x7c9c0000 - 0x7d1d7000     C:\WINNT\system32\SHELL32.dll
                        0x72000000 - 0x72014000     C:\Program Files\Adobe\Adobe ColdFusion Builder\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_12 06.dll
                        0x77c00000 - 0x77c08000     C:\WINNT\system32\VERSION.dll
                        0x6d8b0000 - 0x6db47000     C:\Program Files\Adobe\Adobe ColdFusion Builder\jre\bin\client\jvm.dll
                        0x76b40000 - 0x76b6d000     C:\WINNT\system32\WINMM.dll
                        0x7c360000 - 0x7c3b6000     C:\WINNT\system32\MSVCR71.dll
                        0x76bf0000 - 0x76bfb000     C:\WINNT\system32\PSAPI.DLL

                        • 9. Re: ColdFusion Builder won't start at all
                          Vinu_kumar_t Level 1

                          The library is in the path and i am not sure if it will cause any issue. We try to duplicate this issue in our end and see if we can provide any workaround for you. Also, have you tried installing CFB or FB outside "Program Files"? I guess you have installed eclipse outside Program Files. Priv manager targets applications inside Program Files I guess.

                           

                          - Vinu

                          1 person found this helpful
                          • 10. Re: ColdFusion Builder won't start at all
                            _jmprich_ Level 1

                            Beyond Trust could be the problem, but I wanted to make sure it had nothing to do with CFB/FB. BT does interfere with other software, but usually when I run as an elevated user those problems go away. So far CFB/FB are the only two pieces of software that are completely failing, even when I execute as an elevated user.

                             

                            I have installed both as plugins outside of the protected C:\ drive into a separate eclipse installation, but no I haven't tried to install the standalone outside of Program Files. I can try that to help narrow down the problem if you would like.

                            • 11. Re: ColdFusion Builder won't start at all
                              Vinu_kumar_t Level 1

                              When you find time, please do try to install outside Program Files. We would try to duplicate this problem

                              in our end and see if we can find a work around.

                               

                              - Vinu

                              • 12. Re: ColdFusion Builder won't start at all
                                _jmprich_ Level 1

                                Ok, it seems that Beyond Trust is most likely the issue here. Afer uninstalling CFB standalone, and then reinstalling it (without elevated priv) into My Documents, CFB now works. There was a message from the CFB installer that there were errors related to installing without administrator privileges, but it seems to run without any problems. I'm not sure why it says that you must install CFB as an administrator though, if it works without admin.

                                 

                                Unfortunately, with FB4 the installer will not let you continue without admin. So after installing FB4 into My Documents _with_ admin, I can no longer start FB4 standalone as a regular user... even in my own documents folder. Once again this fault lies with Beyond Trust because I am able to run FB4 with elevated privileges.

                                 

                                So the moral of the story here seems to be that Adobe products don't mix well with Beyond Trust products. On that note we just got CS5, and I'm a more than a little nervous that we are going to see the same problems there. Only this time the consequences will be much worse because Photoshop doesn't exactly have an eclipse plugin .

                                • 13. Re: ColdFusion Builder won't start at all
                                  Vinu_kumar_t Level 1

                                  CFB and FB requires admin privileges for adding other third part plugins or updating itself. Running with elevated permissions should be enough. That said the issue could be lying with Eclipse and Priv. manager not playing well. Other Adobe products may play nicely with priv. manager. Also since you want to use both FB and CFB, installing both into same eclipse is more advantageous.

                                   

                                  Thanks

                                  - Vinu

                                  • 14. Re: ColdFusion Builder won't start at all
                                    _jmprich_ Level 1

                                    I can indeed run with elevated privileges but this is far from optimal. There are extra steps to running in this manner, and Beyond Trust is extremely slow to respond. My original workaround is to run as a plugin, and I guess this will have to do.

                                     

                                    One thing... I'm not entirely convinced eclipse is the problem. I have other eclipse installations that do not suffer these startup problems. Who knows, it seems like just a bad combination. I think ultimately, it's Beyond Trust incorrectly handling permissions of the execution and the DLLs being loaded.

                                    • 15. Re: ColdFusion Builder won't start at all
                                      jcook4now

                                      I am having the exact same problem but I don't have Beyond Trust installed and am running with local admin privileges.  My error log also the same error:

                                      #
                                      # A fatal error has been detected by the Java Runtime Environment:
                                      #
                                      #  Internal Error (os_windows.cpp:3276), pid=6056, tid=5844
                                      #  Error: DuplicateHandle failed

                                       

                                      #
                                      # JRE version: (uninitialized)
                                      # Java VM: Java HotSpot(TM) Client VM (16.0-b13 mixed mode, sharing windows-x86 )
                                      # If you would like to submit a bug report, please visit:
                                      #   http://java.sun.com/webapps/bugreport/crash.jsp
                                      #

                                       

                                      ---------------  T H R E A D  ---------------

                                       

                                      Current thread is native thread

                                       

                                      Stack: [0x00030000,0x00130000],  sp=0x0012fba4,  free space=3fe0012fbb4k
                                      Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
                                      V  [jvm.dll+0x1f4000]
                                      V  [jvm.dll+0xa1cc8]
                                      V  [jvm.dll+0x17d0e3]
                                      V  [jvm.dll+0x1030a0]
                                      C  [eclipse_1206.dll+0x501e]
                                      C  [eclipse_1206.dll+0x4721]
                                      C  [eclipse_1206.dll+0x152c]
                                      C  [CFBuilder.exe+0x1495]
                                      C  [CFBuilder.exe+0x1181]
                                      C  [CFBuilder.exe+0x4a3a]
                                      C  [kernel32.dll+0x17067]

                                       


                                      ---------------  P R O C E S S  ---------------

                                       

                                      VM state:not at safepoint (not fully initialized)

                                       

                                      VM Mutex/Monitor currently owned by a thread: None

                                       

                                      Dynamic libraries:
                                      0x00400000 - 0x0040e000     C:\Program Files\Adobe\Adobe ColdFusion Builder\CFBuilder.exe
                                      0x7c900000 - 0x7c9b2000     C:\WINDOWS\system32\ntdll.dll
                                      0x7c800000 - 0x7c8f6000     C:\WINDOWS\system32\kernel32.dll
                                      0x7e410000 - 0x7e4a1000     C:\WINDOWS\system32\USER32.dll
                                      0x77f10000 - 0x77f59000     C:\WINDOWS\system32\GDI32.dll
                                      0x773d0000 - 0x774d3000     C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x- ww_35d4ce83\COMCTL32.dll
                                      0x77c10000 - 0x77c68000     C:\WINDOWS\system32\msvcrt.dll
                                      0x77dd0000 - 0x77e6b000     C:\WINDOWS\system32\ADVAPI32.dll
                                      0x77e70000 - 0x77f02000     C:\WINDOWS\system32\RPCRT4.dll
                                      0x77fe0000 - 0x77ff1000     C:\WINDOWS\system32\Secur32.dll
                                      0x77f60000 - 0x77fd6000     C:\WINDOWS\system32\SHLWAPI.dll
                                      0x76390000 - 0x763ad000     C:\WINDOWS\system32\IMM32.DLL
                                      0x10000000 - 0x1001e000     C:\WINDOWS\system32\privman32.dll
                                      0x7c9c0000 - 0x7d1d7000     C:\WINDOWS\system32\SHELL32.dll
                                      0x72000000 - 0x72014000     C:\Program Files\Adobe\Adobe ColdFusion Builder\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_12 06.dll
                                      0x77c00000 - 0x77c08000     C:\WINDOWS\system32\VERSION.dll
                                      0x6d8b0000 - 0x6db47000     C:\Program Files\Adobe\Adobe ColdFusion Builder\jre\bin\client\jvm.dll
                                      0x76b40000 - 0x76b6d000     C:\WINDOWS\system32\WINMM.dll
                                      0x7c340000 - 0x7c396000     C:\WINDOWS\system32\MSVCR71.dll
                                      0x76bf0000 - 0x76bfb000     C:\WINDOWS\system32\PSAPI.DLL

                                       

                                      VM Arguments:
                                      java_command: <unknown>
                                      Launcher Type: generic

                                       

                                      Environment Variables:
                                      CLASSPATH=.;C:\Program Files\Java\jre6\lib\ext\QTJava.zip
                                      PATH=C:/Program Files/Adobe/Adobe ColdFusion Builder/jre/bin/client;C:/Program Files/Adobe/Adobe ColdFusion Builder/jre/bin;C:\Program Files\Adobe\Adobe ColdFusion Builder;C:\CF9\verity\k2\_nti40\bin;C:\Program Files\Windows Resource Kit\;C:\ColdFusion8\verity\k2\_nti40\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System 32\Wbem;w:\mssql\binn;w:\pb050_dll;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program Files\Wave Systems Corp\Gemalto\Access Client\v5\;C:\Program Files\Gemplus\GemSafe Libraries\BIN;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program Files\Common Files\Roxio Shared\9.0\DLLShared\;C:\WINDOWS\system32\WindowsPowerShell\v1.0;C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\Microsoft SQL Server\90\DTS\Binn\;C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\;C:\Program Files\TortoiseSVN\bin;c:\utils;C:\Program Files\QuickTime\QTSystem\
                                      USERNAME=clid1215
                                      OS=Windows_NT
                                      PROCESSOR_IDENTIFIER=x86 Family 6 Model 23 Stepping 6, GenuineIntel

                                       

                                       

                                       

                                      ---------------  S Y S T E M  ---------------

                                       

                                      OS: Windows XP Build 2600 Service Pack 3

                                       

                                      CPU:total 2

                                       

                                      Memory: 4k page, physical 3667860k(2555860k free), swap 7690296k(6688000k free)

                                       

                                      vm_info: Java HotSpot(TM) Client VM (16.0-b13) for windows-x86 JRE (1.6.0_18-b07), built on Dec 17 2009 13:35:55 by "java_re" with MS VC++ 7.1 (VS2003)

                                       

                                      time: Mon Jun 28 11:56:40 2010
                                      elapsed time: 0 seconds

                                      • 16. Re: ColdFusion Builder won't start at all
                                        jcook4now Level 1

                                        Whoops!  My mistake - I DO have BeyondTrust Privilege Manager Client installed - it appears to be installed automatically by my company's group policy. . .

                                        • 17. Re: ColdFusion Builder won't start at all
                                          _jmprich_ Level 1

                                          That makes me feel more confident that BT is the source of the problem. I've found Beyond Trust to be a really bad solution to the security problems in windows. It has broken more of my software than I can count - which fall upon deaf ears in corporate situatations. I guess the plan is that if a computer is completely unproductive then you can't use it and it is, therefore, completely secure.

                                           

                                          The only workaround that I can suggest is to install it as a plugin to eclipse. You can install it into your home directory without admin, but that only fixes CFB, not FB4. FB4 will still ask for the admin password every time using BT.

                                           

                                          The problem with the eclipse install is that the Data Source stuff doesn't work quite right. I find that my web services invalidate themselves some how, and the data explorer gives an error. You will then have to re-generate your webservice objects every time.

                                          • 18. Re: ColdFusion Builder won't start at all
                                            jcook4now Level 1

                                            Thanks for the info!  Fortunately, my network support group is willing to uninstall BT in this case.  I'll let you know if that solves my problem. . .

                                             

                                            Jeff

                                            • 19. Re: ColdFusion Builder won't start at all
                                              jcook4now Level 1

                                              FYI - Beyond Trust is still "installed" in Add/Remove Programs but my helpdesk had me delete the C:\Windows\Beyond Trust folder and now CF Builder loads ok even with BT installed. . .  Go figure. . .

                                               

                                              Jeff