5 Replies Latest reply on May 17, 2010 3:26 AM by hans-g.

    FAVICON DOESN’T APPEAR

    lalbarado

      I am working in DW CS4. My browser IE7 and my OS is Vista. I used a png file and resized and saved it to 16x16 pixels. I then went to www.dynamicdrive.com to convert my png file to an ico file. I saved the ico file into the images folder. Next I went under “Code View” and added this line below my title in the head section:

       

      <link rel="shortcut icon" type="image/x-icon" href="images/favicon.ico">

       

      I also have the png file stored under the images folder with the the same name just different extensions. The file name and what is called out in the code are the same.

       

      It does not show up.

       

      My question is will the icons appear even though a site has not been established on the web?

       

       

      Thank you for your time in this matter.

       

       

      L

        • 1. Re: FAVICON DOESN’T APPEAR
          hans-g. Adobe Community Professional & MVP

          Hi L,

           

          your browser must be convinced first to show It!

          Upload the favicon.ico file to your server's root directory.
          Insert this line of code between the
          <Head> </Head> tags on your home or index.html page:
          If you wish to use an animated icon too,
          upload the animated_favicon1.gif as above
          and add one of this code lines:

          <link rel="icon" href="favicon.ico" type="image/x-icon" />
          <link rel="shortcut icon" href="favicon.ico" type="image/x-icon" />
          <link rel="icon" href="pictures/favicon.ico" type="image/x-icon" />

          <link rel="icon" href="animated_favicon1.gif" type="image/gif">


          Clear ALL your caches!

          Check with another browser, the new icon will be there.

          Or:

           

          - If set, delete the bookmark to the page or re-create the bookmark.
          - Quit browser
          - Empty the Temp Internet Files Internet Options
          - Clear History
          - Delete everything in general, where the browser remembers visited sites.
          - Restart
          - Clear Site visit
          - Clear Bookmark

           

          HTH
          Hans-G.

          • 2. Re: FAVICON DOESN’T APPEAR
            shafranit

            Hi,

            I have the same problem, and I followed your instruction. Still - no favicon.

            My WS: www.anatshafran.com

             

            Thanks,

            Shafranit

            • 3. Re: FAVICON DOESN’T APPEAR
              hans-g. Adobe Community Professional & MVP

              Hi Shafranit,

               

              look at your pictures directory, there is no "favicon.ico", I only found "favicon.html"

               

              HCH

              Hans-G.

              • 4. Re: FAVICON DOESN’T APPEAR
                shafranit Level 1

                Hi,

                Thanks for being so fast!

                 

                It's really weird 'cause I can see the favicon when I'm typing http://anatshafran.com/images

                http://anatshafran.com/imagesIn my file manager in the host, I can see the file "favicon.ico" and in the source I can't see "favicon.html"

                 

                thanks again

                • 5. Re: FAVICON DOESN’T APPEAR
                  hans-g. Adobe Community Professional & MVP

                  Hi,

                   

                  I don't want to resist, but that's wrong:

                   

                  <link rel="Shortcut Icon" href="images/favicon.html" type="image/x-icon"/>, you have to refer to your favicon! Like that:

                  <link rel="Shortcut Icon" href="images/favicon.ico" type="image/x-icon"/>,

                   

                  and I can't find your favicon.ico anywhere! Copy and load it up to your imgages-subdirectory!

                   

                  Hans-G.