1 Reply Latest reply on Jun 10, 2010 10:26 PM by Flex in a Week, FiaW

    Day 4 - possible bug

    gsavkic

      In day 4 when I finish section "Use an inline item renderer" and when I try to increase/decrease NumericStepper I get exception with this message:

       

      TypeError: Error #1009: Cannot access a property or method of a null object reference.
          at mx.controls::DataGrid/createItemEditor()[E:\dev\4.0.0\frameworks\projects\framework\src\m x\controls\DataGrid.as:4325]
          at mx.controls::DataGrid/itemEditorItemEditBeginHandler()[E:\dev\4.0.0\frameworks\projects\f ramework\src\mx\controls\DataGrid.as:5237]
          at flash.events::EventDispatcher/dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at mx.core::UIComponent/dispatchEvent()[E:\dev\4.0.0\frameworks\projects\framework\src\mx\co re\UIComponent.as:12266]
          at mx.controls::DataGrid/commitEditedItemPosition()[E:\dev\4.0.0\frameworks\projects\framewo rk\src\mx\controls\DataGrid.as:4093]
          at mx.controls::DataGrid/updateDisplayList()[E:\dev\4.0.0\frameworks\projects\framework\src\ mx\controls\DataGrid.as:1804]
          at mx.controls.listClasses::ListBase/validateDisplayList()[E:\dev\4.0.0\frameworks\projects\ framework\src\mx\controls\listClasses\ListBase.as:3962]
          at mx.managers::LayoutManager/validateDisplayList()[E:\dev\4.0.0\frameworks\projects\framewo rk\src\mx\managers\LayoutManager.as:663]
          at mx.managers::LayoutManager/doPhasedInstantiation()[E:\dev\4.0.0\frameworks\projects\frame work\src\mx\managers\LayoutManager.as:736]
          at mx.managers::LayoutManager/doPhasedInstantiationCallback()[E:\dev\4.0.0\frameworks\projec ts\framework\src\mx\managers\LayoutManager.as:1072]

        • 1. Re: Day 4 - possible bug
          Flex in a Week, FiaW Level 1

          Hi Gsavkic,

           

          We ran throug the exercise with no errors.  It might be possible that you are clicking in the wrong place or missed a step which is causing the DataGrid control to have a null value.  Could you tell us exactly where you get the error (at which step to be precise)?