15 Replies Latest reply on Sep 27, 2010 3:46 PM by patrickm

    Flash Builder Premium and Create Stuite CS5 not compatible

    swflex

      Hello,

       

      After installing Create Suite CS5 Master Collection, my exisiting Flash Builder Premium becomes Flash Builder Standard. I tried to reinstall Flash Builder, but it always picks up the serial number from CS5. How to restore Flash Builder Premium? This is very frustrating.

       

      sw

        • 2. Re: Flash Builder Premium and Create Stuite CS5 not compatible
          Mayank (Adobe) Adobe Employee

          Try the following steps:

          1.  Install CS5 master collection

          2.  Launch Photoshop to activate Master Collection and then exit

          3.  Launch FB

          4.  Navigate to Help > Deactivate ... and click on the "Deactivate Permanently" button

          5.  Exit FB

          6.  Launch FB again, when prompted for a serial key, enter the FB premium key

          7.  Now launch Photoshop CS5, when prompted for a serial key enter the CS5 Master Collection key

          This should help you setup FB Premium with CS5 Master Collection.

          -mayank

          • 4. Re: Flash Builder Premium and Create Stuite CS5 not compatible
            graphex

            Wait, the CS5 Master Collection is for Flash Builder Standard, not Flash Builder Premium? I looked as hard as I could in Adobe's marketing material (and on the box of my product) and they're very unclear about which version of Flash Builder is included. Please clarify. I really hope my massive purchase has the ONE thing I really wanted - Flash Builder 4 Premium.

            • 5. Re: Flash Builder Premium and Create Stuite CS5 not compatible
              bobba1 Level 1

              No -- MC5 does not include FB4 premium, it includes FB4 standard

              • 6. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                graphex Level 1

                Oh, man, that's bad news. I feel like Adobe could do a better job with being up front about the master collection not having the top-end version of the products. Being the top-end suite product I think the average purchaser is going to be disappointed by this move. The box and product information on the website do not specify either version and it seems to be a bit of a bait-and-switch. Master collection = top end tools, not low end.

                 

                It is also noteworthy that the features you don't get with the master collection's Flash Builder 4 Standard version are things like a profiler, which helps make better products that don't use as much RAM on user's computers. That's certainly something that would seem to be in Adobe's best interest to facilitate, as they're certainly getting a bad name developed around the Flash brand for managing those things poorly. All in all, bad choice, Adobe, bad choice.

                • 7. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                  keithdvo Level 1

                  I was having this exact problem. I followed your instructions for deactivating and reactivating, and they seem to have worked, but...???...only partially?

                   

                  Now, when I launch FB Premium, it says FB Premium on the splash screen, but when I get to the start page, it says FB Standard.

                   

                  What's going on?

                  • 8. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                    bobba1 Level 1

                    Try to close the welcome screen and then re-open it ... or try and close the welcome screen, shut down FB and then reopen it.

                     

                    same thing happened to me the first couple of times I opened FB but then I resolved it this way -- I think it must be because something was cached (those screens link to a website I think??).

                     

                    Also, check your features, Do you have the premium features running (like network monitor?)

                     

                    Good luck!

                    • 9. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                      keithdvo Level 1

                      That did the trick! Thank you!!!!

                       

                      I did notice the network monitor tab, so I suspected things were looking good, but the wrong splash screen and start page were annoying even still.

                       

                      Thank you again!

                      • 10. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                        bobba1 Level 1

                        I'm glad this helped you -- great to know you're up and running!

                        • 11. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                          nbilyk Level 1

                          This is unfortunate that MC only comes with FB Standard.  Adobe also doesn't give a very good upgrade price to go to premium if you have MC; 500$.  Is there any possibility UGMs will get FB Premium keys any time soon?  

                          • 12. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                            keithdvo Level 1

                            Yeah, I have a hard time with Adobe at times. I now have four Acrobat Professional Licenses, and because they've included Flash Builder into the Suites, I have two licenses for FB. One for Flex Builder 3 Professional, and one for Flash Builder, included in the Master Collection. There was no upgrade path to Flash Builder Premium from the Master Collection, at least when I called. Since the Master Collection includes Photoshop Advanced, I hope it's not a stretch to say I think they should have included FBP as well, or certainly offered an upgrade path.

                             

                            I swear it seems like Adobe is either 1) malicious in it's upgrade policies as far as new suites and bundles and all go, or 2) are completely inept and don't stop to think about what already exists, and what the policy should be. I don't believe 1 is the case, but, come on, Adobe! Think about what your users are using, and offer sane and logical upgrade paths and options. Don't keep forcing us to end up with multiple copies or require us to buy a second license for something we have so we can upgrade via the second copy because we can't upgrade through the first. I really do believe they just don't think this through. The alternative (malicious greed), is too unpleasant to believe.

                            • 13. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                              patrickm

                              Hello all,

                               

                              I have exactly the same problem, I bought, severals months ago, a creative suite CS5 which worked fine, and then I bought au upgrade for Adobe Flash Builder 4 premium (I use the Eclipse plug-in). All worked fine.

                              But I do not know why, my Eclipse plug-in is now in standard mode

                              I try your advice

                              Mayank (Adobe) wrote:

                               

                              1.  Install CS5 master collection
                              2.  Launch Photoshop to activate Master Collection and then exit
                              3.  Launch FB
                              4.  Navigate to Help > Deactivate ... and click on the "Deactivate Permanently" button
                              5.  Exit FB
                              6.  Launch FB again, when prompted for a serial key, enter the FB premium key
                              7.  Now launch Photoshop CS5, when prompted for a serial key enter the CS5 Master Collection key

                              In step 7, when I activate PhotoShop, my Flash Builder Premium goes back to a standard edition

                               

                              Tanks a lot

                              • 14. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                                C. Agruss (Adobe) Level 3

                                Hi,

                                 

                                Is it fair to assume you've already seen this KB article, that describes the steps slightly differently:

                                http://kb2.adobe.com/cps/839/cpsid_83941.html

                                 

                                If not, that's a good place to start for FB4 Standalone (steps are easier for FB4 Plug-in). If you've already tried those steps for Standalone, and it's still not working, please let me know.

                                 

                                For FB4 Plug-in, the steps for de-activating the Standard license are a bit different:

                                - launch FB4 Plug-in, and choose Deactivate from the Help menu

                                - deactivate it permanently

                                - relaunch FB4 Plug-in, and enter your Premium SN when prompted (you might need to relaunch eclipse once or twice before the SN dialog comes up automatically).

                                 

                                The Plug-in licenses are insulated better from the Suite licenses, so you shouldn't need to re-activate the Suite at all after entering your Premium SN for Plug-in.

                                 

                                -Chris

                                • 15. Re: Flash Builder Premium and Create Stuite CS5 not compatible
                                  patrickm Level 1

                                  Thanks a lot for your help.

                                  I found at last, the solution, but it was not very simple.

                                  I am on Macintosh and I previously used the stand alone version, then after a few months I used the plug-in version with eclipse.

                                  I think, it is the beginning of the problem.

                                   

                                  When I un-installed the creative suite, I launch eclipse which run fine in Premium Edition, but the menu to remove the installation was grey.

                                  So, I install the stand alone version, and with this version, I was able to install and remove my Premium serial number.

                                   

                                  After that, I can un-install my version from the plug-in and then un-install my stand alone version and then I can use your KB article.

                                   

                                  Thanks a lot

                                   

                                  Patrick