5 Replies Latest reply on Dec 21, 2010 10:14 AM by $$VIKS$$

    Events working on one server and not the other

    Arnej6511

      We have a development and a production server for LC. I have events working on the development server that accept parameters.

       

      The services were deployed to the production server and the following error occured:

       

      2010-05-04 09:14:04,203 ERROR [STDERR] May 4, 2010 9:14:04 AM com.adobe.idp.scheduler.callback.ServiceCallbackHandler execute
      SEVERE: Exception thrown while calling back a DSC componentINVALID_CHARACTER_ERR: An invalid or illegal XML character is specified.


      2010-05-04 09:14:04,203 INFO  [org.quartz.core.JobRunShell] Job Asynchronous.SWR.RAAC.RequestSendEmail:12729788401870.18563775243350922 threw a JobExecutionException:
      org.quartz.JobExecutionException: java.lang.Exception: org.w3c.dom.DOMException: INVALID_CHARACTER_ERR: An invalid or illegal XML character is specified.

      [See nested exception: java.lang.Exception: org.w3c.dom.DOMException: INVALID_CHARACTER_ERR: An invalid or illegal XML character is specified. ]
          at com.adobe.idp.scheduler.callback.ServiceCallbackHandler.execute(ServiceCallbackHandler.ja va:102)
          at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
          at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:529)
      Caused by: java.lang.Exception: org.w3c.dom.DOMException: INVALID_CHARACTER_ERR: An invalid or illegal XML character is specified.
          at com.adobe.idp.scheduler.callback.ServiceCallbackHandler.execute(ServiceCallbackHandler.ja va:101)
          ... 2 more
      Caused by: org.w3c.dom.DOMException: INVALID_CHARACTER_ERR: An invalid or illegal XML character is specified.
          at org.apache.xerces.dom.CoreDocumentImpl.createElement(Unknown Source)
          at com.adobe.idp.event.xml.XMLGenerator.createElement(XMLGenerator.java:500)
          at com.adobe.idp.event.xml.XMLGenerator.createEventDataDocument(XMLGenerator.java:293)
          at com.adobe.idp.event.content.EventContent.createEventDataXML(EventContent.java:173)

       

       

      I took the xml from the production service and ran it through the development server, it worked fine.

       

      Any idea as to where to start the troubleshooting?

       

       

      Cheers,