1 2 3 4 Previous Next 130 Replies Latest reply on Oct 19, 2017 10:35 AM by peterl89228493

    Stop the beeping!!!

    MicahBurke Level 1

      Seems like if I have something selected and use the keyboard shortcut to zoom in, the hold space bar to get the Hand tool, Illustrator CS 5 beeps. There seems to be so much beeping in the app that I've turned my sound off.

       

      Any way to stop the beeping aside from not using the tools Illustrator gave us!?

        • 1. Re: Stop the beeping!!!
          Monika Gause Adobe Community Professional & MVP

          Maybe you have also deactivated some error warning. Please try and "reset all warnings dialogs" in Preferences. Then Illy will perhaps show you what's going wrong

          • 2. Re: Stop the beeping!!!
            MicahBurke Level 1

            Ok, tried that, still having the issue. It seems like this happens when you hold the spacebar before the screen has fully refreshed.

             

            I turned off anti-aliasing and can get Illustrator to beep continuously, simply by alt-wheel and then spacebar. Works ok in CS 4. Minor inconvience.

            • 3. Re: Stop the beeping!!!
              oranjeguice

              Uggh. Having this problem too. Incredibly annoying.

              • 4. Re: Stop the beeping!!!
                candrax

                Yeah Adobe, how do we solve/disable this annoying this in CS5?

                 

                My config CS5 Master trial and Windows 7 x64.

                • 5. Re: Stop the beeping!!!
                  oranjeguice Level 1

                  Seriously. This actually happens to me in Photoshop, Illustrator, and InDesign. Pretty annoying.

                   

                  I often hit ALT and use my mouse scroll to zoom in/out of things, then use the spacebar to move around. Now after I release ALT, the File menu is highlighted, and when I hit the spacebar I get the "ding" sound. I have to click back on the photoshop doc/artboard/page to avoid the beep.

                   

                  I didn't seem to have this problem with CS4.

                   

                  Also on Win7 64 Pro.

                  • 6. Re: Stop the beeping!!!
                    candrax Level 1

                    Yes same here - Photoshop and Illustartor Didn't try Indesign.

                     

                    Anyone found resolution for this?  I really can't stand it anymore.. Are adobe guys really testing their software before releasing it? How can they ovelook this  when it's one of the most used shortcut key combinations people use: ALT+ scroll to zoom/in out then SPACE to move.

                    • 7. Re: Stop the beeping!!!
                      MicahBurke Level 1

                      I created a movie and emailed it to the Adobe support staff. Hopefully they'll figure it out.  Seems like it may be confined to Win 7 64bit.  Which brings up the whole WHY DIDNT THEY MAKE A 64 BIT VERSION OF ILLUSTRATOR!? question.

                      • 8. Re: Stop the beeping!!!
                        Anish Singla Adobe Employee

                        This is a standard OS behaviour for Windows. This has nothing to do with Adobe Illustrator or any other adobe application. If you press Alt key the focus goes to menu bar and now if you press any key which is not a valid Keyboard shortcut for opening a menu then this beep will come. Since spacebar is not a valid key so you hear this sound.

                        you can see the same behaviour in MS Word also, press Alt key in Word and then press any invalid shortcut key like 6, you will hear this sound.

                         

                        Solution for this is to press the Esc key so that the focus goes away from the menu bar and returns to the document

                         

                        hope this helps

                        • 9. Re: Stop the beeping!!!
                          oranjeguice Level 1

                          While the ALT key does bring focus to the menu bar, I only get the beeping sound in CS5 applications.

                           

                          I tried to reproduce the beeping sound in MS Office 07, and no sound occurred. The same goes for all CS4 applications. The focus does indeed go to the menu bar, but there is no error beep.

                           

                          I just want the beep to diappear without having to press any extra keys

                          • 10. Re: Stop the beeping!!!
                            Anish Singla Adobe Employee

                            It is very well reproducible in word 2007 on my Win7 machine. I was able to reproduce even in notepad but for notepad it only beeps once and then the focus goes back to text area,

                             

                            For Word If i press Alt and then press any key say 6 then I hear the same beep and focus remains there,

                            • 11. Re: Stop the beeping!!!
                              oranjeguice Level 1

                              I can reproduce this behavior in other programs, but this is besides the point.

                               

                              CS4 didn't make the beeping. CS5 does.

                               

                              I am aware that this may be the typical behavior of Windows, but I am very used to using the Adobe programs in a specific way.

                               

                              So whatever disabled the beeping in CS4, please...bring it back!

                              1 person found this helpful
                              • 12. Re: Stop the beeping!!!
                                Anish Singla Adobe Employee

                                Your point is valid that it is a change in behaviour from CS4 but by changing this Adobe is trying to make their applications work as per the OS standards and I don't see any issues in that.

                                 

                                If this behaviour is acceptanble to you in other applications then it should be acceptable for Adobe applications also. I personally feel it more problamatic if different applications work in different ways on a typical OS than new version of an app working in different way than previous version provided new behaviour is in compliance with the other standard applications for that OS.

                                • 13. Re: Stop the beeping!!!
                                  MicahBurke Level 1

                                  No, it's not just beeping. The tools fail to work during the beeping.

                                   

                                  This is not "standard OS behaviour", for if that were the case it would do it in CS 4 and this behaviour is not acceptable in any other applications that usethe  alt-scroll wheel for zooming.

                                   

                                  I also, like orangejuice could not replicate this in Word 2007 and does not do this in Adobe Photoshop CS 4, however it IS happening in Photoshop CS5 in certain circumstances.

                                   

                                  That all said... I think you've actually explained why it is happening.  CS4 would wait for a key to be pressed with the alt key before activating the menu bar. CS5 activates it immediately.

                                   

                                  CS5 however still uses alt-scroll wheel for zooming and should not activate the menu bar until another key is pressed with it.

                                  • 14. Re: Stop the beeping!!!
                                    manuks2

                                    Hello,

                                     

                                    Just turn off the default beep sound in the Windows control panel. That worked for me.

                                     

                                    Bye

                                    • 15. Re: Stop the beeping!!!
                                      MicahBurke Level 1

                                      That doesn't actually fix anything. Firstly, I have no intention of turning off the default sounds in the control panel to fix a bug in Adobe Illustrator. Secondly, the problem is actually that the menu bar is activated by the pressing of the Alt key. This makes pressing the space bar to pull up the hand tool malfunction.

                                      • 16. Re: Stop the beeping!!!
                                        Anish Singla Adobe Employee

                                        Only solution to this is pressing the 'Esc' key if the focus has shifted to menu bar after using Alt key.

                                        • 17. Re: Stop the beeping!!!
                                          Anish Singla Adobe Employee

                                          Also in Word press and release Alt key, you will see focus in menu bar. now press some key like 6 or 7. I am able to reproduce it on all the machines I tried.

                                          • 18. Re: Stop the beeping!!!
                                            MicahBurke Level 1

                                            It doesn't matter if it happens in any other application (Word etc.)

                                             

                                            The published shortcut for zooming into an illustration in Adobe Illustrator and Photoshop is to hold the alt key and use the scroll wheel

                                             

                                            This shortcut is working properly in CS 4 in both Illustrator and Photoshop, but appears broken in CS 5.

                                             

                                            Per Adobe's instructions, I have created and sent a video demonstrating the issue.

                                             

                                            Simply put, when in Adobe Illustrator 10 - CS 4, this shortcut works properly, it is broken in CS 5.

                                            • 19. Re: Stop the beeping!!!
                                              MicahBurke Level 1

                                              Hitting ESC is not solution. This is a bug.

                                              • 20. Re: Stop the beeping!!!
                                                manuks2 Level 1

                                                Of course it´s not a solution, but for now I find it´s  the best workaround out there, certainly better than muting all sounds by turning off the speakers or having to hit another key (esc or alt again) every time we want to zoom and pan, which is too ofen.

                                                 

                                                In my case I dont have any problem with the zoom tool, just the beeping. I can even hold the  alt key while panning with the spacebar with no problem.

                                                • 21. Re: Stop the beeping!!!
                                                  Wade_Zimmerman Level 6

                                                  Not necessarily a bug but as pointed out a necessity. Consider that Illustrator CS 4 and CS 5 are no longer quite the same and do not necessarily follow the same rules,which are established by the developer of the OS.

                                                   

                                                  Where as if CS 4 works in this regards and causes no problems that might not be true for CS 5 and CS 5 might have to be this way in order for ti to function better with Windows 7 or earlier versions of Windows. Doesn't however mean there is not something Adobe can do about.

                                                   

                                                  It might be that in the past Adobe was able to deactivate this behavior  but while writing CS 5 it was no longer allowed if they want to move forward. However dies not mean they cannot find an alternative mechanism.

                                                   

                                                  Reasonable to ask fr them to look at the issue but don't be surprised if they cannot do anything about it, but you should do something folow this link:

                                                   

                                                  https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

                                                  • 22. SOLUTION: (temporarily)
                                                    ugur_koban

                                                    yes! i hated this problem and because of my habit i couldn't use PS,Ai,...

                                                     

                                                    here is my solution and i use this until Adobe find something about this issue. This bug is very important but i can't understand how they overlook this bug.

                                                     

                                                     

                                                     

                                                     

                                                    firstly download this: http://webpages.charter.net/krumsick/KeyTweak_install.exe

                                                     

                                                    it changes the keyboard keys.

                                                     

                                                    change left alt key with right alt key.

                                                     

                                                    that's all... now you can zoom in and after this you could press space without hearing beep or working problem.

                                                    • 23. Re: SOLUTION: (temporarily)
                                                      infested-rat

                                                      Does anybody have an alternative link to the tool or could please upload it again somewhere?

                                                      Thanks!

                                                       

                                                      http://download.chip.eu/en/KeyTweak-2.3.0_1325540.html

                                                      • 24. Re: Stop the beeping!!!
                                                        karenskelly

                                                        I am using CS5 standard edition on windows vista 64 bit.  I get beeping when I use keyboard shortcuts for things like enlarging and reducing the size of brushes using the bracket keys, when I use the x key to change from black to white and back again, and on other things like that.  How do I stop that?

                                                        Thanks, Karen

                                                        • 25. Re: Stop the beeping!!!
                                                          anse1208

                                                          My solution is just hold the spacebar down 1st while pressing the alt key problem solved, I know it is different then what we all are use to doing but it work's and it's a heck of alot faster than reaching over to press the ESC key all the time.( that kills productivity time.) LOL

                                                          • 26. ?
                                                            ugur_koban Level 1

                                                            there is a program  http://www.autohotkey.com/download/AutoHotkeyInstall.exe

                                                             

                                                            i ve tried to add this line  ~LAlt::~LAlt but it didn't work perfectly.

                                                             

                                                            maybe you can solve this program (because it is english i couldn't) to help the solution.

                                                            • 27. Re: Stop the beeping!!!
                                                              hotLunch2000 Level 1

                                                              I just tried installing Photoshop CS5 today and have been getting this error.  It's incredibly annoying to not be able to move and zoom using alt, spacebar, and the mousewheel without hearing that crazy ding sound.  I like to listen to music while I work, so I'm not about to mute all sound just because of this one thing.  I know it's nothing wrong on my end, as I'm a Maya user first and foremost, and I have to use alt and other keys to navigate the UI in there all the time.

                                                               

                                                              I'll just stick with CS4 for now I guess... It's a shame, I really like some of the new features (paste in place should have been implemented years ago), but I can't stand the constant dinging sound.  It's so stupid that a bug like this could make it all the way to retail.  

                                                              • 28. Re: Stop the beeping!!!
                                                                oranjeguice Level 1

                                                                This issue is still plaguing me. So annoying.

                                                                 

                                                                Maybe everyone can fill out an "Adobe Wish" request below, and who knows, maybe it'll catch someone's eye.

                                                                 

                                                                https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

                                                                • 29. Re: Stop the beeping!!!
                                                                  Paevo Kelley Level 2

                                                                  Beep be bee beep beep beep be beep...

                                                                  • 30. Re: Stop the beeping!!!
                                                                    Matthew Laun Adobe Employee

                                                                    I may not fully understand the steps users are doing here, so I appologize if this doesn't work. I find that if I simply press the space bar first, then press alt, I can operate the hand tool without any issues. Likewise for most every other function. Also, checking to see if the menu bar has a menu activated allows me to hit alt to deactivate it then press other key combinations and avoid the beeping. I'd have to say this is hard to call a bug when it's matching the behavior of every Microsoft application I've tested. I think some change to be more in compliance with using standard MS APIs may explain the change from CS4 to CS5.

                                                                    1 person found this helpful
                                                                    • 31. Re: Stop the beeping!!!
                                                                      oranjeguice Level 1

                                                                      What the majority of people complaining in this thread are doing is using ALT + Scrollwheel as their primary way of zooming in and out of documents. After scrolling, they use the Spacebar to re-position the document.

                                                                       

                                                                      Pressing the Spacebar first unfortunately is not an option--after "ALT + Scrolling", the document needs to be repositioned again.

                                                                       

                                                                      What's nice about this is that the user does not have to switch tools when wanting to zoom in/out of a doc. It's a timesaver. Now, unfortunately, you have to click on the pasteboard, or like you said, press ALT once again to avoid the beeping.

                                                                       

                                                                      While this happens in many other Windows programs, it was awesome that this didn't occur in CS3 and CS4 (possibly even CS2 and earlier). I can see that Adobe would want their programs to be as compliant with MS APIs as possible--but then why even leave the ALT + Scrollwheel functionality if it is clearly annoying to use? Nobody wants to hear a "ding" every time they use an actual feature of the software. Regardless if this is common in other Windows software--this was a good feature and now it is difficult to use.

                                                                       

                                                                      Nothing like this occurs on the OSX version of CS5. I often switch between both systems, and it's annoying that I will have to use the two differently, or disrupt my workflow and get used to a different way of zooming.

                                                                       

                                                                      I would just like an official explanation. I would absolutely LOVE if they could fix this issue.

                                                                      • 32. Re: Stop the beeping!!!
                                                                        Matthew Laun Adobe Employee

                                                                        I see. A quick fix would be to always hit alt twice before using the scroll wheel to zoom. I'm installing CS4 on my windows box to take a look and better understand what changed. More soon...

                                                                         

                                                                        Matthew

                                                                        1 person found this helpful
                                                                        • 33. Re: Stop the beeping!!!
                                                                          oranjeguice Level 1

                                                                          And also, I'd like to ask what the benefits of standardizing the ALT functionality are. Why even change it? Did Adobe have no choice? Were there users complaining about ALT NOT accessing the menus?

                                                                          • 34. Re: Stop the beeping!!!
                                                                            hotLunch2000 Level 1

                                                                            oranjeguice hit the nail on the head with his description here.  It is possible to not hear the beep if you double tap alt every time, but that shouldn't be necessary in the fist place, it's still an extra annoying step to circumvent a problem that wasn't there before. 

                                                                             

                                                                            Also, Paevo Kelley, is... is that some Architecture in Helsinki?

                                                                            • 35. Re: Stop the beeping!!!
                                                                              Architrion

                                                                              Two things to consider:

                                                                              1.- Adobe can't use windows standards for one thing, and forget about them for others. I mean, standard zoom keys for windows apps is Ctrl + Mouse wheel, not Alt + Mouse wheel. I had to remap my brain to use the later in each and every adobe app (although whole windows maps uses Ctrl + Wheel). And now I found I need to remap again to go around what is not but a bug from Adobe.

                                                                               

                                                                              2.- Zoom worked nice and clean on CS4. No need to change a coma. What I'm doing now is clicking an empty space on the work area after the Alt+Wheel zoom. But I'm pretty sure that to program a patch to bring back previous Alt+key, or either, use windows standard Ctrl + key is not a great challenge for those fantastics genius under Adobe headquarters.

                                                                              • 36. Re: Stop the beeping!!!
                                                                                MicahBurke Level 1

                                                                                I would still call this a bug, even if it's not the Windows standard. Adobe has used this configuration for years and now there's a change in how it works? This is still the most annoying issue since I installed CS5.

                                                                                • 37. Re: Stop the beeping!!!
                                                                                  Architrion Level 1

                                                                                  My english is not the perfect stuff I would like, so maybe I said it badly, I call it a bug. But I read up there that it was done to adjust CS5 to windows standards. Not, my lord. Windows standard for zooming is Ctrl + Wheel. I'm already adjusted to CS4 and previous Alt + Wheel zoom, and it's perfect for me, even though when I go to Office, Openoffice or whatever stuff I have to switch back to windows standards.

                                                                                  • 38. Re: Stop the beeping!!!
                                                                                    unique_jb

                                                                                    I just wanted to chime in here and say I'm having exactly the same problem. I use alt scroll-wheel all the time to zoom in/out and now, what happens is when I'm done, it activates the file menu. When I go to use other keyboard shortcuts, it activates file menus rather than the tools which I want, which either beeps, or does the wrong thing, which indeed is quite annoying.

                                                                                     

                                                                                    the best solution I've seen here is to hit alt twice when using the scrole wheel, so that the "state" of the keyboard menu activation is always off. The essential problem is that the alt key toggles the state of the menu activation, but then when you use the scroll wheel without using the menus, the state is still toggled, so hitting alt again (or hitting esc) is necessary to toggle back to the non file menu state.

                                                                                     

                                                                                    It'd be great (and I think still windows compatible) if there was an option to say something like "never activate keyboard menu mode and only allow keystrokes to correspond to tools".

                                                                                     

                                                                                    In the mean time, I think the double alt solution is the best I've heard for now.

                                                                                    • 39. Re: Stop the beeping!!!
                                                                                      Pacoan-wZPMMm Level 1

                                                                                      Using Illustrator in Fullscreen mode disables the beeping. Although, it also disables any menu access through the alt key. I wonder if actual Illustrator users develop the software, this is no brainer stuff.

                                                                                      1 2 3 4 Previous Next