3 Replies Latest reply on May 12, 2010 9:23 AM by vestigefilmworks

    After Effects 9.0.2 crashes at launch on OS X 10.6.3

    vestigefilmworks

      I installed After Effects CS4 a couple of months ago, and everything was working fine. Then today, it wouldn't launch at all. It got to "Initializing Type Engine..." and then crashed with the following message:

      Screen shot 2010-05-06 at 3.46.14 PM.PNG

       

      The OS X error report is as follows:

       

       

      Process:         After Effects [1043]

      Path:            /Applications/Media/Adobe After Effects CS4/Adobe After Effects CS4.app/Contents/MacOS/After Effects

      Identifier:      com.adobe.AfterEffects

      Version:         9.0.2 (9.0.2)

      Code Type:       X86 (Native)

      Parent Process:  launchd [233]

       

      Date/Time:       2010-05-06 16:29:40.930 -0500

      OS Version:      Mac OS X 10.6.3 (10D573)

      Report Version:  6

       

      Interval Since Last Report:          286357 sec

      Crashes Since Last Report:           24

      Per-App Interval Since Last Report:  313511 sec

      Per-App Crashes Since Last Report:   20

      Anonymous UUID:                      CB4DAD58-94D2-4E1C-B4C5-2F2C69A89324

       

      Exception Type:  EXC_CRASH (SIGABRT)

      Exception Codes: 0x0000000000000000, 0x0000000000000000

      Crashed Thread:  21

       

      Application Specific Information:

      abort() called

       

       

      [.........]

       

      Thread 21 Crashed:

      0   libSystem.B.dylib             0x957b14be __semwait_signal_nocancel + 10

      1   libSystem.B.dylib             0x957b13a2 nanosleep$NOCANCEL$UNIX2003 + 166

      2   libSystem.B.dylib             0x9582c2f2 usleep$NOCANCEL$UNIX2003 + 61

      3   libSystem.B.dylib             0x9584d9a8 abort + 105

      4   U.dylib                       0x02581141 U_LoadFrameworkBundle + 593

      5   libSystem.B.dylib             0x957aa42b _sigtramp + 43

      6   ???                           0x0000000a 0 + 10

      7   com.apple.DesktopServices     0x97a87ed9 TCopyQueue::ReportStatus(OperationStatus const&, TUString const&, TCountedPtr<TCFURLInfo> const&, bool) + 257

      8   com.apple.DesktopServices     0x97a87afa TCopyWriter::ReportStatus(bool) + 146

      9   com.apple.DesktopServices     0x97a8456b TCopyWriter::Write() + 735

      10  com.apple.DesktopServices     0x97a83c25 TCopyWriter::WriteTaskProc(void*) + 75

      11  ...ple.CoreServices.CarbonCore 0x90932eb6 PrivateMPEntryPoint + 68

      12  libSystem.B.dylib             0x95771a19 _pthread_start + 345

      13  libSystem.B.dylib             0x9577189e thread_start + 34

       

      Thread 21 crashed with X86 Thread State (32-bit):

        eax: 0x0000003c  ebx: 0x957b1309  ecx: 0xb0b0561c  edx: 0x957b14be

        edi: 0xb0b056d0  esi: 0xb0b05678  ebp: 0xb0b05658  esp: 0xb0b0561c

         ss: 0x0000001f  efl: 0x00000247  eip: 0x957b14be   cs: 0x00000007

         ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037

        cr2: 0x0babf000

      It gives me the same error each time. I've tried all the usual tricks: deleting caches, preferences, repairing permissions, trying as different users (including a band new user). I also uninstalled and reinstalled the software, and it threw the same error. In perusing the forums, it looked like someone else had a similar issue, but it was a Windows specific fix, and I couldn't figure out how to port that to the Mac. I figured I'd have more luck on the forums after wasting an hour and half on the phone with Adobe, and still not even connected to the right department.
      Also, I validated all my fonts with Font Book (since it seemed like it could be a font problem). It found 3 fonts with "serious errors", but I removed them and the problem persisted.
      Any and all help is appreciated.
      Thanks,
      Sam
        • 1. UPDATE: After Effects 9.0.2 crashes at launch on OS X 10.6.3
          vestigefilmworks Level 1

          After 10 hours of troubleshooting, I've gotten AE to start in Safe Mode. I've tried disabling/deleting color profiles, fonts, QuickTime components, all to no avail. I've cleaned all the caches, etc. etc. In reading Apple's support document on Safe Boot/Safe Mode (http://support.apple.com/kb/ht1564), my best guess is that it's a faulty kernel extension, or a faulty startup item. I've tried disabling all the login items, but since it's crashing on a brand new user account as well, my guess is it is not a login item. I've updated all the drivers for my peripherals.

           

          Multiple uninstalls (using Adobe uninstaller, and double checking with Adobe cleaner script) and reinstalls have not changed the behavior: AE starts in Safe Mode, not in normal mode.

           

          Any advice on figuring out exactly what extension/item is faulty?

          • 2. Re: UPDATE: After Effects 9.0.2 crashes at launch on OS X 10.6.3
            Mylenium Most Valuable Participant

            I'm sorry, I can't help you with any of that, since I never bothered to upgrade to 10.6. With such geeky errors you may have better luck opening a support case and filing the logs, anyway.

             

            Mylenium

            • 3. SOLVED: After Effects 9.0.2 crashes at launch on OS X 10.6.3
              vestigefilmworks Level 1

              Well, I finally did the smart thing and created a new partition to make sure that it would work starting from a clean install. After putting 10.6 on it, and installing AE, After Effects worked perfectly. So I went through the system updates. After 10.6.3 was installed, AE crashed with the same message. On a brand new install, with no other extensions or applications beyond the default. So I scanned the kexts (based on earlier success launcing AE in safe mode), and noticed that the 10.6.3 update removed an extension labelled "GeForce8xxxGLDriver.bundle" and added one called "GeForceGLDriver.bundle". I'm running the 8800GT card on the MacPro3,1. Now, I have no idea if this particular extension is the source of the problem, but my limited developer knowledge leads me to believe it could be.

               

              I'm curious if there is anyone out there successfully using AE CS4 with 10.6.3 on an 8800GT.

               

              Good times,

              Sam