0 Replies Latest reply on May 7, 2010 9:33 AM by treehuggerinny

    swfs not displaying in IE, using SWFObject2

    treehuggerinny Level 1

      Hi,

       

      I have a site I did a couple years ago, and have had to open it up, and now none of the SWFs display in IE. In my template I deleted my old Flash nav and reinserted it (insert/media/swf) and then I got a white box where the navigation should be.

       

      I've tried going to the Google site and got sample code for SWFObject2, I uploaded the swfobject.js and expressinstall.swf to the site's root directory, but I still get a white box in IE. It works fine in Firefox and Chrome.

       

      What am I doing wrong?

       

      I really appreciate your help.

       

      Take a look at this page: http://stagerightorg.com/resources/articles2.aspx

      I'm using DW CS4 on a PC.

       

      I've bolded changed code:

       

      <%@LANGUAGE="VBSCRIPT"%>

      <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

      <html><!-- InstanceBegin template="/Templates/asppage.dwt.asp" codeOutsideHTMLIsLocked="false" -->

      <head>

       

      <meta http-equiv="Content-Type" content="text/html; charset=utf-8">

      <!-- InstanceBeginEditable name="doctitle" -->

      <title>Stage Right!</title>

      <!-- InstanceEndEditable -->

      <!-- InstanceBeginEditable name="head" -->

      <!-- InstanceEndEditable -->

      <link href="/main.css" rel="stylesheet" type="text/css">

      <link rel="shortcut icon" href="favicon.ico">

      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

      <script type="text/javascript" src="swfobject.js"></script>

      <script type="text/javascript">

      swfobject.registerObject("myId", "7.0.0", "expressInstall.swf");

      </script>

      <script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>

      </head>

      <body>

      <table width="749" border="0" align="center" cellpadding="0" cellspacing="0" bgcolor="#004159">

        <tr>

          <td>

       

      <!-- InstanceBeginEditable name="main" -->

       

            <table width="100%"  border="0" cellpadding="0" cellspacing="0" bgcolor="#009530">

              <tr>

                <td>

       

                <table width="749" border="0" cellspacing="0" cellpadding="0">

                    <tr>

                      <td colspan="2"><img src="/flash/top.jpg" width="749" height="141"></td>

                    </tr>

                    <tr>

                      <td width="156" align="left" valign="top" background="/images/bpondlownav.jpg">

      <object id="myId" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="156" height="358">

      <param name="movie" value="/flash/nav.swf" />

              <!--[if !IE]>-->

      <object type="application/x-shockwave-flash" data="/flash/nav.swf" width="156" height="358">

      <!--<![endif]-->

      <div>

      <h1>You will have a richer experience on this site if you download Flash</h1>

      <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" /></a></p>

      </div>

      <!--[if !IE]>-->

      </object>

      <!--<![endif]-->

      </object>

                  </td>

       

       

      and it goes on...