1 Reply Latest reply on Jun 1, 2010 11:14 PM by nishadmusthafa

    FB4 & FlexUnit4 library version dependencies

    AlucinariOlim

      Hi there,

       

      I'm a user of Flash Builder 4 and think it is great.  I like to stay up to date with the latest available libraries for all my projects and noticed that FB4 comes with the following FlexUnit1/FlexUnit4 libs built in:

       

      flexunit_0.9.swc

      hamcrest-1.0.2.swc

      flexunit-core-flex-4.0.0.2-sdk3.5.0.12683.swc

      flexunitextended.swc

      FlexUnitTestRunner_rb.swc

       

      I'm curious to know if the contents of these libs have been tailored to support the FB4 FlexUnit4 eclipse views.  In keeping up to date, I'd like to be able to swap out the old and usher in the new builds if possible.  If swapping out all the libs will cause problems, are there any that can be updated w/o issues?

       

      Thanks.

        • 1. Re: FB4 & FlexUnit4 library version dependencies
          nishadmusthafa

          Hi,

           

          The libs can be swapped without any issues. Just replace the libraries with the newer version in the current location.

           

          flexunitextended.swc  is autogenerated. Hence you needn't replace that. The other four have to be.

           


          What exactly did u mean by " FB4 FlexUnit4 eclipse views". Did u mean as opposed to the browser view? Then yes both flexUnit1 and FlexUnit 4 have that functionality. Do reply if you have queries.

           

          Nishad